aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 18:29:12 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-10 18:29:12 +0000
commit0a52b6abcfe917dbb9b39514b1d2d5dc0d50a8de (patch)
treec8575b4e8de296d19969edb80e5429f5eadc9f9e /lang
parent64be746e535b0ca620460c95a819b81ac2159d01 (diff)
downloadports-0a52b6abcfe917dbb9b39514b1d2d5dc0d50a8de.tar.gz
ports-0a52b6abcfe917dbb9b39514b1d2d5dc0d50a8de.zip
lang/ocaml: fix build on powerpc
Use ld.bfd: ld: error: can't create dynamic relocation R_PPC_ADDR16_LO against symbol: caml_last_return_address in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
Diffstat (limited to 'lang')
-rw-r--r--lang/ocaml/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 3c0c8335af3a..9eb9faca8621 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -71,6 +71,8 @@ PLIST_SUB+= DOC="@comment "
.if ${ARCH} == armv6 || ${ARCH} == armv7
CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS} -meabi=5"
+.elif ${ARCH} == powerpc
+LLD_UNSAFE= yes
.else
CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
.endif