aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2013-06-16 14:13:25 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2013-06-16 14:13:25 +0000
commit1cfeb1945a16d6e7056f038fa8417faf5fd3b1ce (patch)
treec71c30d4bd1d88700d0a7dc06b302e7166996a7c /lang
parent50ca6b816699ba8c35c57689baf0e3ba42caa479 (diff)
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index c937a86812e0..c1bb8c53957d 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 4.6.3
CATEGORIES= lang java
MASTER_SITES= ${MASTER_SITE_GCC}
MASTER_SITE_SUBDIR= releases/gcc-${VERSIONSTRING}
-DISTNAME= gcc-${VERSIONSTRING}
MAINTAINER= gerald@FreeBSD.org
COMMENT= GNU Compiler Collection 4.6
@@ -39,10 +38,12 @@ MAKE_JOBS_SAFE= yes
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
+OPTIONS_DEFINE= BOOTSTRAP
OPTIONS_DEFINE_i386= JAVA
OPTIONS_DEFINE_amd64= JAVA
OPTIONS_DEFAULT_i386= JAVA
OPTIONS_DEFAULT_amd64= JAVA
+BOOTSTRAP_DESC= Build using a full bootstrap
.include <bsd.port.pre.mk>
@@ -59,8 +60,12 @@ TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ARGS+=--disable-bootstrap \
- --disable-nls \
+.if empty(PORT_OPTIONS:MBOOTSTRAP)
+CONFIGURE_ARGS+=--disable-bootstrap
+.else
+ALL_TARGET= bootstrap-lean
+.endif
+CONFIGURE_ARGS+=--disable-nls \
--libdir=${TARGLIB} \
--libexecdir=${LIBEXEC} \
--program-suffix=${SUFFIX} \