aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-04-17 16:52:17 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-04-17 16:52:17 +0000
commit1fea71bce458e843c8d044a7c52b7292faeef039 (patch)
treef00585328808e06b8e7c0923b27a4200fe2a445f /lang
parentdc21c7d629a7c2b9021e0d82f0e8430f6fb0705f (diff)
downloadports-1fea71bce458e843c8d044a7c52b7292faeef039.tar.gz
ports-1fea71bce458e843c8d044a7c52b7292faeef039.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/J/Makefile6
-rw-r--r--lang/J/distinfo6
-rw-r--r--lang/J/files/patch-Makefile10
-rw-r--r--lang/J/files/patch-jlibrary_system_config_base.cfg4
-rw-r--r--lang/J/files/patch-jlibrary_system_main_regex.ijs6
-rw-r--r--lang/J/files/patch-jlibrary_system_main_stdlib.ijs20
-rw-r--r--lang/J/files/patch-jsrc_jeload.c11
-rw-r--r--lang/J/files/patch-make_build__jconsole.sh8
-rw-r--r--lang/J/files/patch-make_build__jdll.sh54
-rw-r--r--lang/J/files/patch-make_build__libj.sh71
-rw-r--r--lang/J/files/patch-make_build__tsdll.sh4
-rw-r--r--lang/J/files/patch-make_domake.sh10
-rw-r--r--lang/J/files/patch-make_jvars.sh4
-rw-r--r--lang/J/files/patch-make_makefile12
-rw-r--r--lang/J/files/patch-netdefs_netdefs.c16
-rw-r--r--lang/J/pkg-plist13
16 files changed, 73 insertions, 182 deletions
diff --git a/lang/J/Makefile b/lang/J/Makefile
index 20ce9a406f17..5766faea6235 100644
--- a/lang/J/Makefile
+++ b/lang/J/Makefile
@@ -8,7 +8,7 @@ MAINTAINER= sevenjp@gmail.com
COMMENT= J programming language
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/jsource-j806-release/license.txt
+LICENSE_FILE= ${WRKDIR}/jsource-${JVERSION}/license.txt
ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON_amd64= Not built or tested for other archs. i386 needs hostdefs and netdefs files to be generated.
@@ -28,10 +28,10 @@ GH_PROJECT= jsource
GH_TAGNAME= ${JVERSION}
# J is released with ports-unfriendly versioning
-JVERSION= j806-release
+JVERSION= j808-release
BIN_FILES= jconsole
-LIB_FILES= libj.so libtsdll.so libjavx.so
+LIB_FILES= libj.so libtsdll.so
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib/j/bin
diff --git a/lang/J/distinfo b/lang/J/distinfo
index 15e01277e20c..a0ad4143d598 100644
--- a/lang/J/distinfo
+++ b/lang/J/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1519502511
-SHA256 (jsoftware-jsource-806-j806-release_GH0.tar.gz) = 033a787ad3180a8ead8f4a3880c016b8581ddf6a3081f86a88774575c7cc168f
-SIZE (jsoftware-jsource-806-j806-release_GH0.tar.gz) = 2280551
+TIMESTAMP = 1520449029
+SHA256 (jsoftware-jsource-808-j808-release_GH0.tar.gz) = 1c7335e0d705bfc630da230ee8d196487627eed6f9374728bcac6b9ffbb1fd1d
+SIZE (jsoftware-jsource-808-j808-release_GH0.tar.gz) = 2128876
diff --git a/lang/J/files/patch-Makefile b/lang/J/files/patch-Makefile
index 5e6360acd4ea..3d78596e1887 100644
--- a/lang/J/files/patch-Makefile
+++ b/lang/J/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2018-02-24 19:49:42 UTC
+--- Makefile.orig 2018-04-09 18:07:38 UTC
+++ Makefile
-@@ -0,0 +1,25 @@
+@@ -0,0 +1,21 @@
+.PHONY: all
+all: make-${ARCH}
+
+.PHONY: make-amd64
-+make-amd64: build-j64 libj-avx
++make-amd64: build-j64
+
+.PHONY: make-i386
+make-i386: build-j32
@@ -14,10 +14,6 @@
+init:
+ make/install.sh
+
-+.PHONY: libj-avx
-+libj-avx: init
-+ make/build_libj.sh j64avx
-+
+build-%: init
+ make/build_jconsole.sh $*
+ make/build_libj.sh $*
diff --git a/lang/J/files/patch-jlibrary_system_config_base.cfg b/lang/J/files/patch-jlibrary_system_config_base.cfg
index 75e203ab35ad..3570bb64a0f5 100644
--- a/lang/J/files/patch-jlibrary_system_config_base.cfg
+++ b/lang/J/files/patch-jlibrary_system_config_base.cfg
@@ -1,6 +1,6 @@
---- jlibrary/system/config/base.cfg.orig 2018-02-22 18:45:28 UTC
+--- jlibrary/system/config/base.cfg.orig 2016-11-25 19:04:24 UTC
+++ jlibrary/system/config/base.cfg
-@@ -90,6 +90,18 @@ case. 'Linux' do.
+@@ -93,6 +93,18 @@ case. 'Linux' do.
XDiff=: '/usr/bin/meld'
Editor=: 'geany +%l %f'
Editor_nox=: 'vi -c%l %f'
diff --git a/lang/J/files/patch-jlibrary_system_main_regex.ijs b/lang/J/files/patch-jlibrary_system_main_regex.ijs
index fa4915aeefa2..f93061a5bf9a 100644
--- a/lang/J/files/patch-jlibrary_system_main_regex.ijs
+++ b/lang/J/files/patch-jlibrary_system_main_regex.ijs
@@ -1,10 +1,10 @@
---- jlibrary/system/main/regex.ijs.orig 2018-02-22 18:45:28 UTC
+--- jlibrary/system/main/regex.ijs.orig 2018-03-07 18:59:01 UTC
+++ jlibrary/system/main/regex.ijs
@@ -101,6 +101,7 @@ NB. rxdll is in bin or tools/regex
select. UNAME
case. 'Win' do. t=. 'jpcre.dll'
case. 'Darwin' do. t=. 'libjpcre.dylib'
-+case. 'FreeBSD' do. t=. 'libpcreposix.so'
- fcase. 'Linux' do. NB. fall throught
++case. 'FreeBSD' do. t=. 'libpcreposix.so'
+ fcase. 'Linux' do.
if. 2 0-:('libpcreposix.so.3 dummyfunction n')&(15!:0) ::(15!:10) '' do.
rxdll=: 'libpcreposix.so.3'
diff --git a/lang/J/files/patch-jlibrary_system_main_stdlib.ijs b/lang/J/files/patch-jlibrary_system_main_stdlib.ijs
index 6d14e7aafb05..5ec733fb90cb 100644
--- a/lang/J/files/patch-jlibrary_system_main_stdlib.ijs
+++ b/lang/J/files/patch-jlibrary_system_main_stdlib.ijs
@@ -1,14 +1,6 @@
---- jlibrary/system/main/stdlib.ijs.orig 2018-02-22 18:45:28 UTC
+--- jlibrary/system/main/stdlib.ijs.orig 2016-11-25 19:04:24 UTC
+++ jlibrary/system/main/stdlib.ijs
-@@ -35,6 +35,7 @@ if. notdef 'UNAME' do.
- end.
- end.
- 'libc.so.6 setlocale > x i *c'&(15!:0)^:(UNAME-:'Linux') 1;,'C'
-+'libc.so.7 setlocale > x i *c'&(15!:0)^:(UNAME-:'FreeBSD') 1;,'C'
- if. notdef 'IFRASPI' do.
- if. UNAME -: 'Linux' do.
- cpu=. 2!:0 'cat /proc/cpuinfo'
-@@ -97,6 +98,7 @@ if. (<'home') -.@e. {."1 SystemFolders d
+@@ -93,6 +93,7 @@ if. (<'home') -.@e. {."1 SystemFolders d
elseif. 'Android'-:UNAME do. t=. '/sdcard'
elseif. 'Darwin'-:UNAME do. t=. (0-:t){::'';~t=. 2!:5'HOME'
elseif. 'Linux'-:UNAME do. t=. (0-:t){::'';~t=. 2!:5'HOME'
@@ -16,7 +8,7 @@
elseif. do. t=. ''
end.
if. (''-:t)+.((,'/')-:t)+.('/root'-:t)+.('/usr/'-:5{.t) do.
-@@ -111,6 +113,7 @@ if. (<'temp') -.@e. {."1 SystemFolders d
+@@ -107,6 +108,7 @@ if. (<'temp') -.@e. {."1 SystemFolders d
elseif. 'Android'-:UNAME do. t=. '/sdcard'
elseif. 'Darwin'-:UNAME do. 1!:5 ::] <t=. '/tmp/',":2!:6''
elseif. 'Linux'-:UNAME do. 1!:5 ::] <t=. '/tmp/',":2!:6''
@@ -24,7 +16,7 @@
elseif. do. t=. ''
end.
SystemFolders=: SystemFolders, 'temp';t
-@@ -123,14 +126,14 @@ end.
+@@ -119,14 +121,14 @@ end.
18!:4 <'z'
18!:4 <'z'
UNXLIB=: ([: <;._1 ' ',]);._2 (0 : 0)
@@ -44,8 +36,8 @@
(<r,c) {:: UNXLIB_z_
)
18!:4 <'z'
-@@ -1344,7 +1347,7 @@ require 'pacman'
- x do_install_jpacman_ y
+@@ -1337,7 +1339,7 @@ require 'pacman'
+ do_install_jpacman_ y
)
getqtbin=: 3 : 0
-if. (<UNAME) -.@e. 'Linux';'Darwin';'Win' do. return. end.
diff --git a/lang/J/files/patch-jsrc_jeload.c b/lang/J/files/patch-jsrc_jeload.c
deleted file mode 100644
index 2d22116012ad..000000000000
--- a/lang/J/files/patch-jsrc_jeload.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- jsrc/jeload.c.orig 2018-02-22 18:45:28 UTC
-+++ jsrc/jeload.c
-@@ -322,6 +322,8 @@ int jefirst(int type,char* arg)
- strcat(input,"[UNAME_z_=:'Win'");
- #elif defined(__MACH__)
- strcat(input,"[UNAME_z_=:'Darwin'");
-+#elif defined(__FreeBSD__)
-+ strcat(input,"[UNAME_z_=:'FreeBSD'");
- #elif !defined(ANDROID)
- strcat(input,"[UNAME_z_=:'Linux'");
- #endif
diff --git a/lang/J/files/patch-make_build__jconsole.sh b/lang/J/files/patch-make_build__jconsole.sh
index 8a29ab13bba1..4de9eafb7eef 100644
--- a/lang/J/files/patch-make_build__jconsole.sh
+++ b/lang/J/files/patch-make_build__jconsole.sh
@@ -1,4 +1,4 @@
---- make/build_jconsole.sh.orig 2018-02-24 19:49:42 UTC
+--- make/build_jconsole.sh.orig 2018-04-09 17:54:22 UTC
+++ make/build_jconsole.sh
@@ -1,9 +1,8 @@
#!/usr/local/bin/bash
@@ -7,12 +7,12 @@
-. jvars.sh
+. make/jvars.sh
--common=" -fPIC -O1 -Wextra -Wno-unused-parameter "
-+common=" -fPIC -Wextra -Wno-unused-parameter "
+-common=" -fPIC -O1 -Wextra "
++common=" -fPIC -Wextra "
case $jplatform\_$1 in
-@@ -31,6 +30,14 @@ darwin_j64)
+@@ -27,6 +26,14 @@ darwin_j64)
COMPILE="$common -DREADLINE -mmacosx-version-min=10.5"
LINK=" -ledit -ldl -lncurses -mmacosx-version-min=10.5 -o jconsole "
;;
diff --git a/lang/J/files/patch-make_build__jdll.sh b/lang/J/files/patch-make_build__jdll.sh
deleted file mode 100644
index 5b89d7053bd3..000000000000
--- a/lang/J/files/patch-make_build__jdll.sh
+++ /dev/null
@@ -1,54 +0,0 @@
---- make/build_jdll.sh.orig 2018-02-24 19:49:42 UTC
-+++ make/build_jdll.sh
-@@ -1,7 +1,6 @@
- #!/usr/local/bin/bash
- # $1 is j32 or j64
--cd ~
--. jvars.sh
-+. make/jvars.sh
-
- # gcc 5 vs 4 - killing off linux asm routines (overflow detection)
- # new fast code uses builtins not available in gcc 4
-@@ -37,10 +36,10 @@ fi
-
- if [ "x$COMPILER" = x'gcc' ] ; then
- # gcc
--common="$OPENMP -fPIC -O1 -fwrapv -fno-strict-aliasing -Wextra -Wno-maybe-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-clobbered -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-shift-negative-value"
-+common="$OPENMP -fPIC -fwrapv -fno-strict-aliasing -Wextra -Wno-maybe-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-clobbered -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-shift-negative-value"
- else
- # clang 3.5 .. 5.0
--common="$OPENMP -Werror -fPIC -O1 -fwrapv -fno-strict-aliasing -Wextra -Wno-consumed -Wno-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-unsequenced -Wno-string-plus-int"
-+common="$OPENMP -Werror -fPIC -fwrapv -fno-strict-aliasing -Wextra -Wno-consumed -Wno-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-unsequenced -Wno-string-plus-int"
- fi
- darwin="$OPENMP -fPIC -O1 -fwrapv -fno-strict-aliasing -Wno-string-plus-int -Wno-empty-body -Wno-unsequenced -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-return-type -Wno-constant-logical-operand -Wno-comment -Wno-unsequenced"
-
-@@ -101,6 +100,29 @@ LINK=" -dynamiclib -lm -ldl $LDOPENMP -m
- OBJS_FMA=" blis/gemm_int-fma.o "
- ;;
-
-+freebsd_j32) # freebsd x86
-+TARGET=libj.so
-+# faster, but sse2 not available for 32-bit amd cpu
-+# sse does not support mfpmath=sse in 32-bit gcc
-+COMPILE="$common -m32 -msse2 -mfpmath=sse -DC_NOMULTINTRINSIC "
-+# slower, use 387 fpu and truncate extra precision
-+# COMPILE="$common -m32 -ffloat-store "
-+LINK=" -shared -Wl,-soname,libj.so -m32 -lm $LDOPENMP32 -o libj.so "
-+;;
-+
-+freebsd_j64) # freebsd intel 64bit
-+TARGET=libj.so
-+COMPILE="$common $OPENMP "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
-+;;
-+
-+freebsd_j64avx) # freebsd intel 64bit avx
-+TARGET=libj.so
-+COMPILE="$common -mavx -DC_AVX=1 $OPENMP "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
-+OBJS_FMA=" blis/gemm_int-fma.o "
-+;;
-+
- windows_j32) # windows x86
- DLLOBJS=" jdll.o jdllcomx.o "
- LIBJDEF=" $jgit/dllsrc/jdll.def "
diff --git a/lang/J/files/patch-make_build__libj.sh b/lang/J/files/patch-make_build__libj.sh
index c35af47fb73a..ed409dc08a90 100644
--- a/lang/J/files/patch-make_build__libj.sh
+++ b/lang/J/files/patch-make_build__libj.sh
@@ -1,4 +1,4 @@
---- make/build_libj.sh.orig 2018-02-24 19:49:42 UTC
+--- make/build_libj.sh.orig 2018-04-09 18:12:26 UTC
+++ make/build_libj.sh
@@ -1,7 +1,6 @@
#!/usr/local/bin/bash
@@ -9,69 +9,34 @@
# gcc 5 vs 4 - killing off linux asm routines (overflow detection)
# new fast code uses builtins not available in gcc 4
-@@ -38,10 +37,10 @@ fi
-
- if [ "x$COMPILER" = x'gcc' ] ; then
- # gcc
--common="$OPENMP -fPIC -O1 -fwrapv -fno-strict-aliasing -Wextra -Wno-maybe-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-clobbered -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-shift-negative-value"
-+common="$OPENMP -fPIC -fwrapv -fno-strict-aliasing -Wextra -Wno-maybe-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-clobbered -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-shift-negative-value"
- else
- # clang 3.5 .. 5.0
--common="$OPENMP -Werror -fPIC -O1 -fwrapv -fno-strict-aliasing -Wextra -Wno-consumed -Wno-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-unsequenced -Wno-string-plus-int"
-+common="$OPENMP -Werror -fPIC -fwrapv -fno-strict-aliasing -Wextra -Wno-consumed -Wno-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-unsequenced -Wno-string-plus-int"
- fi
- darwin="$OPENMP -fPIC -O1 -fwrapv -fno-strict-aliasing -Wno-string-plus-int -Wno-empty-body -Wno-unsequenced -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-return-type -Wno-constant-logical-operand -Wno-comment -Wno-unsequenced"
-
-@@ -55,19 +54,19 @@ TARGET=libj.so
- COMPILE="$common -m32 -msse2 -mfpmath=sse -DC_NOMULTINTRINSIC "
- # slower, use 387 fpu and truncate extra precision
- # COMPILE="$common -m32 -ffloat-store "
--LINK=" -shared -Wl,-soname,libj.so -m32 -lm -ldl $LDOPENMP32 -o libj.so "
-+LINK=" -shared -Wl,-soname,libj.so -m32 -lm $LDOPENMP32 -o libj.so "
- ;;
-
- linux_j64) # linux intel 64bit
- TARGET=libj.so
- COMPILE="$common "
--LINK=" -shared -Wl,-soname,libj.so -lm -ldl $LDOPENMP -o libj.so "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
- ;;
+@@ -15,6 +14,8 @@ common="-fPIC -O1 -fno-if-conversion2 -f
+ # clang
+ # common="-Werror -fPIC -O1 -fwrapv -fno-strict-aliasing -Wextra -Wno-clobbered -Wno-maybe-uninitialized -Wno-unused-parameter -Wno-sign-compare -Wno-empty-body -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-unsequenced -Wno-string-plus-int"
+ darwin="-fPIC -O1 -fwrapv -fno-strict-aliasing -Wno-string-plus-int -Wno-empty-body -Wno-unsequenced -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-return-type -Wno-constant-logical-operand -Wno-comment -Wno-unsequenced"
++freebsd="-fPIC -O1 -fwrapv -fno-strict-aliasing -Wno-string-plus-int -Wno-empty-body -Wno-unsequenced -Wno-unused-value -Wno-pointer-sign -Wno-parentheses -Wno-return-type -Wno-constant-logical-operand -Wno-comment -Wno-unsequenced"
++
- linux_j64avx) # linux intel 64bit avx
- TARGET=libj.so
- COMPILE="$common -mavx -DC_AVX=1 "
--LINK=" -shared -Wl,-soname,libj.so -lm -ldl $LDOPENMP -o libj.so "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
- OBJS_FMA=" blis/gemm_int-fma.o "
- ;;
+ case $jplatform\_$1 in
-@@ -102,6 +101,29 @@ LINK=" -dynamiclib -lm -ldl $LDOPENMP -m
- OBJS_FMA=" blis/gemm_int-fma.o "
+@@ -50,6 +51,21 @@ TARGET=libj.dylib
+ COMPILE="$darwin -mmacosx-version-min=10.5"
+ LINK=" -dynamiclib -lm -ldl -mmacosx-version-min=10.5 -o libj.dylib"
;;
-
++
+freebsd_j32) # freebsd x86
+TARGET=libj.so
+# faster, but sse2 not available for 32-bit amd cpu
+# sse does not support mfpmath=sse in 32-bit gcc
-+COMPILE="$common -m32 -msse2 -mfpmath=sse -DC_NOMULTINTRINSIC "
++COMPILE="$freebsd -m32 -msse2 -mfpmath=sse -DC_NOMULTINTRINSIC "
+# slower, use 387 fpu and truncate extra precision
-+# COMPILE="$common -m32 -ffloat-store "
-+LINK=" -shared -Wl,-soname,libj.so -m32 -lm $LDOPENMP32 -o libj.so "
++# COMPILE="$freebsd -m32 -ffloat-store "
++LINK=" -shared -Wl,-soname,libj.so -m32 -lm -o libj.so "
+;;
-+
-+freebsd_j64) # freebsd intel 64bit
++freebsd_j64) # freebsd x86
+TARGET=libj.so
-+COMPILE="$common "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
++COMPILE="$freebsd -DC_NOMULTINTRINSIC "
++LINK=" -shared -Wl,-soname,libj.so -lm -o libj.so "
+;;
-+
-+freebsd_j64avx) # freebsd intel 64bit avx
-+TARGET=libj.so
-+COMPILE="$common -mavx -DC_AVX=1 "
-+LINK=" -shared -Wl,-soname,libj.so -lm $LDOPENMP -o libj.so "
-+OBJS_FMA=" blis/gemm_int-fma.o "
-+;;
-+
*)
echo no case for those parameters
exit
diff --git a/lang/J/files/patch-make_build__tsdll.sh b/lang/J/files/patch-make_build__tsdll.sh
index 52f2978200a9..6bfa8cb9b640 100644
--- a/lang/J/files/patch-make_build__tsdll.sh
+++ b/lang/J/files/patch-make_build__tsdll.sh
@@ -1,4 +1,4 @@
---- make/build_tsdll.sh.orig 2018-02-24 19:49:42 UTC
+--- make/build_tsdll.sh.orig 2018-04-09 18:00:06 UTC
+++ make/build_tsdll.sh
@@ -1,9 +1,8 @@
#!/usr/local/bin/bash
@@ -12,7 +12,7 @@
case $jplatform\_$1 in
-@@ -38,6 +37,16 @@ TARGET=libtsdll.dylib
+@@ -33,6 +32,16 @@ TARGET=libtsdll.dylib
COMPILE="$common "
LINK=" -dynamiclib -o libtsdll.dylib "
;;
diff --git a/lang/J/files/patch-make_domake.sh b/lang/J/files/patch-make_domake.sh
index a3d3d709ef0b..881ba0478490 100644
--- a/lang/J/files/patch-make_domake.sh
+++ b/lang/J/files/patch-make_domake.sh
@@ -1,4 +1,4 @@
---- make/domake.sh.orig 2017-11-02 18:50:23 UTC
+--- make/domake.sh.orig 2018-04-09 18:08:56 UTC
+++ make/domake.sh
@@ -3,8 +3,7 @@
# run by build_jconsole and build_libj
@@ -10,12 +10,10 @@
echo $TARGET
echo $COMPILE
-@@ -12,7 +11,7 @@ echo $LINK
- mkdir -p $jbld/jout/$TARGET/$1/blis
+@@ -12,5 +11,5 @@ echo $LINK
+ mkdir -p $jbld/jout/$TARGET/$1
cd $jbld/jout/$TARGET/$1
-make -f $jmake/makefile
+gmake -f $jmake/makefile
-
- if [ $1 = "j64avx" ] ; then
- if [ $TARGET = "libj.dylib" ] ; then
+ cp $TARGET $jbld/$1/bin
diff --git a/lang/J/files/patch-make_jvars.sh b/lang/J/files/patch-make_jvars.sh
index 152f9734e345..2a76845f23d0 100644
--- a/lang/J/files/patch-make_jvars.sh
+++ b/lang/J/files/patch-make_jvars.sh
@@ -1,11 +1,11 @@
---- make/jvars.sh.orig 2017-11-02 18:50:23 UTC
+--- make/jvars.sh.orig 2018-04-09 18:05:09 UTC
+++ make/jvars.sh
@@ -1,11 +1,11 @@
# source shell script (read with . jvars.sh) so stuff is easy to find
# edit following if your install is not standard
-jgit=~/gitdev/jsource # git jsource folder
-+jgit=~/jsource-j806-release # git jsource folder
++jgit=~/jsource-j808-release # git jsource folder
jbld=~/jbld # test libraries and binaries will be put here
# edit platform to build - linux darwin raspberry
diff --git a/lang/J/files/patch-make_makefile b/lang/J/files/patch-make_makefile
index b8cde983f6a5..dde7365c7252 100644
--- a/lang/J/files/patch-make_makefile
+++ b/lang/J/files/patch-make_makefile
@@ -1,11 +1,9 @@
---- make/makefile.orig 2018-02-24 19:45:08 UTC
+--- make/makefile.orig 2016-11-25 19:04:24 UTC
+++ make/makefile
-@@ -3,7 +3,7 @@ vpath % $(jgit)/jsrc
- %.o: %.c
- $(CC) -c $(CFLAGS) $(CFLAGS_FMA) -o$@ $^
+@@ -1,5 +1,5 @@
+ vpath % $(jgit)/jsrc
-CFLAGS=$(COMPILE)
+CFLAGS+=$(COMPILE)
- $(OBJS_FMA) : CFLAGS_FMA := -mfma
- $(TARGET) : $(OBJS) $(OBJS_FMA)
- $(CC) $(OBJS) $(OBJS_FMA) $(LINK)
+ $(TARGET) : $(OBJS)
+ $(CC) $(OBJS) $(LINK)
diff --git a/lang/J/files/patch-netdefs_netdefs.c b/lang/J/files/patch-netdefs_netdefs.c
index 04cce4878503..cafbfc75f2fc 100644
--- a/lang/J/files/patch-netdefs_netdefs.c
+++ b/lang/J/files/patch-netdefs_netdefs.c
@@ -1,11 +1,11 @@
---- netdefs/netdefs.c.orig 2018-02-22 18:45:28 UTC
+--- netdefs/netdefs.c.orig 2016-11-25 19:04:24 UTC
+++ netdefs/netdefs.c
-@@ -152,7 +152,7 @@ int main(){
- printf ("msg_iov_sz=: " FMTI "\n",sizeof(((struct msghdr*)0)->msg_iov));
- printf ("msg_iovlen_off=: " FMTI "\n",offset(struct msghdr,msg_iovlen));
- printf ("msg_iovlen_sz=: " FMTI "\n",sizeof(((struct msghdr*)0)->msg_iovlen));
+@@ -147,7 +147,7 @@ int main(){
+ printf ("msg_iov_sz=: %d\n",sizeof(((struct msghdr*)0)->msg_iov));
+ printf ("msg_iovlen_off=: %d\n",offset(struct msghdr,msg_iovlen));
+ printf ("msg_iovlen_sz=: %d\n",sizeof(((struct msghdr*)0)->msg_iovlen));
-#if defined(linux) || defined(Darwin)
+#if defined(linux) || defined(Darwin) || defined(__FreeBSD__)
- printf ("msg_control_off=: " FMTI "\n",offset(struct msghdr,msg_control));
- printf ("msg_control_sz=: " FMTI "\n",sizeof(((struct msghdr*)0)->msg_control));
- printf ("msg_controllen_off=: " FMTI "\n",offset(struct msghdr,msg_controllen));
+ printf ("msg_control_off=: %d\n",offset(struct msghdr,msg_control));
+ printf ("msg_control_sz=: %d\n",sizeof(((struct msghdr*)0)->msg_control));
+ printf ("msg_controllen_off=: %d\n",offset(struct msghdr,msg_controllen));
diff --git a/lang/J/pkg-plist b/lang/J/pkg-plist
index da8f8087d276..ed4ac18228e8 100644
--- a/lang/J/pkg-plist
+++ b/lang/J/pkg-plist
@@ -1,7 +1,6 @@
bin/jconsole
lib/j/bin/jconsole
lib/j/bin/libj.so
-lib/j/bin/libjavx.so
lib/j/bin/libtsdll.so
share/j/addons/data/jmf/history.txt
share/j/addons/data/jmf/jmf.ijs
@@ -105,14 +104,15 @@ share/j/addons/ide/jhs/utilh.ijs
share/j/addons/ide/jhs/utiljs.ijs
share/j/profile.ijs
share/j/system/config/base.cfg
+share/j/system/config/base.cfg.orig
share/j/system/config/folders.cfg
share/j/system/config/version.txt
share/j/system/defs/hostdefs_aix.ijs
share/j/system/defs/hostdefs_android.ijs
-share/j/system/defs/hostdefs_android_64.ijs
share/j/system/defs/hostdefs_darwin.ijs
share/j/system/defs/hostdefs_darwin_64.ijs
share/j/system/defs/hostdefs_freebsd_64.ijs
+share/j/system/defs/hostdefs_freebsd_64.ijs.orig
share/j/system/defs/hostdefs_linux.ijs
share/j/system/defs/hostdefs_linux_64.ijs
share/j/system/defs/hostdefs_sunos.ijs
@@ -120,24 +120,31 @@ share/j/system/defs/hostdefs_win.ijs
share/j/system/defs/hostdefs_win_64.ijs
share/j/system/defs/netdefs_aix.ijs
share/j/system/defs/netdefs_android.ijs
-share/j/system/defs/netdefs_android_64.ijs
share/j/system/defs/netdefs_darwin.ijs
share/j/system/defs/netdefs_darwin_64.ijs
share/j/system/defs/netdefs_freebsd_64.ijs
+share/j/system/defs/netdefs_freebsd_64.ijs.orig
share/j/system/defs/netdefs_linux.ijs
share/j/system/defs/netdefs_linux_64.ijs
share/j/system/defs/netdefs_sunos.ijs
share/j/system/defs/netdefs_win.ijs
share/j/system/defs/netdefs_win_64.ijs
+share/j/system/main/ctag.ijs
share/j/system/main/regex.ijs
+share/j/system/main/regex.ijs.orig
share/j/system/main/socket.ijs
share/j/system/main/stdlib.ijs
+share/j/system/main/stdlib.ijs.orig
share/j/system/main/task.ijs
share/j/system/util/boot.ijs
share/j/system/util/configure.ijs
+share/j/system/util/edit.png
+share/j/system/util/edit.svg
+share/j/system/util/jadetag.ijs
share/j/system/util/pacman.ijs
share/j/system/util/pm.ijs
share/j/system/util/pp.ijs
share/j/system/util/project.ijs
share/j/system/util/scripts.ijs
share/j/system/util/tar.ijs
+share/j/system/util/term.png