aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 17:21:21 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-13 17:21:21 +0000
commit2da2308e07cc201fd7469542810c2d0aa26d9217 (patch)
tree5f461fdb8efefe5219d6c63d6b924f7ff8fed38a /lang
parent6992885f5bc433ac7136855e450db0a652961749 (diff)
downloadports-2da2308e07cc201fd7469542810c2d0aa26d9217.tar.gz
ports-2da2308e07cc201fd7469542810c2d0aa26d9217.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/haskell-mode.el/Makefile58
-rw-r--r--lang/haskell-mode.el/distinfo2
-rw-r--r--lang/haskell-mode.el/files/pkg-message.in15
-rw-r--r--lang/haskell-mode.el/pkg-descr9
5 files changed, 85 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 2b0282b14a9a..d324abae4626 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -124,6 +124,7 @@
SUBDIR += guile
SUBDIR += guile2
SUBDIR += harbour
+ SUBDIR += haskell-mode.el
SUBDIR += hla
SUBDIR += hope
SUBDIR += hs-brainfuck
diff --git a/lang/haskell-mode.el/Makefile b/lang/haskell-mode.el/Makefile
new file mode 100644
index 000000000000..652098e552c4
--- /dev/null
+++ b/lang/haskell-mode.el/Makefile
@@ -0,0 +1,58 @@
+# Created by: Josh Elsasser <jre@vineyard.net>
+# $FreeBSD$
+
+PORTNAME= haskell-mode
+PORTVERSION= 13.18
+DISTVERSIONPREFIX=v
+CATEGORIES= lang elisp
+
+MAINTAINER= aehlig@linta.de
+COMMENT= Emacs lisp mode for editing haskell programs
+
+LICENSE= GPLv3
+
+USE_EMACS= yes
+
+OPTIONS_DEFINE= DOCS
+
+GH_ACCOUNT= haskell
+PORTDOCS= NEWS README.md
+USE_GITHUB= yes
+USES= gmake
+ALL_TARGET= haskell-mode-autoloads.el
+
+ELISPDIR= ${PREFIX}/${PLIST_DIRS}
+ELISPFILES= ghc-core.el ghci-script-mode.el haskell-align-imports.el \
+ haskell-cabal.el haskell-checkers.el \
+ haskell-collapse.el haskell-commands.el \
+ haskell-compile.el haskell-compat.el \
+ haskell-complete-module.el haskell-completions.el \
+ haskell-customize.el \
+ haskell-debug.el haskell-decl-scan.el \
+ haskell-doc.el haskell-font-lock.el haskell-hoogle.el \
+ haskell-indent.el haskell-indentation.el \
+ haskell-interactive-mode.el haskell-lexeme.el haskell-load.el \
+ haskell-menu.el haskell-mode-pkg.el haskell-mode.el \
+ haskell-mode-autoloads.el haskell-modules.el \
+ haskell-move-nested.el haskell-navigate-imports.el \
+ haskell-package.el haskell-presentation-mode.el \
+ haskell-process.el haskell-repl.el haskell-sandbox.el \
+ haskell-session.el \
+ haskell-sort-imports.el haskell-string.el \
+ haskell-unicode-input-method.el haskell-utils.el \
+ haskell.el highlight-uses-mode.el inf-haskell.el \
+ w3m-haddock.el
+
+PLIST_DIRS= share/emacs/site-lisp/${PORTNAME}/
+PLIST_FILES= ${ELISPFILES:C/^| [^ ]/${PLIST_DIRS}/g}
+SUB_FILES= pkg-message
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${ELISPDIR}
+ ${INSTALL_DATA} ${ELISPFILES:S,^,${WRKSRC}/,} ${STAGEDIR}${ELISPDIR}/
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/lang/haskell-mode.el/distinfo b/lang/haskell-mode.el/distinfo
new file mode 100644
index 000000000000..7a028c018e72
--- /dev/null
+++ b/lang/haskell-mode.el/distinfo
@@ -0,0 +1,2 @@
+SHA256 (haskell-haskell-mode-v13.18_GH0.tar.gz) = 144c39f748b41391918334c29700dc0dc8661070387eee543bf182ed11f10b9c
+SIZE (haskell-haskell-mode-v13.18_GH0.tar.gz) = 555164
diff --git a/lang/haskell-mode.el/files/pkg-message.in b/lang/haskell-mode.el/files/pkg-message.in
new file mode 100644
index 000000000000..f9681ef85c30
--- /dev/null
+++ b/lang/haskell-mode.el/files/pkg-message.in
@@ -0,0 +1,15 @@
+To use haskell-mode in Emacs, add the following lines to your ~/.emacs:
+
+(add-to-list 'load-path "%%PREFIX%%/share/emacs/site-lisp/haskell-mode/")
+(require 'haskell-mode-autoloads)
+
+Add the following lines according to which modules you want to use:
+
+(add-hook 'haskell-mode-hook 'turn-on-haskell-doc-mode)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-indentation)
+(add-hook 'haskell-mode-hook 'turn-on-haskell-indent)
+(autoload 'turn-on-haskell-indent "hindent" "Indentation mode for Haskell" t)
+(add-hook 'haskell-mode-hook 'font-lock-mode)
+
+Note that the three indentation modules are mutually exclusive - add at
+most one.
diff --git a/lang/haskell-mode.el/pkg-descr b/lang/haskell-mode.el/pkg-descr
new file mode 100644
index 000000000000..0b1f221587e5
--- /dev/null
+++ b/lang/haskell-mode.el/pkg-descr
@@ -0,0 +1,9 @@
+Haskell-mode is a major Emacs mode for editing Haskell source code. It
+provides syntax highlighting and automatic indentation and comes with
+inf-haskell which allows interaction with an inferior Haskell interactive
+loop such as the one of Hugs or GHCi.
+
+Note that if you want to use haskell-mode under XEmacs, you should
+install editors/xemacs-packages instead.
+
+WWW: http://projects.haskell.org/haskellmode-emacs/