aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-09-14 15:55:20 +0000
committerSteve Wills <swills@FreeBSD.org>2014-09-14 15:55:20 +0000
commit332ecdd0456c900471c0e78baac685e23209c427 (patch)
treee52cf7876c12862322cb1571c0f077e66df9d79c /lang
parent9116798617b234d164420b0d5d3ab50ffd10012c (diff)
downloadports-332ecdd0456c900471c0e78baac685e23209c427.tar.gz
ports-332ecdd0456c900471c0e78baac685e23209c427.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby21/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index adda9ab7db9a..6696170acbc1 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -17,8 +17,7 @@ COMMENT?= Object-oriented interpreted scripting language
LICENSE= BSD2CLAUSE RUBY
LICENSE_COMB= dual
-LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo \
- libyaml.so:${PORTSDIR}/textproc/libyaml
+LIB_DEPENDS= libyaml.so:${PORTSDIR}/textproc/libyaml
# Using LIB_DEPENDS finds the libffi from gcc which causes problems
BUILD_DEPENDS= libffi>=0:${PORTSDIR}/devel/libffi
@@ -47,7 +46,6 @@ USE_RUBY= yes
RUBY_NO_BUILD_DEPENDS= yes
RUBY_NO_RUN_DEPENDS= yes
NO_LATEST_LINK= yes
-MAKE_JOBS_UNSAFE= yes
OPTIONS_DEFINE= CAPIDOCS DEBUG DOCS EXAMPLES RDOC
OPTIONS_DEFAULT= RDOC READLINE
@@ -64,7 +62,7 @@ CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
CAPIDOCS_CONFIGURE_OFF= --disable-install-capi
RDOC_CONFIGURE_OFF= --disable-install-rdoc
-USES= tar:bzip2 cpe
+USES= execinfo cpe tar:bzip2
CPE_VENDOR= ruby-lang
CPE_VERSION= ${RUBY_RELVERSION}
@@ -92,6 +90,10 @@ CONFIGURE_ARGS+= --disable-dtrace
CONFIGURE_ENV= debugflags=
+.if ${PORT_OPTIONS:MCAPIDOCS}
+MAKE_JOBS_UNSAFE= yes
+.endif
+
.if ${PORT_OPTIONS:MLIBEDIT}
BUILD_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit
RUN_DEPENDS+= libedit>=0:${PORTSDIR}/devel/libedit