aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAndreas Tobler <andreast@FreeBSD.org>2018-12-29 15:41:15 +0000
committerAndreas Tobler <andreast@FreeBSD.org>2018-12-29 15:41:15 +0000
commit3ef2bed0e9cb58c5a4ecc25c31f80fb97e3e2f91 (patch)
tree0a7ab415012ed38406112ec2ff8c97905af6074e /lang
parent5f9a3c9f23721ff862cdc38698a98aa86fa8bfb5 (diff)
downloadports-3ef2bed0e9cb58c5a4ecc25c31f80fb97e3e2f91.tar.gz
ports-3ef2bed0e9cb58c5a4ecc25c31f80fb97e3e2f91.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/gcc8-devel/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/lang/gcc8-devel/Makefile b/lang/gcc8-devel/Makefile
index 7f48a50e04a0..e9c97e4a00a0 100644
--- a/lang/gcc8-devel/Makefile
+++ b/lang/gcc8-devel/Makefile
@@ -72,6 +72,7 @@ CONFIGURE_ARGS+= --with-cpu=8540 --enable-e500_double --without-fp
LANGUAGES:= c,c++,objc,fortran
TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
+TARGLIB32= ${PREFIX}/lib32 # The version information is added later
LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
GNU_CONFIGURE= yes
CONFIGURE_OUTSOURCE= yes
@@ -141,7 +142,13 @@ post-stage:
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
+
+.if ${ARCH} == powerpc64 && ${PORT_OPTIONS:MMULTILIB}
+ ${MKDIR} ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
+ ${MV} ${STAGEDIR}${PREFIX}/lib/lib32/* ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
+.endif
+
+.for d in ${TARGLIB:S/^${PREFIX}\///} ${TARGLIB32:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
fi