aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-04-06 21:21:26 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-04-06 23:02:51 +0000
commit41c875bfe9575306fc1d297505781e4c574e3166 (patch)
tree0070cbf47f23f93a682724dfd64beb0f281b31de /lang
parentdad35af59d19ee1dd90251081d63470de7325141 (diff)
downloadports-41c875bfe9575306fc1d297505781e4c574e3166.tar.gz
ports-41c875bfe9575306fc1d297505781e4c574e3166.zip
lang/cling: fix build ahead of CMake 3.20
The --target command-line argument is ignored when not applicable in versions of CMake up to 3.20. It should never be necessary in FreeBSD ports **anyway** since we generate a build system (ninja or make) and use that, rather than building directly out of CMake. Bumping PORTREVISION even though there shouldn't be a difference.
Diffstat (limited to 'lang')
-rw-r--r--lang/cling/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/lang/cling/Makefile b/lang/cling/Makefile
index fd5cf521c813..46aaa3c78bf5 100644
--- a/lang/cling/Makefile
+++ b/lang/cling/Makefile
@@ -2,7 +2,7 @@
PORTNAME= cling
DISTVERSION= 0.5-2018-08-13
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= lang devel
MASTER_SITES= https://root.cern.ch/download/cling/
DISTNAME= ${PORTNAME}_${DISTVERSION:C/^[0-9]\.[0-9]-//}_sources
@@ -49,8 +49,7 @@ PLIST_SUB+= LLVM_SUFFIX=${LLVM_SUFFIX} LLVM_RELEASE=${LLVM_RELEASE}
CMAKE_BUILD_TYPE= Release
CMAKE_INSTALL_PREFIX= ${LLVM_PREFIX}
-CMAKE_ARGS+= -DINSTALL_LAYOUT=FREEBSD \
- --target ${PORTNAME}
+CMAKE_ARGS+= -DINSTALL_LAYOUT=FREEBSD
post-patch:
@${REINPLACE_CMD} -e 's|%%LLVM_PREFIX%%|${LLVM_PREFIX}|g' \