aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-06-01 18:10:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-06-10 18:03:46 +0000
commit49e8b5dd76fe28e7e846e824e0defcdbede64866 (patch)
tree25bd97213d22174cfcc74d8f2a650f4ba005cb24 /lang
parentc1b8b295583db63cef26fbeced118f6fce54ec22 (diff)
downloadports-49e8b5dd76fe28e7e846e824e0defcdbede64866.tar.gz
ports-49e8b5dd76fe28e7e846e824e0defcdbede64866.zip
lang/intel-compute-runtime: update to 22.23.23405
Diffstat (limited to 'lang')
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-userptr8
3 files changed, 8 insertions, 8 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index b3553674613e..2a43550f4461 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,5 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 22.22.23355
+DISTVERSION= 22.23.23405
CATEGORIES= lang
PKGNAMEPREFIX= intel-
PKGNAMESUFFIX= -${FLAVOR}
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index 658aaee6c78a..6bc8cfefdd4c 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1653506865
-SHA256 (intel-compute-runtime-22.22.23355_GH0.tar.gz) = dd74b1947784ffbf0acf0ad4011e4fab932c4a9ec3ebd3229270ba3b07dd28e0
-SIZE (intel-compute-runtime-22.22.23355_GH0.tar.gz) = 5498680
+TIMESTAMP = 1654107032
+SHA256 (intel-compute-runtime-22.23.23405_GH0.tar.gz) = ce594214b6e6424e53cf41c9c36325ecb84910230fda66b557cd13f275bc6c95
+SIZE (intel-compute-runtime-22.23.23405_GH0.tar.gz) = 5515173
diff --git a/lang/intel-compute-runtime/files/patch-userptr b/lang/intel-compute-runtime/files/patch-userptr
index 189b17e940a8..5d04bb042b36 100644
--- a/lang/intel-compute-runtime/files/patch-userptr
+++ b/lang/intel-compute-runtime/files/patch-userptr
@@ -38,16 +38,16 @@ frame #5: 0x000000080104b4e5 libigdrcl.so`NEO::DrmMemoryManager::DrmMemoryManage
60 }
61 }
---- shared/source/os_interface/linux/drm_memory_manager.cpp.orig 2022-04-25 08:39:54 UTC
+--- shared/source/os_interface/linux/drm_memory_manager.cpp.orig 2022-06-01 18:10:32 UTC
+++ shared/source/os_interface/linux/drm_memory_manager.cpp
-@@ -246,7 +246,17 @@ NEO::BufferObject *DrmMemoryManager::allocUserptr(uint
+@@ -248,7 +248,17 @@ NEO::BufferObject *DrmMemoryManager::allocUserptr(uint
auto &drm = this->getDrm(rootDeviceIndex);
- if (drm.ioctl(DRM_IOCTL_I915_GEM_USERPTR, &userptr) != 0) {
+ if (drm.ioctl(DrmIoctl::GemUserptr, &userptr) != 0) {
- return nullptr;
+ if (errno == ENODEV && userptr.flags == 0) {
+ userptr.flags = I915_USERPTR_UNSYNCHRONIZED;
-+ if (drm.ioctl(DRM_IOCTL_I915_GEM_USERPTR, &userptr) != 0) {
++ if (drm.ioctl(DrmIoctl::GemUserptr, &userptr) != 0) {
+ if (geteuid() != 0) {
+ printDebugString(true, stderr, "%s", "ioctl(I915_GEM_USERPTR) failed. Try running as root but expect poor stability.\n");
+ }