aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2015-11-24 08:15:09 +0000
committerRomain Tartière <romain@FreeBSD.org>2015-11-24 08:15:09 +0000
commit4c63218f5ccb8f6a3d2dc97f2ad8c7aaa9425198 (patch)
tree4aedcd9a656600c989332c227ffe4af9c7b31151 /lang
parent077c7556bb859068db07c41f8b70b8884f85b2d2 (diff)
downloadports-4c63218f5ccb8f6a3d2dc97f2ad8c7aaa9425198.tar.gz
ports-4c63218f5ccb8f6a3d2dc97f2ad8c7aaa9425198.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/mono/Makefile4
-rw-r--r--lang/mono/distinfo4
-rw-r--r--lang/mono/files/patch-configure11
-rw-r--r--lang/mono/files/patch-eglib_src_gmisc-unix.c43
-rw-r--r--lang/mono/files/patch-mcs_tools_xbuild_targets_Microsoft.Portable.Common.targets7
-rw-r--r--lang/mono/files/patch-mono-mini-ldscript.mono31
-rw-r--r--lang/mono/files/patch-mono_mini_exceptions-x86.c10
-rw-r--r--lang/mono/files/patch-mono_tests_Makefile.in11
-rw-r--r--lang/mono/files/patch-mono_unit-tests_Makefile.in23
-rw-r--r--lang/mono/pkg-plist17
10 files changed, 15 insertions, 146 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index b5607629da0c..7f658ed47850 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= mono
-PORTVERSION= 4.0.3.20
+PORTVERSION= 4.2.1.102
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
@@ -21,7 +21,7 @@ USE_GNOME= glib20
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-WRKSRC= ${WRKDIR}/mono-4.0.3
+WRKSRC= ${WRKDIR}/mono-${PORTVERSION:R}
# Moonlight is installed as part of www/moonlight
CONFIGURE_ARGS= --with-moonlight=no --disable-dtrace
diff --git a/lang/mono/distinfo b/lang/mono/distinfo
index 09407f0c01ab..c41262c1dde3 100644
--- a/lang/mono/distinfo
+++ b/lang/mono/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mono-4.0.3.20.tar.bz2) = 976c0be3ab9b66361f48e8133c60b1b2942b88c44a7a11a19cd98f5ff64313fc
-SIZE (mono-4.0.3.20.tar.bz2) = 95987018
+SHA256 (mono-4.2.1.102.tar.bz2) = b7b461fe04375f621d88166ba8c6f1cb33c439fd3e17136460f7d087a51ed792
+SIZE (mono-4.2.1.102.tar.bz2) = 96228604
diff --git a/lang/mono/files/patch-configure b/lang/mono/files/patch-configure
deleted file mode 100644
index a8377755294f..000000000000
--- a/lang/mono/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig
-+++ configure
-@@ -25136,7 +25136,7 @@
- INTL="libintl.so.0"
- ;;
- *-*-*freebsd*)
-- LIBC="libc.so"
-+ LIBC="libc.so.7"
- INTL="libintl.so"
- SQLITE="libsqlite.so"
- SQLITE3="libsqlite3.so"
diff --git a/lang/mono/files/patch-eglib_src_gmisc-unix.c b/lang/mono/files/patch-eglib_src_gmisc-unix.c
deleted file mode 100644
index 8eb695d4f5cc..000000000000
--- a/lang/mono/files/patch-eglib_src_gmisc-unix.c
+++ /dev/null
@@ -1,43 +0,0 @@
-https://github.com/mono/mono/pull/1861
-
---- eglib/src/gmisc-unix.c~
-+++ eglib/src/gmisc-unix.c
-@@ -93,24 +93,27 @@ get_pw_data (void)
- pthread_mutex_unlock (&pw_lock);
- return;
- }
-+
-+ home_dir = g_getenv ("HOME");
-+ user_name = g_getenv ("USER");
-+
- #ifdef HAVE_GETPWUID_R
-- if (getpwuid_r (getuid (), &pw, buf, 4096, &result) == 0) {
-- home_dir = g_strdup (pw.pw_dir);
-- user_name = g_strdup (pw.pw_name);
-+ if (home_dir == NULL || user_name == NULL) {
-+ if (getpwuid_r (getuid (), &pw, buf, 4096, &result) == 0) {
-+ if (home_dir == NULL)
-+ home_dir = g_strdup (pw.pw_dir);
-+ if (user_name == NULL)
-+ user_name = g_strdup (pw.pw_name);
-+ } else {
-+ if (user_name == NULL)
-+ user_name = "somebody";
-+ }
- }
- #endif
-- if (home_dir == NULL)
-- home_dir = g_getenv ("HOME");
-
-- if (user_name == NULL) {
-- user_name = g_getenv ("USER");
-- if (user_name == NULL)
-- user_name = "somebody";
-- }
- pthread_mutex_unlock (&pw_lock);
- }
-
--/* Give preference to /etc/passwd than HOME */
- const gchar *
- g_get_home_dir (void)
- {
diff --git a/lang/mono/files/patch-mcs_tools_xbuild_targets_Microsoft.Portable.Common.targets b/lang/mono/files/patch-mcs_tools_xbuild_targets_Microsoft.Portable.Common.targets
deleted file mode 100644
index a845d4cf7f3e..000000000000
--- a/lang/mono/files/patch-mcs_tools_xbuild_targets_Microsoft.Portable.Common.targets
+++ /dev/null
@@ -1,7 +0,0 @@
---- /dev/null
-+++ mcs/tools/xbuild/targets/Microsoft.Portable.Common.targets
-@@ -0,0 +1,4 @@
-+<Project xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
-+ <Import Project="..\Microsoft.Portable.Core.props" />
-+ <Import Project="..\Microsoft.Portable.Core.targets" />
-+</Project>
diff --git a/lang/mono/files/patch-mono-mini-ldscript.mono b/lang/mono/files/patch-mono-mini-ldscript.mono
deleted file mode 100644
index 4ec5c9876152..000000000000
--- a/lang/mono/files/patch-mono-mini-ldscript.mono
+++ /dev/null
@@ -1,31 +0,0 @@
-Address this build error when using binutils 2.24's ld(1):
-
-====================
- .
- .
- CCLD mono-sgen
-/usr/local/bin/ld: mono-boehm: local symbol `__progname' in /usr/lib/crt1.o is referenced by DSO
-/usr/local/bin/ld: final link failed: Bad value
-clang: error: linker command failed with exit code 1 (use -v to see invocation)
-gmake[4]: *** [mono-boehm] Error 1
-gmake[4]: *** Waiting for unfinished jobs....
-/usr/local/bin/ld: mono-sgen: local symbol `__progname' in /usr/lib/crt1.o is referenced by DSO
-/usr/local/bin/ld: final link failed: Bad value
-clang: error: linker command failed with exit code 1 (use -v to see invocation)
-gmake[4]: *** [mono-sgen] Error 1
- .
- .
-====================
-
-See also:
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=190851
-
---- mono/mini/ldscript.mono.orig 2014-03-31 14:25:50.000000000 -0600
-+++ mono/mini/ldscript.mono 2014-06-18 14:27:28.000000000 -0600
-@@ -7,6 +7,4 @@
- gc_thread_vtable;
- mini_type_is_vtype;
- mini_is_gsharedvt_klass;
-- local:
-- *;
- };
diff --git a/lang/mono/files/patch-mono_mini_exceptions-x86.c b/lang/mono/files/patch-mono_mini_exceptions-x86.c
deleted file mode 100644
index 31070e7046e9..000000000000
--- a/lang/mono/files/patch-mono_mini_exceptions-x86.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- mono/mini/exceptions-x86.c.orig
-+++ mono/mini/exceptions-x86.c
-@@ -12,6 +12,7 @@
- #include <glib.h>
- #include <signal.h>
- #include <string.h>
-+#include <sys/ucontext.h>
-
- #include <mono/metadata/abi-details.h>
- #include <mono/arch/x86/x86-codegen.h>
diff --git a/lang/mono/files/patch-mono_tests_Makefile.in b/lang/mono/files/patch-mono_tests_Makefile.in
deleted file mode 100644
index c00f67fabbf4..000000000000
--- a/lang/mono/files/patch-mono_tests_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- mono/tests/Makefile.in.orig
-+++ mono/tests/Makefile.in
-@@ -1509,7 +1509,7 @@
- @HOST_WIN32_TRUE@@NACL_CODEGEN_FALSE@test-messages:
- @HOST_WIN32_FALSE@@NACL_CODEGEN_FALSE@test-messages: w32message.exe
- @HOST_WIN32_FALSE@@NACL_CODEGEN_FALSE@ > test_messages.zero
--@HOST_WIN32_FALSE@@NACL_CODEGEN_FALSE@ $(with_mono_path) $(JITTEST_PROG_RUN) w32message.exe >& w32message.allout && cmp test_messages.zero w32message.allout
-+@HOST_WIN32_FALSE@@NACL_CODEGEN_FALSE@ $(with_mono_path) $(JITTEST_PROG_RUN) w32message.exe > w32message.allout 2>&1 && cmp test_messages.zero w32message.allout
-
- @AMD64_TRUE@test-sgen : sgen-tests
- @AMD64_FALSE@@HOST_WIN32_TRUE@@X86_TRUE@test-sgen :
diff --git a/lang/mono/files/patch-mono_unit-tests_Makefile.in b/lang/mono/files/patch-mono_unit-tests_Makefile.in
deleted file mode 100644
index 4e9968e2c684..000000000000
--- a/lang/mono/files/patch-mono_unit-tests_Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
-See comments on:
-https://github.com/mono/mono/commit/056cc3be24f933bc3638be4909ad1b7f1cd6e6d4
- (What is wrong with the test)
-
-https://github.com/mono/mono/commit/120d194d10ad351dd95450749cc4a62331331d8a
- (Only one program causes trouble)
---- mono/unit-tests/Makefile.in.orig
-+++ mono/unit-tests/Makefile.in
-@@ -81,12 +81,10 @@
- target_triplet = @target@
- @CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@noinst_PROGRAMS = test-sgen-qsort$(EXEEXT) \
- @CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-gc-memfuncs$(EXEEXT) \
--@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-mono-linked-list-set$(EXEEXT) \
--@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-conc-hashtable$(EXEEXT)
-+@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-mono-linked-list-set$(EXEEXT)
- @CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@TESTS = test-sgen-qsort$(EXEEXT) \
- @CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-gc-memfuncs$(EXEEXT) \
--@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-mono-linked-list-set$(EXEEXT) \
--@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-conc-hashtable$(EXEEXT)
-+@CROSS_COMPILE_FALSE@@HOST_WIN32_FALSE@@PLATFORM_GNU_FALSE@@SUPPORT_BOEHM_TRUE@ test-mono-linked-list-set$(EXEEXT)
- subdir = mono/unit-tests
- DIST_COMMON = $(srcdir)/Makefile.in $(srcdir)/Makefile.am \
- $(top_srcdir)/mkinstalldirs $(top_srcdir)/depcomp \
diff --git a/lang/mono/pkg-plist b/lang/mono/pkg-plist
index d1cfa04d903b..9b6907ed3868 100644
--- a/lang/mono/pkg-plist
+++ b/lang/mono/pkg-plist
@@ -50,6 +50,7 @@ bin/mono-service2
bin/mono-sgen
bin/mono-sgen-gdb.py
bin/mono-shlib-cop
+bin/mono-symbolicate
bin/mono-test-install
bin/mono-xmltool
bin/monodis
@@ -147,10 +148,6 @@ lib/libmono-profiler-aot.a
lib/libmono-profiler-aot.so
lib/libmono-profiler-aot.so.0
lib/libmono-profiler-aot.so.0.0.0
-lib/libmono-profiler-cov.a
-lib/libmono-profiler-cov.so
-lib/libmono-profiler-cov.so.0
-lib/libmono-profiler-cov.so.0.0.0
lib/libmono-profiler-iomap.a
lib/libmono-profiler-iomap.so
lib/libmono-profiler-iomap.so.0
@@ -457,6 +454,7 @@ lib/mono/4.5/PEAPI.dll
lib/mono/4.5/RabbitMQ.Client.Apigen.exe
lib/mono/4.5/RabbitMQ.Client.Apigen.exe.mdb
lib/mono/4.5/RabbitMQ.Client.dll
+lib/mono/4.5/SMDiagnostics.dll
lib/mono/4.5/System.ComponentModel.Composition.dll
lib/mono/4.5/System.ComponentModel.DataAnnotations.dll
lib/mono/4.5/System.Configuration.Install.dll
@@ -508,6 +506,7 @@ lib/mono/4.5/System.Runtime.Serialization.dll
lib/mono/4.5/System.Security.dll
lib/mono/4.5/System.ServiceModel.Activation.dll
lib/mono/4.5/System.ServiceModel.Discovery.dll
+lib/mono/4.5/System.ServiceModel.Internals.dll
lib/mono/4.5/System.ServiceModel.Routing.dll
lib/mono/4.5/System.ServiceModel.Web.dll
lib/mono/4.5/System.ServiceModel.dll
@@ -613,6 +612,8 @@ lib/mono/4.5/mono-service.exe.mdb
lib/mono/4.5/mono-shlib-cop.exe
lib/mono/4.5/mono-shlib-cop.exe.config
lib/mono/4.5/mono-shlib-cop.exe.mdb
+lib/mono/4.5/mono-symbolicate.exe
+lib/mono/4.5/mono-symbolicate.exe.mdb
lib/mono/4.5/mono-xmltool.exe
lib/mono/4.5/mono-xmltool.exe.mdb
lib/mono/4.5/monolinker.exe
@@ -659,8 +660,6 @@ lib/mono/4.5/sqlsharp.exe
lib/mono/4.5/sqlsharp.exe.mdb
lib/mono/4.5/svcutil.exe
lib/mono/4.5/svcutil.exe.mdb
-lib/mono/4.5/symbolicate.exe
-lib/mono/4.5/symbolicate.exe.mdb
lib/mono/4.5/wsdl.exe
lib/mono/4.5/wsdl.exe.mdb
lib/mono/4.5/xbuild.exe
@@ -779,6 +778,8 @@ lib/mono/gac/PEAPI/4.0.0.0__0738eb9f132ed756/PEAPI.dll
lib/mono/gac/PEAPI/4.0.0.0__0738eb9f132ed756/PEAPI.dll.mdb
lib/mono/gac/RabbitMQ.Client/4.0.0.0__b03f5f7f11d50a3a/RabbitMQ.Client.dll
lib/mono/gac/RabbitMQ.Client/4.0.0.0__b03f5f7f11d50a3a/RabbitMQ.Client.dll.mdb
+lib/mono/gac/SMDiagnostics/0.0.0.0__b77a5c561934e089/SMDiagnostics.dll
+lib/mono/gac/SMDiagnostics/0.0.0.0__b77a5c561934e089/SMDiagnostics.dll.mdb
lib/mono/gac/System.ComponentModel.Composition/4.0.0.0__b77a5c561934e089/System.ComponentModel.Composition.dll
lib/mono/gac/System.ComponentModel.Composition/4.0.0.0__b77a5c561934e089/System.ComponentModel.Composition.dll.mdb
lib/mono/gac/System.ComponentModel.DataAnnotations/4.0.0.0__31bf3856ad364e35/System.ComponentModel.DataAnnotations.dll
@@ -881,6 +882,8 @@ lib/mono/gac/System.ServiceModel.Activation/4.0.0.0__31bf3856ad364e35/System.Ser
lib/mono/gac/System.ServiceModel.Activation/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Activation.dll.mdb
lib/mono/gac/System.ServiceModel.Discovery/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Discovery.dll
lib/mono/gac/System.ServiceModel.Discovery/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Discovery.dll.mdb
+lib/mono/gac/System.ServiceModel.Internals/0.0.0.0__b77a5c561934e089/System.ServiceModel.Internals.dll
+lib/mono/gac/System.ServiceModel.Internals/0.0.0.0__b77a5c561934e089/System.ServiceModel.Internals.dll.mdb
lib/mono/gac/System.ServiceModel.Routing/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Routing.dll
lib/mono/gac/System.ServiceModel.Routing/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Routing.dll.mdb
lib/mono/gac/System.ServiceModel.Web/4.0.0.0__31bf3856ad364e35/System.ServiceModel.Web.dll
@@ -1102,6 +1105,7 @@ man/man1/mono-cil-strip.1.gz
man/man1/mono-configuration-crypto.1.gz
man/man1/mono-service.1.gz
man/man1/mono-shlib-cop.1.gz
+man/man1/mono-symbolicate.1.gz
man/man1/mono-xmltool.1.gz
man/man1/mono.1.gz
man/man1/monodis.1.gz
@@ -1164,3 +1168,4 @@ share/locale/es/LC_MESSAGES/mcs.mo
share/locale/ja/LC_MESSAGES/mcs.mo
share/locale/pt_BR/LC_MESSAGES/mcs.mo
%%DATADIR%%-2.0/mono/cil/cil-opcodes.xml
+%%DATADIR%%-2.0/mono/profiler/mono-profiler-log.suppression