aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-09 00:41:46 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-06-09 00:41:46 +0000
commit62bd7b9f9900528481ab4ae32b4a2bd183afecfb (patch)
tree4b4122721cf08ac9e6434664c4bc81c6285855c9 /lang
parent233e8c358443cf32cb95ed9e68945529ad5b9e27 (diff)
downloadports-62bd7b9f9900528481ab4ae32b4a2bd183afecfb.tar.gz
ports-62bd7b9f9900528481ab4ae32b4a2bd183afecfb.zip
lang/php80: fix build on riscv64
DTRACE doesn't yet work on riscv64. JIT in PCRE2 is not yet implemented.
Diffstat (limited to 'lang')
-rw-r--r--lang/php80/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index 00eb5388ba65..ca90715958ba 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -47,6 +47,7 @@ OPTIONS_EXCLUDE_powerpc= DTRACE
OPTIONS_EXCLUDE_powerpc64= ${OPTIONS_EXCLUDE_${ARCH}_${OSREL:R}}
OPTIONS_EXCLUDE_powerpc64_11= DTRACE
OPTIONS_EXCLUDE_powerpc64_12= DTRACE
+OPTIONS_EXCLUDE_riscv64= DTRACE
OPTIONS_EXCLUDE_sparc64= DTRACE
OPTIONS_SUB= yes
@@ -73,6 +74,10 @@ DESTDIRNAME= INSTALL_ROOT
.include <bsd.port.pre.mk>
+.if ${ARCH} == riscv64
+CONFIGURE_ARGS+=--without-pcre-jit
+.endif
+
.if ${PORT_OPTIONS:MMYSQLND}
CONFIGURE_ARGS+=--enable-mysqlnd
.endif