aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-08-16 05:54:55 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-08-16 05:54:55 +0000
commit66e571eca1172d5292b16043444f72817aea2d7b (patch)
tree6ae5b8639611093d4cea56d587651739c173d629 /lang
parentb0e7ef5f128cf1f9806dd2de4da7c576af40ad1f (diff)
downloadports-66e571eca1172d5292b16043444f72817aea2d7b.tar.gz
ports-66e571eca1172d5292b16043444f72817aea2d7b.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ocamlduce/Makefile37
-rw-r--r--lang/ocamlduce/distinfo2
-rw-r--r--lang/ocamlduce/files/patch-Makefile72
-rw-r--r--lang/ocamlduce/pkg-descr3
-rw-r--r--lang/ocamlduce/pkg-plist24
6 files changed, 0 insertions, 139 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 13d827a7b1e6..f6e875f59cf7 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -189,7 +189,6 @@
SUBDIR += ocaml-examples
SUBDIR += ocaml-mode.el
SUBDIR += ocaml-nox11
- SUBDIR += ocamlduce
SUBDIR += ocs
SUBDIR += ofc
SUBDIR += ohugs
diff --git a/lang/ocamlduce/Makefile b/lang/ocamlduce/Makefile
deleted file mode 100644
index e0fb08a7423e..000000000000
--- a/lang/ocamlduce/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-# New ports collection makefile for: ocamlduce
-# Date created: Feb 24, 2007
-# Whom: Jaap Boender <jaapb@kerguelen.rg>
-#
-# $FreeBSD$
-#
-
-PORTNAME= ocamlduce
-PORTVERSION= 3.11.1.0
-CATEGORIES= lang
-MASTER_SITES= https://forge.ocamlcore.org/frs/download.php/225/
-
-MAINTAINER= jaapb@kerguelen.org
-COMMENT= Library to integrate XML features into OCaml
-
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/lang/ocaml:extract
-
-BROKEN= does not build
-DEPRECATED= has been broken for over a year
-EXPIRATION_DATE=2011-04-17
-
-ALL_TARGET= prepare config/Makefile world world.opt
-INSTALL_TARGET= installbyte installopt
-
-.include <bsd.port.pre.mk>
-
-OCAML_WRKSRC!= (cd ${PORTSDIR}/lang/ocaml && ${MAKE} -V WRKSRC)
-
-USE_GMAKE= yes
-USE_OCAML= yes
-MAKE_ENV+= PORTSDIR="${PORTSDIR}" OCAML_SOURCE="${OCAML_WRKSRC}" BINDIR="${LOCALBASE}/bin" SA_DIR="${LOCALBASE}/lib/ocaml/site-lib"
-OCAMLC_DEPEND= ocaml>=3.11.1:${OCAMLC_PORT}
-USE_OCAML_FINDLIB= yes
-USE_OCAML_LDCONFIG= yes
-USE_OCAML_PLIST= yes
-
-.include <bsd.port.post.mk>
diff --git a/lang/ocamlduce/distinfo b/lang/ocamlduce/distinfo
deleted file mode 100644
index d7b33b7c15f7..000000000000
--- a/lang/ocamlduce/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ocamlduce-3.11.1.0.tar.gz) = fd1f92e80b36b1fae028c4d1119dd2ff567001ed09e0ce5634a3497027827d4e
-SIZE (ocamlduce-3.11.1.0.tar.gz) = 138926
diff --git a/lang/ocamlduce/files/patch-Makefile b/lang/ocamlduce/files/patch-Makefile
deleted file mode 100644
index ae74f5db2a1b..000000000000
--- a/lang/ocamlduce/files/patch-Makefile
+++ /dev/null
@@ -1,72 +0,0 @@
---- Makefile.orig 2009-06-13 01:49:38.000000000 +0200
-+++ Makefile 2009-12-21 11:51:23.000000000 +0100
-@@ -1,13 +1,12 @@
- #-include config/Makefile
-
- OCAML_VERSION := $(shell ocamlc -version)
--OCAML_SOURCE := /usr/src/ocaml-source-$(OCAML_VERSION).tar.bz2
- OCAML_SRCDIR := ocaml-$(OCAML_VERSION)
-
- DUCE_VERSION := $(shell head -n1 VERSION)
- DUCE_SRCDIR := ocamlduce-$(DUCE_VERSION)
-
--DUCE_LIBDIR := $(LIBDIR)/ocamlduce
-+DUCE_LIBDIR := $(SA_DIR)/ocamlduce
-
- BASE_BYT := ocamlc ocamldoc/ocamldoc tools/ocamldep
- BYT := ocaml $(BASE_BYT)
-@@ -36,7 +35,7 @@
- @echo "===> Please explicit what you want <==="
-
- prepare:
-- tar xf $(OCAML_SOURCE)
-+ cp -PpR $(OCAML_SOURCE) $(OCAML_SRCDIR)
- cp -PpR $(DUCEP_FILES) $(OCAML_SRCDIR)
- cp -PpR ocamlduce $(OCAML_SRCDIR)/otherlibs
- cd $(OCAML_SRCDIR) && for X in ../patches/*.diff; do patch -p1 < $$X; done
-@@ -46,13 +45,13 @@
-
- config/Makefile:
- @echo "===> You should probably run ./configure yourself, trying on my own... <==="
-- $(shell sed -ne '1s@^.*\(./configure.*\)$$@\1@p' $(shell ocamlc -where)/Makefile.config)
-+ cd $(OCAML_SRCDIR) && $(shell sed -ne '1s@^.*\(./configure.*\)$$@\1@p' $(shell ocamlc -where)/Makefile.config)
-
- world: config/Makefile
-- MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" ./mkocamlduce.sh
-+ cd $(OCAML_SRCDIR) && MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" ./mkocamlduce.sh
-
- world.opt: config/Makefile
-- MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" HAS_NATIVE=y ./mkocamlduce.sh
-+ cd $(OCAML_SRCDIR) && MAKE="$(MAKE)" CFLAGS="$(CFLAGS)" HAS_NATIVE=y ./mkocamlduce.sh
-
- META: META.in
- sed 's/%VER%/$(DUCE_VERSION)/' $< > $@
-@@ -63,20 +62,20 @@
- install -m 755 -d $(DUCE_LIBDIR)
- install -m 755 ocamlducefind $(BINDIR)
- install -m 644 META $(DUCE_LIBDIR)
-- install -m 644 $(addprefix _build/,$(MLI)) $(DUCE_LIBDIR)
-- install -m 644 $(addprefix _build/,$(CMI)) $(DUCE_LIBDIR)
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(MLI)) $(DUCE_LIBDIR)
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMI)) $(DUCE_LIBDIR)
-
- installbyte: installcommon-stamp
- @echo "===> Installing non-native files... <==="
-- for X in $(BYT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 _build/$$X $(BINDIR)/ocamlduce$$Y; done
-- install -m 644 $(addprefix _build/,$(TOPCMO)) $(DUCE_LIBDIR)
-- install -m 644 $(addprefix _build/,$(TOPCMA)) $(DUCE_LIBDIR)
-- install -m 644 $(addprefix _build/,$(CMA)) $(DUCE_LIBDIR)
-+ for X in $(BYT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 $(OCAML_SRCDIR)/_build/$$X $(BINDIR)/ocamlduce$$Y; done
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(TOPCMO)) $(DUCE_LIBDIR)
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(TOPCMA)) $(DUCE_LIBDIR)
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMA)) $(DUCE_LIBDIR)
-
- installopt: installcommon-stamp
- @echo "===> Installing native files... <==="
-- for X in $(OPT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 _build/$$X $(BINDIR)/ocamlduce$$Y; done
-- install -m 644 $(addprefix _build/,$(CMXA)) $(DUCE_LIBDIR)
-+ for X in $(OPT); do Y=$${X##*/}; Y=$${Y#ocaml}; install -m 755 $(OCAML_SRCDIR)/_build/$$X $(BINDIR)/ocamlduce$$Y; done
-+ install -m 644 $(addprefix $(OCAML_SRCDIR)/_build/,$(CMXA)) $(DUCE_LIBDIR)
-
- clean:
- build/distclean.sh
diff --git a/lang/ocamlduce/pkg-descr b/lang/ocamlduce/pkg-descr
deleted file mode 100644
index 9b6e6159d53f..000000000000
--- a/lang/ocamlduce/pkg-descr
+++ /dev/null
@@ -1,3 +0,0 @@
-OCamlDuce is an enhancement to OCaml that allows you to use XML types.
-
-WWW: http://www.cduce.org/ocaml
diff --git a/lang/ocamlduce/pkg-plist b/lang/ocamlduce/pkg-plist
deleted file mode 100644
index 57f44b407a7d..000000000000
--- a/lang/ocamlduce/pkg-plist
+++ /dev/null
@@ -1,24 +0,0 @@
-%%OCAML_SITELIBDIR%%/ocamlduce/META
-%%OCAML_SITELIBDIR%%/ocamlduce/cduce_types.cmi
-%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.a
-%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cma
-%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmi
-%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.cmxa
-%%OCAML_SITELIBDIR%%/ocamlduce/ocamlduce.mli
-%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.cmi
-%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.cmo
-%%OCAML_SITELIBDIR%%/ocamlduce/topdirs.mli
-%%OCAML_SITELIBDIR%%/ocamlduce/toplevellib.cma
-%%OCAML_SITELIBDIR%%/ocamlduce/toploop.cmi
-%%OCAML_SITELIBDIR%%/ocamlduce/toploop.cmo
-%%OCAML_SITELIBDIR%%/ocamlduce/toploop.mli
-%%OCAML_SITELIBDIR%%/ocamlduce/topmain.cmi
-%%OCAML_SITELIBDIR%%/ocamlduce/topmain.cmo
-%%OCAML_SITELIBDIR%%/ocamlduce/topmain.mli
-%%OCAML_SITELIBDIR%%/ocamlduce/topstart.cmo
-bin/ocamlducec
-bin/ocamlduce
-bin/ocamlducedep
-bin/ocamlducedoc
-bin/ocamlduceopt
-bin/ocamlducefind