aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2019-08-15 16:14:22 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2019-08-15 16:14:22 +0000
commit7f1c1de732aa3fc6d43be7f4293e961acecad4f0 (patch)
tree1e508a5f12aa01b0e8212f3c41842b2bc5673f4e /lang
parent4b5930e48a6f56f3b6ed302f77a648181f48eaf3 (diff)
downloadports-7f1c1de732aa3fc6d43be7f4293e961acecad4f0.tar.gz
ports-7f1c1de732aa3fc6d43be7f4293e961acecad4f0.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/fpc-source/Makefile33
-rw-r--r--lang/fpc-source/distinfo3
-rw-r--r--lang/fpc-source/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 581e40fc7845..8e7087a12ab5 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -91,6 +91,7 @@
SUBDIR += fpc-rtl-extra
SUBDIR += fpc-rtl-objpas
SUBDIR += fpc-rtl-unicode
+ SUBDIR += fpc-source
SUBDIR += fpc-units
SUBDIR += fpc-utils
SUBDIR += fsharp
diff --git a/lang/fpc-source/Makefile b/lang/fpc-source/Makefile
new file mode 100644
index 000000000000..eabf8191c28c
--- /dev/null
+++ b/lang/fpc-source/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= fpc
+PORTVERSION= 3.0.4
+DISTVERSIONSUFFIX=.source
+CATEGORIES= lang
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
+ ftp://planetmirror.com/pub/fpc/dist/${PORTVERSION}/source/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/${PORTVERSION}/source/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/${PORTVERSION}/source/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/${PORTVERSION}/source/ \
+ SF/freepascal/Source/${PORTVERSION}
+PKGNAMESUFFIX= -source
+DIST_SUBDIR= freepascal
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal compiler with Turbo and Delphi (source)
+
+ONLY_FOR_ARCHS= amd64 i386
+NO_BUILD= yes
+
+PORTDATA= *
+
+PATCHDIR= ${PORTSDIR}/lang/fpc/files
+DATADIR= ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+do-install:
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . \
+ ${STAGEDIR}${DATADIR})
+
+.include <bsd.port.mk>
diff --git a/lang/fpc-source/distinfo b/lang/fpc-source/distinfo
new file mode 100644
index 000000000000..8abef10bde36
--- /dev/null
+++ b/lang/fpc-source/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565829645
+SHA256 (freepascal/fpc-3.0.4.source.tar.gz) = 69b3b7667b72b6759cf27226df5eb54112ce3515ff5efb79d95ac14bac742845
+SIZE (freepascal/fpc-3.0.4.source.tar.gz) = 40347617
diff --git a/lang/fpc-source/pkg-descr b/lang/fpc-source/pkg-descr
new file mode 100644
index 000000000000..60edfc59f71a
--- /dev/null
+++ b/lang/fpc-source/pkg-descr
@@ -0,0 +1,6 @@
+Originally named FPK-Pascal, the Free Pascal compiler is a 32 bit and 64 bit
+Turbo Pascal compatible Pascal compiler for DOS, Linux, Win32, OS/2,
+(based on an older version) the AmigaOS, FreeBSD/ELF, BeOS, Darwin(OSX)
+and others (source code).
+
+WWW: https://www.freepascal.org/