aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-06-15 14:54:57 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-06-15 14:54:57 +0000
commit89fae5eb69ede1baa916e21646afac9d7e88790e (patch)
treebe053145f068d496d128941a7de272b7355482da /lang
parent041e6a2b5e9b9ee6df167cbf0083e569ba9ef913 (diff)
downloadports-89fae5eb69ede1baa916e21646afac9d7e88790e.tar.gz
ports-89fae5eb69ede1baa916e21646afac9d7e88790e.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/Makefile1
-rw-r--r--lang/arena/Makefile19
-rw-r--r--lang/arena/distinfo3
-rw-r--r--lang/arena/pkg-descr15
-rw-r--r--lang/arena/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index 0d8bfabdfae4..dae6647cb602 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -9,6 +9,7 @@
SUBDIR += TenDRA
SUBDIR += afnix
SUBDIR += alisp
+ SUBDIR += arena
SUBDIR += asn1c
SUBDIR += atlast
SUBDIR += awka
diff --git a/lang/arena/Makefile b/lang/arena/Makefile
new file mode 100644
index 000000000000..11e7cc2c6988
--- /dev/null
+++ b/lang/arena/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: arena
+# Date created: 2006-06-15
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arena
+PORTVERSION= 0.9.2
+CATEGORIES= lang
+MASTER_SITES= http://www.minimalinux.org/arena/
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= C-like scripting language with automatic memory management
+
+GNU_CONFIGURE= yes
+MAN1= arena.1
+
+.include <bsd.port.mk>
diff --git a/lang/arena/distinfo b/lang/arena/distinfo
new file mode 100644
index 000000000000..efe357fc2683
--- /dev/null
+++ b/lang/arena/distinfo
@@ -0,0 +1,3 @@
+MD5 (arena-0.9.2.tar.gz) = e8edf4ae6b1bd320e43b14a6ea047015
+SHA256 (arena-0.9.2.tar.gz) = 7c23ec263fb88b1603e51b7573b47d19189d43121ba75bbc185705e46de9fc44
+SIZE (arena-0.9.2.tar.gz) = 190841
diff --git a/lang/arena/pkg-descr b/lang/arena/pkg-descr
new file mode 100644
index 000000000000..fd98d8b44431
--- /dev/null
+++ b/lang/arena/pkg-descr
@@ -0,0 +1,15 @@
+The Arena language was designed with the following main features in mind,
+most of which were added on top of a very C-like core to support better
+ad-hoc scripting:
+
+ * syntax similar to ANSI C
+ * standard library similar to ANSI C
+ * automatic memory management
+ * runtime polymorphism
+ * support for exceptions
+ * support for anonymous functions
+
+Additionally, an interpreter for the Arena language can be implemented
+to be very compact in terms of both source code size and memory consumption.
+
+WWW: http://www.minimalinux.org/arena/
diff --git a/lang/arena/pkg-plist b/lang/arena/pkg-plist
new file mode 100644
index 000000000000..9b4fa5a78d0f
--- /dev/null
+++ b/lang/arena/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+bin/arena
+%%DOCSDIR%%/manual.asc
+%%DOCSDIR%%/transform
+@dirrm %%DOCSDIR%%