aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMichael Moll <mmoll@FreeBSD.org>2015-10-25 00:21:23 +0000
committerMichael Moll <mmoll@FreeBSD.org>2015-10-25 00:21:23 +0000
commit9e4f8bdd8b71c7b699065b55e99782765b418df8 (patch)
tree79702fa4c7a1bbd3a9f3902384b2fef77189a918 /lang
parent97cb359803d8a24f1305db089732c73afb2b3b4e (diff)
downloadports-9e4f8bdd8b71c7b699065b55e99782765b418df8.tar.gz
ports-9e4f8bdd8b71c7b699065b55e99782765b418df8.zip
lang/ruby2*: fix readline & libedit configure options
The fixed error(s) were only visible with LOCALBASE not set to /usr/local. PR: 203988 Submitted by: John Hein <z7dr6ut7gs@snkmail.com>
Notes
Notes: svn path=/head/; revision=400142
Diffstat (limited to 'lang')
-rw-r--r--lang/ruby20/Makefile4
-rw-r--r--lang/ruby20/files/patch-ext_readline_extconf.rb14
-rw-r--r--lang/ruby21/Makefile4
-rw-r--r--lang/ruby21/files/patch-ext_readline_extconf.rb14
-rw-r--r--lang/ruby22/Makefile4
-rw-r--r--lang/ruby22/files/patch-ext_readline_extconf.rb14
6 files changed, 39 insertions, 15 deletions
diff --git a/lang/ruby20/Makefile b/lang/ruby20/Makefile
index 367bda6d9472..2daad5ac124e 100644
--- a/lang/ruby20/Makefile
+++ b/lang/ruby20/Makefile
@@ -59,11 +59,11 @@ CAPIDOCS_BUILD_DEPENDS= doxygen>0:${PORTSDIR}/devel/doxygen \
dot:${PORTSDIR}/graphics/graphviz
CAPIDOCS_CONFIGURE_ENABLE= install-capi
LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
-LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-prefix=${LOCALBASE}
+LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LIBEDITPREFIX}
LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
-READLINE_CONFIGURE_ON= --disable-libedit --with-readline-prefix=${LOCALBASE}
+READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${READLINEPREFIX}
READLINE_RUN_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
CPE_VENDOR= ruby-lang
diff --git a/lang/ruby20/files/patch-ext_readline_extconf.rb b/lang/ruby20/files/patch-ext_readline_extconf.rb
index 1dc60bf099c3..1eed0c2b49ba 100644
--- a/lang/ruby20/files/patch-ext_readline_extconf.rb
+++ b/lang/ruby20/files/patch-ext_readline_extconf.rb
@@ -1,6 +1,14 @@
---- ext/readline/extconf.rb.orig 2014-04-30 07:39:45 UTC
-+++ ext/readline/extconf.rb
-@@ -62,7 +62,7 @@ else
+--- ext/readline/extconf.rb.orig 2014-05-01 11:59:37.000000000 +0000
++++ ext/readline/extconf.rb 2015-10-23 04:05:44.000000000 +0000
+@@ -37,6 +37,7 @@
+ case enable_libedit
+ when true
+ # --enable-libedit
++ dir_config("libedit")
+ unless (readline.have_header("editline/readline.h") ||
+ readline.have_header("readline/readline.h")) &&
+ have_library("edit", "readline")
+@@ -62,7 +63,7 @@ else
end
readline.have_func("rl_getc")
diff --git a/lang/ruby21/Makefile b/lang/ruby21/Makefile
index dc79355859d6..4e2f4d0eb3ad 100644
--- a/lang/ruby21/Makefile
+++ b/lang/ruby21/Makefile
@@ -62,11 +62,11 @@ CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
-LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-prefix=${LOCALBASE}
+LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LIBEDITPREFIX}
LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
-READLINE_CONFIGURE_ON= --disable-libedit --with-readline-prefix=${LOCALBASE}
+READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${READLINEPREFIX}
READLINE_RUN_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
CPE_VENDOR= ruby-lang
diff --git a/lang/ruby21/files/patch-ext_readline_extconf.rb b/lang/ruby21/files/patch-ext_readline_extconf.rb
index 96a330b5b3ad..1eed0c2b49ba 100644
--- a/lang/ruby21/files/patch-ext_readline_extconf.rb
+++ b/lang/ruby21/files/patch-ext_readline_extconf.rb
@@ -1,6 +1,14 @@
---- ext/readline/extconf.rb.orig 2015-01-23 15:37:01 UTC
-+++ ext/readline/extconf.rb
-@@ -62,7 +62,7 @@ else
+--- ext/readline/extconf.rb.orig 2014-05-01 11:59:37.000000000 +0000
++++ ext/readline/extconf.rb 2015-10-23 04:05:44.000000000 +0000
+@@ -37,6 +37,7 @@
+ case enable_libedit
+ when true
+ # --enable-libedit
++ dir_config("libedit")
+ unless (readline.have_header("editline/readline.h") ||
+ readline.have_header("readline/readline.h")) &&
+ have_library("edit", "readline")
+@@ -62,7 +63,7 @@ else
end
readline.have_func("rl_getc")
diff --git a/lang/ruby22/Makefile b/lang/ruby22/Makefile
index a762f7f81faf..ee111e569d7b 100644
--- a/lang/ruby22/Makefile
+++ b/lang/ruby22/Makefile
@@ -62,11 +62,11 @@ CAPIDOCS_CONFIGURE_ENABLE= install-capi
GMP_CONFIGURE_WITH= gmp
GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
LIBEDIT_BUILD_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
-LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-prefix=${LOCALBASE}
+LIBEDIT_CONFIGURE_ON= --enable-libedit --with-libedit-dir=${LIBEDITPREFIX}
LIBEDIT_RUN_DEPENDS= libedit>=0:${PORTSDIR}/devel/libedit
RDOC_CONFIGURE_ENABLE= install-rdoc
READLINE_BUILD_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
-READLINE_CONFIGURE_ON= --disable-libedit --with-readline-prefix=${LOCALBASE}
+READLINE_CONFIGURE_ON= --disable-libedit --with-readline-dir=${READLINEPREFIX}
READLINE_RUN_DEPENDS= readline>=0:${PORTSDIR}/devel/readline
CPE_VENDOR= ruby-lang
diff --git a/lang/ruby22/files/patch-ext_readline_extconf.rb b/lang/ruby22/files/patch-ext_readline_extconf.rb
index 6bcedb6db89e..1eed0c2b49ba 100644
--- a/lang/ruby22/files/patch-ext_readline_extconf.rb
+++ b/lang/ruby22/files/patch-ext_readline_extconf.rb
@@ -1,6 +1,14 @@
---- ext/readline/extconf.rb.orig 2015-01-16 23:05:12 UTC
-+++ ext/readline/extconf.rb
-@@ -62,7 +62,7 @@ else
+--- ext/readline/extconf.rb.orig 2014-05-01 11:59:37.000000000 +0000
++++ ext/readline/extconf.rb 2015-10-23 04:05:44.000000000 +0000
+@@ -37,6 +37,7 @@
+ case enable_libedit
+ when true
+ # --enable-libedit
++ dir_config("libedit")
+ unless (readline.have_header("editline/readline.h") ||
+ readline.have_header("readline/readline.h")) &&
+ have_library("edit", "readline")
+@@ -62,7 +63,7 @@ else
end
readline.have_func("rl_getc")