aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-24 20:23:06 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-07-24 20:23:06 +0000
commita0e02daf64cc89ceb2b068c143bcca27d67e0a21 (patch)
tree982ce6bd0645d974daac491c8058541392d3bb89 /lang
parentb7f8a1602e5c811f5496e48d6fffda66206a49bd (diff)
downloadports-a0e02daf64cc89ceb2b068c143bcca27d67e0a21.tar.gz
ports-a0e02daf64cc89ceb2b068c143bcca27d67e0a21.zip
lang/python3: Clean up
- Remove leading definite article from COMMENT - Update USES=python - Remove unneeded use of PYTHON_MAJOR_VER because this is for python 3.x - Merge the symbolic link of 2to3 and python to the .for loop
Diffstat (limited to 'lang')
-rw-r--r--lang/python3/Makefile36
1 files changed, 16 insertions, 20 deletions
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index b371a0f3be83..088617005054 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -1,38 +1,34 @@
PORTNAME= python3
-PORTVERSION= ${PYTHON_MAJOR_VER}
+PORTVERSION= 3
PORTREVISION= 3
CATEGORIES= lang python
-MASTER_SITES=
-DISTFILES=
-EXTRACT_ONLY=
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
MAINTAINER= python@FreeBSD.org
-COMMENT= The "meta-port" for version 3 of the Python interpreter
+COMMENT= Meta-port for the Python interpreter 3.x
-USES= python:3.5+,run
+USES= python:3.6+,run
NO_ARCH= yes
NO_BUILD= yes
-PLIST_FILES= bin/2to3-${PYTHON_MAJOR_VER} \
- bin/idle${PYTHON_MAJOR_VER} \
- bin/pydoc${PYTHON_MAJOR_VER} \
- bin/python${PYTHON_MAJOR_VER} \
- bin/python${PYTHON_MAJOR_VER}-config \
- libdata/pkgconfig/python${PYTHON_MAJOR_VER}.pc
+PLIST_FILES= bin/2to3-3 \
+ bin/idle3 \
+ bin/pydoc3 \
+ bin/python3 \
+ bin/python3-config \
+ libdata/pkgconfig/python3.pc
do-install:
- ${LN} -sf python${PYTHON_VER} \
- ${STAGEDIR}${PREFIX}/bin/python${PYTHON_MAJOR_VER}
- ${LN} -sf 2to3-${PYTHON_VER} \
- ${STAGEDIR}${PREFIX}/bin/2to3-${PYTHON_MAJOR_VER}
-.for file in idle pydoc
+.for file in 2to3- idle pydoc python
${LN} -sf ${file}${PYTHON_VER} \
- ${STAGEDIR}${PREFIX}/bin/${file}${PYTHON_MAJOR_VER}
+ ${STAGEDIR}${PREFIX}/bin/${file}3
.endfor
${LN} -sf python${PYTHON_VER}-config \
- ${STAGEDIR}${PREFIX}/bin/python${PYTHON_MAJOR_VER}-config
+ ${STAGEDIR}${PREFIX}/bin/python3-config
${LN} -sf python-${PYTHON_VER}.pc \
- ${STAGEDIR}${PREFIX}/libdata/pkgconfig/python${PYTHON_MAJOR_VER}.pc
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig/python3.pc
.include <bsd.port.mk>