aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-15 06:46:31 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-15 06:46:31 +0000
commita800fd141c4bd0f89bf6d27d7ffbac24862e8cf5 (patch)
tree3ac246990932b59583df8cf78fbffd735f34ac90 /lang
parent6e9e4f7522f5383613e59df98244ac0990ea2563 (diff)
downloadports-a800fd141c4bd0f89bf6d27d7ffbac24862e8cf5.tar.gz
ports-a800fd141c4bd0f89bf6d27d7ffbac24862e8cf5.zip
lang/opencoarrays: Simplify handling of GCC versions
GCC_DEFAULT now is at least 8, so we can simplify this port and remove special casing for GCC versions 6 and 7. Approved by: maintainer timeout (four months / 11 weeks)
Diffstat (limited to 'lang')
-rw-r--r--lang/opencoarrays/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/lang/opencoarrays/Makefile b/lang/opencoarrays/Makefile
index c1fc30a961fd..4a2d2e74e63b 100644
--- a/lang/opencoarrays/Makefile
+++ b/lang/opencoarrays/Makefile
@@ -24,7 +24,7 @@ GH_ACCOUNT= sourceryinstitute
GH_PROJECT= OpenCoarrays
USE_LDCONFIG= yes
-PLIST_SUB= GCC_VER=${_GCC_VER} PORTVERSION=${PORTVERSION}
+PLIST_SUB= GCC_VER=${_GCC_VER} PORTVERSION=${PORTVERSION} SOVERSION=3
OPTIONS_SINGLE= MPI
OPTIONS_SINGLE_MPI= MPICH OPENMPI
@@ -42,16 +42,6 @@ OPENMPI_CMAKE_ON= -DMPI_C_COMPILE_OPTIONS="-lpthread" \
.include <bsd.port.options.mk>
-.if ${GCC_DEFAULT} >= 8
-PLIST_SUB+= SOVERSION=3
-.elif ${GCC_DEFAULT} == 7
-PLIST_SUB+= SOVERSION=2
-.elif ${GCC_DEFAULT} == 6
-PLIST_SUB+= SOVERSION=1
-.else
-IGNORE= requires GCC 6 or higher
-.endif
-
post-patch:
@${REINPLACE_CMD} '/mod_dir_tail/s/$${CMAKE_Fortran_COMPILER_VERSION}/${_GCC_VER}/' \
${WRKSRC}/CMakeLists.txt