aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-23 13:59:17 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-11-23 22:02:57 +0000
commitcea1194ae5f2bfa34526d25e6908fcd9d1698c0c (patch)
treec9e28d45c5df83a2acdb1271fca3460a0fed7f3e /lang
parent8667a82724a9c7d2560c438d98f23990d08a08eb (diff)
downloadports-cea1194ae5f2bfa34526d25e6908fcd9d1698c0c.tar.gz
ports-cea1194ae5f2bfa34526d25e6908fcd9d1698c0c.zip
Diffstat (limited to 'lang')
-rw-r--r--lang/php82/Makefile45
-rw-r--r--lang/php82/distinfo6
-rw-r--r--lang/php82/pkg-plist7
3 files changed, 20 insertions, 38 deletions
diff --git a/lang/php82/Makefile b/lang/php82/Makefile
index ba4329806f88..11d8c1102f8d 100644
--- a/lang/php82/Makefile
+++ b/lang/php82/Makefile
@@ -1,5 +1,5 @@
PORTNAME= php82
-DISTVERSION= 8.2.12
+DISTVERSION= 8.2.13
PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= PHP/distributions
@@ -11,13 +11,14 @@ WWW= https://www.php.net/
LICENSE= PHP301
-USES+= compiler:c11 cpe gnome pkgconfig tar:xz
+USES+= compiler:c11 cpe gnome localbase pkgconfig tar:xz
CPE_PRODUCT= php
PHP_VER= 82
CONFLICTS_INSTALL?= php[0-9][0-9]${PKGNAMESUFFIX}
.if !defined(PKGNAMESUFFIX)
+BUILD_DEPENDS= re2c>0:devel/re2c
LIB_DEPENDS= libargon2.so:security/libargon2 \
libpcre2-8.so:devel/pcre2
@@ -28,14 +29,12 @@ CONFIGURE_ARGS+= --disable-all \
--with-layout=GNU \
--with-libxml \
--with-openssl \
- --with-password-argon2=${LOCALBASE}
-DESTDIRNAME= INSTALL_ROOT
+ --with-password-argon2=${LOCALBASE} \
+ --with-external-pcre=${LOCALBASE}
USES+= autoreconf:build ssl
USE_GNOME= libxml2
-CPPFLAGS= -I${LOCALBASE}/include
-
LDFLAGS= -L${OPENSSLLIB} -lcrypto -lssl
# PR230207 Allow relocations against read-only segments (override lld default)
LDFLAGS_i386= -Wl,-z,notext
@@ -89,6 +88,8 @@ PHPDBG_VARS= PHP_SAPI+=phpdbg
ZTS_CONFIGURE_ON= --enable-zts
ZTS_CONFIGURE_ENV= pthreads_working="yes"
+DESTDIRNAME= INSTALL_ROOT
+
.if defined(PKGNAMEPREFIX)
USES+= apache
PLIST= ${PKGDIR}/pkg-plist.mod
@@ -146,12 +147,12 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/php.ini-development ${WRKSRC}/php.ini-production \
${WRKDIR}/php.conf ${STAGEDIR}/${PREFIX}/etc
-post-install-CLI-on:
- ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php
-
post-install-CGI-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php-cgi
+post-install-CLI-on:
+ ${STRIP_CMD} ${STAGEDIR}/${PREFIX}/bin/php
+
post-install-EMBED-on:
${STRIP_CMD} ${STAGEDIR}/${PREFIX}/lib/libphp.so
@@ -230,8 +231,8 @@ DB4_CONFIGURE_ON= --with-db4=${LOCALBASE}
DB4_USES= bdb
DB4_VARS= WITH_BDB_HIGHEST=yes
FLATFILE_CONFIGURE_ON= --disable-flatfile
-GDBM_CONFIGURE_ARGS= --with-gdbm=${LOCALBASE}
GDBM_LIB_DEPENDS= libgdbm.so:databases/gdbm
+GDBM_CONFIGURE_ARGS= --with-gdbm=${LOCALBASE}
INIFILE_CONFIGURE_OFF= --disable-inifile
LMDB_LIB_DEPENDS= liblmdb.so:databases/lmdb
LMDB_CONFIGURE_ARGS= --with-lmdb=${LOCALBASE}
@@ -251,7 +252,7 @@ USE_GNOME= libxml2
.endif
.if ${PHP_MODNAME} == "enchant"
-LIB_DEPENDS+= libenchant.so:textproc/enchant
+LIB_DEPENDS+= libenchant-2.so:textproc/enchant2
CONFIGURE_ARGS+= --with-enchant=${LOCALBASE}
USES+= pkgconfig
.endif
@@ -331,13 +332,7 @@ USES+= iconv:translit
.if ${PHP_MODNAME} == "imap"
PHP_MOD_PRIO= 30
-OPTIONS_RADIO= CLIENT
-OPTIONS_RADIO_CLIENT= CCLIENT PANDA
-OPTIONS_DEFAULT= PANDA
-CCLIENT_DESC= Uses the original but unmaintained cclient
-PANDA_DESC= Uses the forked panda-cclient instead of the original cclient
-PANDA_LIB_DEPENDS= libc-client.so.2010:mail/panda-cclient
-PANDA_LIB_DEPENDS_OFF= libc-client4.so.9:mail/cclient
+LIB_DEPENDS+= libc-client.so.2010:mail/panda-cclient
CONFIGURE_ARGS+= --with-imap-ssl=${OPENSSLBASE} \
--with-imap=${LOCALBASE}
@@ -382,13 +377,7 @@ PHP_HEADER_DIRS= libmbfl libmbfl/filters libmbfl/mbfl libmbfl/nls
.endif
.if ${PHP_MODNAME} == "mysqli"
-OPTIONS_DEFINE= MYSQLND
-OPTIONS_DEFAULT= MYSQLND
-
-MYSQLND_DESC= Use MySQL Native Driver
-MYSQLND_CONFIGURE_ON= --with-mysqli=mysqlnd
-MYSQLND_CONFIGURE_OFF= --with-mysqli=${LOCALBASE}/bin/mysql_config
-MYSQLND_USES_OFF= mysql
+CONFIGURE_ARGS+= --with-mysqli
.endif
.if ${PHP_MODNAME} == "odbc"
@@ -444,10 +433,10 @@ OPTIONS_DEFAULT= MYSQLND
MYSQLND_DESC= Use MySQL Native Driver
+MYSQLND_CONFIGURE_ON= --with-pdo-mysql=mysqlnd
MYSQLND_CONFIGURE_OFF= --with-pdo-mysql=${LOCALBASE} \
--with-zlib-dir=/usr
MYSQLND_USES_OFF= mysql
-MYSQLND_CONFIGURE_ON= --with-pdo-mysql=mysqlnd
USE_PHP= pdo:build
.endif
@@ -488,8 +477,8 @@ CONFIGURE_ARGS+= --with-pspell=${LOCALBASE}
.endif
.if ${PHP_MODNAME} == "readline"
-CONFIGURE_ARGS+= --with-readline=/usr
-USES+= readline
+CONFIGURE_ARGS+=--with-libedit
+USES+= libedit
.endif
.if ${PHP_MODNAME} == "session"
diff --git a/lang/php82/distinfo b/lang/php82/distinfo
index ab36cb22c7ab..122e2bc243d9 100644
--- a/lang/php82/distinfo
+++ b/lang/php82/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1698354721
-SHA256 (php-8.2.12.tar.xz) = e1526e400bce9f9f9f774603cfac6b72b5e8f89fa66971ebc3cc4e5964083132
-SIZE (php-8.2.12.tar.xz) = 12048788
+TIMESTAMP = 1700689026
+SHA256 (php-8.2.13.tar.xz) = 2629bba10117bf78912068a230c68a8fd09b7740267bd8ebd3cfce91515d454b
+SIZE (php-8.2.13.tar.xz) = 12069092
diff --git a/lang/php82/pkg-plist b/lang/php82/pkg-plist
index 7014f48f577c..2653280ebfc1 100644
--- a/lang/php82/pkg-plist
+++ b/lang/php82/pkg-plist
@@ -165,13 +165,6 @@ include/php/ext/libxml/php_libxml.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_vio.h
%%MYSQLND%%include/php/ext/mysqlnd/mysqlnd_wireprotocol.h
%%MYSQLND%%include/php/ext/mysqlnd/php_mysqlnd.h
-include/php/ext/pcre/pcre2lib/config.h
-include/php/ext/pcre/pcre2lib/pcre2.h
-include/php/ext/pcre/pcre2lib/pcre2_internal.h
-include/php/ext/pcre/pcre2lib/pcre2_intmodedep.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_neon_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_jit_simd_inc.h
-include/php/ext/pcre/pcre2lib/pcre2_ucp.h
include/php/ext/pcre/php_pcre.h
include/php/ext/random/php_random.h
include/php/ext/spl/php_spl.h