aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-13 04:17:05 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-13 04:17:05 +0000
commitcfec7b5b3d9ddcae5154d8633858b4ad1e366115 (patch)
treeb612936fb3442b55e354f44149adcc137c0ff774 /lang
parent81b33695b174912a5b41b33f29a433fa92c13aae (diff)
downloadports-cfec7b5b3d9ddcae5154d8633858b4ad1e366115.tar.gz
ports-cfec7b5b3d9ddcae5154d8633858b4ad1e366115.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/ici/Makefile2
-rw-r--r--lang/ici/files/patch-Makefile.bsd29
-rw-r--r--lang/ici/files/patch-cfunc.c20
-rw-r--r--lang/ici/files/patch-syscall.c17
4 files changed, 67 insertions, 1 deletions
diff --git a/lang/ici/Makefile b/lang/ici/Makefile
index e7cbcbbeb869..58f9121b4bf8 100644
--- a/lang/ici/Makefile
+++ b/lang/ici/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= lang
MASTER_SITES= http://www.zeta.org.au/~atrn/ici/distfiles/
MAINTAINER= atrn@zeta.org.au
-COMMENT= An interpretive language with C's overall feel combined with high level data types
+COMMENT= An interpretive language with C's feel and high level data types
MAKEFILE= Makefile.bsd
MAN1= ici3.1
diff --git a/lang/ici/files/patch-Makefile.bsd b/lang/ici/files/patch-Makefile.bsd
new file mode 100644
index 000000000000..dc4dcdc8d290
--- /dev/null
+++ b/lang/ici/files/patch-Makefile.bsd
@@ -0,0 +1,29 @@
+--- Makefile.bsd Thu Apr 19 19:31:12 2001
++++ Makefile.bsd Mon Jan 26 10:39:43 2004
+@@ -21,7 +21,7 @@
+ findpath.c float.c forall.c\
+ func.c icimain.c init.c int.c lex.c load.c main.c mark.c mem.c\
+ method.c mkvar.c nptrs.c null.c object.c oofuncs.c op.c parse.c pc.c\
+- ptr.c refuncs.o regexp.c set.c\
++ ptr.c refuncs.c regexp.c set.c\
+ sfile.c signals.c skt.c smash.c src.c sstring.c string.c\
+ struct.c syscall.c syserr.c ti.c trace.c unary.c uninit.c win.c\
+ wrap.c buf.c strtol.c idb.c idb2.c profile.c win32err.c
+@@ -59,16 +59,13 @@
+ DOCS=\
+ doc/ici-a4.ps doc/ici-ltr.ps doc/ici.txt
+
+-beforeinstall: ici3.1.gz
++beforeinstall:
+ @echo '=========================================='
+ @echo 'Installing ici interpreter and manual page'
+ @echo '=========================================='
+
+ ici3.1: $(MAN1)
+ ln -sf $(MAN1) $@
+-
+-ici3.1.gz: ici3.1
+- gzip -c ici3.1 > $@
+
+ libici3.a: $(OBJS)
+ $(AR) r libici3.a $(OBJS)
diff --git a/lang/ici/files/patch-cfunc.c b/lang/ici/files/patch-cfunc.c
new file mode 100644
index 000000000000..4a788496fac9
--- /dev/null
+++ b/lang/ici/files/patch-cfunc.c
@@ -0,0 +1,20 @@
+--- cfunc.c Mon Jan 26 10:37:06 2004
++++ cfunc.c Mon Jan 26 10:41:23 2004
+@@ -1378,7 +1378,7 @@
+ register char *p;
+ register int i; /* Where we are up to in buf. */
+ register int j;
+- int which;
++ long which;
+ int nargs;
+ char subfmt[40]; /* %...? portion of string. */
+ int stars[2]; /* Precision and field widths. */
+@@ -1395,7 +1395,7 @@
+ #define IPLUSEQ i +=
+ #endif
+
+- which = (int)CF_ARG1(); /* sprintf, printf, fprintf */
++ which = (long)CF_ARG1(); /* sprintf, printf, fprintf */
+ if (which != 0 && NARGS() > 0 && isfile(ARG(0)))
+ {
+ which = 2;
diff --git a/lang/ici/files/patch-syscall.c b/lang/ici/files/patch-syscall.c
new file mode 100644
index 000000000000..3de76dc2651d
--- /dev/null
+++ b/lang/ici/files/patch-syscall.c
@@ -0,0 +1,17 @@
+--- syscall.c Mon Jan 26 10:37:06 2004
++++ syscall.c Mon Jan 26 10:40:55 2004
+@@ -510,9 +510,13 @@
+ f_ctime(void)
+ {
+ long timev;
++ time_t timet;
+ string_t *s;
+
+- if (ici_typecheck("i", &timev) || (s = new_cname(ctime(&timev))) == NULL)
++ if (ici_typecheck("i", &timev))
++ return 1;
++ timet = timev;
++ if ((s = new_cname(ctime(&timet))) == NULL)
+ return 1;
+ return ici_ret_with_decref(objof(s));
+ }