aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-10-15 17:28:22 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-10-15 17:28:22 +0000
commitd0a0649cdc940991d1841431db82172fd446ad9c (patch)
tree8f01635a5b255b6b74a439c2a079413dd77a9f13 /lang
parent657fc569a75398db985c6e3e4f5e8480c7fa759d (diff)
downloadports-d0a0649cdc940991d1841431db82172fd446ad9c.tar.gz
ports-d0a0649cdc940991d1841431db82172fd446ad9c.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/lua53/Makefile106
-rw-r--r--lang/lua53/distinfo6
-rw-r--r--lang/lua53/files/patch-src_Makefile (renamed from lang/lua53/files/patch-src__Makefile)0
-rw-r--r--lang/lua53/pkg-plist28
4 files changed, 69 insertions, 71 deletions
diff --git a/lang/lua53/Makefile b/lang/lua53/Makefile
index 059f03f3e5cf..14a50e1f8ca2 100644
--- a/lang/lua53/Makefile
+++ b/lang/lua53/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= lua
-DISTVERSION= 5.3.5
-PORTREVISION= 3
+DISTVERSION= 5.3.6
CATEGORIES= lang
MASTER_SITES= https://www.lua.org/ftp/
-PKGNAMESUFFIX= 53
+PKGNAMESUFFIX= ${LUA_VER_STR}
MAINTAINER= russ.haley@gmail.com
COMMENT= Powerful, efficient, lightweight, embeddable scripting language
@@ -24,7 +23,37 @@ USE_LDCONFIG= yes
# See http://wiki.freebsd.org/MatthiasAndree/LuaLessonsLearnt
MAKE_ARGS= __MAKE_CONF=${NONEXISTENT}
-BUILD_WRKSRC= ${WRKSRC}/src
+# using the "bsd" target rather than "freebsd" saves patching out the
+# assumption of using base libedit in order to make it configurable. "bsd"
+# is "generic" plus the POSIX and DLOPEN options, plus -Wl,-E at link time;
+# it doesn't set CC either, which makes it easier for us to control that too.
+ALL_TARGET=bsd
+
+LUA_LIB_STATIC= liblua-${LUA_VER}.a
+LUA_LIB_SHARED= liblua-${LUA_VER}.so
+LUA_PC_FILE= lua-${LUA_VER}.pc
+
+CFLAGS+= -fPIC
+# 2019-01-25: -pthread in LIBS is a work around for the following bug:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235211
+LIBS+= -pthread
+
+WITHOUT_NO_STRICT_ALIASING=yes
+
+MAKE_ARGS+= CC="${CC}" \
+ MYCFLAGS="${CPPFLAGS} ${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS}" \
+ MYLIBS="${LIBS}" \
+ LUA_T=${LUA_CMD} \
+ LUAC_T=${LUAC_CMD} \
+ LUA_A=${LUA_LIB_STATIC} \
+ LUA_SO=${LUA_LIB_SHARED} \
+ LUA_SONAME=${LUA_LIB_SHARED} \
+ TO_BIN="${LUA_CMD} ${LUAC_CMD}" \
+ TO_LIB="${LUA_LIB_SHARED} ${LUA_LIB_STATIC}" \
+ INSTALL_TOP=${STAGEDIR}${PREFIX} \
+ INSTALL_INC=${STAGEDIR}${LUA_INCDIR} \
+ INSTALL_EXEC="${INSTALL_PROGRAM}"
# Source, destination, and filenames to copy for the DOCS option
# (automatically added to pkg-plist if DOCS is set)
@@ -33,95 +62,64 @@ BUILD_WRKSRC= ${WRKSRC}/src
# so that ports for Lua modules can use the version subdir too without
# making a mess.
DOCSDIR= ${LUA_DOCSDIR}
-PORTDOCS= *
BUILD_WRKDOC= ${WRKSRC}/doc
-LUA_LIB_STATIC= liblua-${LUA_VER}.a
-LUA_LIB_SHARED= liblua-${LUA_VER}.so
-LUA_PC_FILE= lua-${LUA_VER}.pc
+SUB_FILES= ${LUA_PC_FILE}
+SUB_LIST= version=${PORTVERSION} \
+ includedir=${LUA_INCDIR} \
+ libdir=${LUA_LIBDIR} \
+ soname=lua-${LUA_VER}
-# using the "bsd" target rather than "freebsd" saves patching out the
-# assumption of using base libedit in order to make it configurable. "bsd"
-# is "generic" plus the POSIX and DLOPEN options, plus -Wl,-E at link time;
-# it doesn't set CC either, which makes it easier for us to control that too.
-ALL_TARGET=bsd
+BUILD_WRKSRC= ${WRKSRC}/src
-# Options
+PORTDOCS= *
-OPTIONS_DEFAULT=LIBEDIT_DL
+# Options
-OPTIONS_GROUP= DOCSGRP DEBUGGRP
-OPTIONS_SINGLE= EDITGRP
+OPTIONS_DEFAULT= LIBEDIT_DL
-OPTIONS_GROUP_DOCSGRP= DOCS
+OPTIONS_GROUP= DOCSGRP DEBUGGRP
OPTIONS_GROUP_DEBUGGRP= ASSERT APICHECK
+OPTIONS_GROUP_DOCSGRP= DOCS
+OPTIONS_SINGLE= EDITGRP
OPTIONS_SINGLE_EDITGRP= EDITNONE LIBEDIT_DL LIBEDIT READLINE
# Option descriptions
-DEBUGGRP_DESC= Debugging options
-ASSERT_DESC= Enable interpreter assertions
APICHECK_DESC= Enable API checks
+ASSERT_DESC= Enable interpreter assertions
+DEBUGGRP_DESC= Debugging options
DOCSGRP_DESC= Documentation options
DOCS_DESC= Install language and API reference (HTML, ~400kB)
EDITGRP_DESC= Interactive command-line editing
EDITNONE_DESC= No command-line editing
-LIBEDIT_DL_DESC=Use dynamically loaded libedit (recommended)
LIBEDIT_DESC= Use libedit (breaks lcurses)
+LIBEDIT_DL_DESC=Use dynamically loaded libedit (recommended)
READLINE_DESC= Use GNU Readline (breaks lcurses)
# Option implementations
-ASSERT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-assert
-
APICHECK_CPPFLAGS= -DLUA_USE_APICHECK
+ASSERT_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-assert
# EDITNONE currently requires no settings
-LIBEDIT_DL_USES= libedit
-LIBEDIT_DL_CPPFLAGS= -DLUA_USE_READLINE_DL
-
LIBEDIT_USES= libedit
LIBEDIT_CPPFLAGS= -DLUA_USE_READLINE
LIBEDIT_LIBS= -ledit
+LIBEDIT_DL_USES= libedit
+LIBEDIT_DL_CPPFLAGS= -DLUA_USE_READLINE_DL
+
READLINE_USES= readline
READLINE_CPPFLAGS= -DLUA_USE_READLINE
READLINE_LIBS= -lreadline
# end of option vars
-CFLAGS+= -fPIC
-# 2019-01-25: -pthread in LIBS is a work around for the following bug:
-# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=235211
-LIBS+= -pthread
-
-WITHOUT_NO_STRICT_ALIASING=yes
-
-MAKE_ARGS+= CC="${CC}" \
- MYCFLAGS="${CPPFLAGS} ${CFLAGS}" \
- MYLDFLAGS="${LDFLAGS}" \
- MYLIBS="${LIBS}" \
- LUA_T=${LUA_CMD} \
- LUAC_T=${LUAC_CMD} \
- LUA_A=${LUA_LIB_STATIC} \
- LUA_SO=${LUA_LIB_SHARED} \
- LUA_SONAME=${LUA_LIB_SHARED} \
- TO_BIN="${LUA_CMD} ${LUAC_CMD}" \
- TO_LIB="${LUA_LIB_SHARED} ${LUA_LIB_STATIC}" \
- INSTALL_TOP=${STAGEDIR}${PREFIX} \
- INSTALL_INC=${STAGEDIR}${LUA_INCDIR} \
- INSTALL_EXEC="${INSTALL_PROGRAM}"
-
-SUB_FILES= ${LUA_PC_FILE}
-SUB_LIST= version=${PORTVERSION} \
- includedir=${LUA_INCDIR} \
- libdir=${LUA_LIBDIR} \
- soname=lua-${LUA_VER}
-
post-patch:
@${REINPLACE_CMD} -e "/LUA_ROOT/s,/usr/local,${LUA_PREFIX}," \
${WRKSRC}/src/luaconf.h
diff --git a/lang/lua53/distinfo b/lang/lua53/distinfo
index 9cf323a9eda2..4afe66763b5e 100644
--- a/lang/lua53/distinfo
+++ b/lang/lua53/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1531618645
-SHA256 (lua-5.3.5.tar.gz) = 0c2eed3f960446e1a3e4b9a1ca2f3ff893b6ce41942cf54d5dd59ab4b3b058ac
-SIZE (lua-5.3.5.tar.gz) = 303543
+TIMESTAMP = 1601041108
+SHA256 (lua-5.3.6.tar.gz) = fc5fd69bb8736323f026672b1b7235da613d7177e72558893a0bdcd320466d60
+SIZE (lua-5.3.6.tar.gz) = 303770
diff --git a/lang/lua53/files/patch-src__Makefile b/lang/lua53/files/patch-src_Makefile
index 8fd03a43c90e..8fd03a43c90e 100644
--- a/lang/lua53/files/patch-src__Makefile
+++ b/lang/lua53/files/patch-src_Makefile
diff --git a/lang/lua53/pkg-plist b/lang/lua53/pkg-plist
index e033913eef47..ca2ffefcdc92 100644
--- a/lang/lua53/pkg-plist
+++ b/lang/lua53/pkg-plist
@@ -1,14 +1,14 @@
-bin/lua53
-bin/luac53
-include/lua53/lauxlib.h
-include/lua53/lua.h
-include/lua53/lua.hpp
-include/lua53/luaconf.h
-include/lua53/lualib.h
-lib/liblua-5.3.a
-lib/liblua-5.3.so
-libdata/pkgconfig/lua-5.3.pc
-man/man1/lua53.1.gz
-man/man1/luac53.1.gz
-@dir lib/lua/5.3
-@dir %%DATADIR%%/5.3
+bin/lua%%LUA_VER_STR%%
+bin/luac%%LUA_VER_STR%%
+%%LUA_INCDIR%%/lauxlib.h
+%%LUA_INCDIR%%/lua.h
+%%LUA_INCDIR%%/lua.hpp
+%%LUA_INCDIR%%/luaconf.h
+%%LUA_INCDIR%%/lualib.h
+%%LUA_LIBDIR%%/liblua-%%LUA_VER%%.a
+%%LUA_LIBDIR%%/liblua-%%LUA_VER%%.so
+libdata/pkgconfig/lua-%%LUA_VER%%.pc
+man/man1/lua%%LUA_VER_STR%%.1.gz
+man/man1/luac%%LUA_VER_STR%%.1.gz
+@dir %%LUA_MODLIBDIR%%
+@dir %%LUA_MODSHAREDIR%%