aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-26 19:40:36 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-26 19:40:36 +0000
commite08da5800ee5f787a527fa5fd7e83dbb43cc2501 (patch)
treeae545790fd5d4480c1ce8084cb2807f239da0153 /lang
parentc15e8d65ae1d54212cb0f81afcfbff40aadcd4e7 (diff)
downloadports-e08da5800ee5f787a527fa5fd7e83dbb43cc2501.tar.gz
ports-e08da5800ee5f787a527fa5fd7e83dbb43cc2501.zip
lang/squeak: Fix build in 14.0-current
The lang/squeak ports assume B576000 and B1152000. Lack of B576000 and B1152000 at /usr/include/sys/_termios.h, lang/squeak is broken at 14.0-Current. While here, add missing USES, dependencies, reorder variables, etc. PR: 254456 Submitted by: takeshi.mutoh@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=569267
Diffstat (limited to 'lang')
-rw-r--r--lang/squeak/Makefile19
-rw-r--r--lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c6
-rw-r--r--lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c6
-rw-r--r--lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c15
-rw-r--r--lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake7
-rw-r--r--lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c2
-rw-r--r--lang/squeak/files/patch-unix_vm_build.cmake6
-rw-r--r--lang/squeak/files/patch-unix_vm_sqUnixMain.c4
8 files changed, 41 insertions, 24 deletions
diff --git a/lang/squeak/Makefile b/lang/squeak/Makefile
index 0213b0128ecd..85b8f38c6da5 100644
--- a/lang/squeak/Makefile
+++ b/lang/squeak/Makefile
@@ -3,7 +3,7 @@
PORTNAME= squeak
PORTVERSION= 4.10.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= lang
MASTER_SITES= http://www.squeakvm.org/unix/release/:vmsrc \
http://ftp.squeak.org/${IMAGE_VERSION}/:src \
@@ -26,16 +26,17 @@ ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc powerpc64 powerpc64le powerpcspe
BUILD_DEPENDS= cmake:devel/cmake \
v4l_compat>=1.0.20120501:multimedia/v4l_compat
LIB_DEPENDS= libaudio.so:audio/nas \
+ libdbus-1.so:devel/dbus \
libffi.so:devel/libffi \
+ libfreetype.so:print/freetype2 \
libasound.so:audio/alsa-lib \
libpulse-simple.so:audio/pulseaudio \
libv4l2.so:multimedia/libv4l
-USES= gl gnome pkgconfig
-USE_GNOME= cairo pango
+USES= gl gnome iconv pkgconfig xorg
USE_GL= gl
-HAS_CONFIGURE= yes
-CONFIGURE_OUTSOURCE= yes
+USE_GNOME= cairo pango
+USE_XORG= ice sm x11 xext xrender
VM_VERSION= ${PORTVERSION}.${SVN_VERSION}
SVN_VERSION= 2614
@@ -45,14 +46,18 @@ IMAGE_FULL_VERSION= ${IMAGE_VERSION}-${IMAGE_SVN_VERSION}
SQUEAK_SRC= SqueakV46.sources
SQUEAK_LIB_DIR= ${PORTVERSION}-${SVN_VERSION}
-WRKSRC= ${WRKDIR}/Squeak-${VM_VERSION}-src
+CMAKE_SOURCE_PATH= unix
+HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= unix/cmake/configure
CONFIGURE_ARGS= --prefix=${PREFIX}
-CMAKE_SOURCE_PATH= unix
+CONFIGURE_OUTSOURCE= yes
SUB_FILES= pkg-message
SUB_LIST= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR} \
IMAGE_FULL_VERSION=${IMAGE_FULL_VERSION}
+
+WRKSRC= ${WRKDIR}/Squeak-${VM_VERSION}-src
+
PLIST_SUB= SQUEAK_LIB_DIR=${SQUEAK_LIB_DIR} \
IMAGE_FULL_VERSION=${IMAGE_FULL_VERSION}
diff --git a/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c b/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c
index 20bd0fc2454e..77b22e2b40a3 100644
--- a/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c
+++ b/lang/squeak/files/patch-unix_plugins_CameraPlugin_sqCamera-linux.c
@@ -1,5 +1,5 @@
---- unix/plugins/CameraPlugin/sqCamera-linux.c.orig 2012-07-31 06:59:01.000000000 +0900
-+++ unix/plugins/CameraPlugin/sqCamera-linux.c 2012-09-24 14:44:26.000000000 +0900
+--- unix/plugins/CameraPlugin/sqCamera-linux.c.orig 2012-07-30 21:59:01 UTC
++++ unix/plugins/CameraPlugin/sqCamera-linux.c
@@ -45,8 +45,9 @@
#include <sys/ioctl.h>
#include <dlfcn.h>
@@ -12,7 +12,7 @@
#include <linux/videodev2.h>
-@@ -176,12 +177,19 @@
+@@ -176,12 +177,19 @@ libCon(void)
int devNum;
camPtr cam;
diff --git a/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c b/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c
index becdc2f816ef..4fffd8bcb6f7 100644
--- a/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c
+++ b/lang/squeak/files/patch-unix_plugins_ScratchPlugin_unixSeriaPort2Ops.c
@@ -1,6 +1,6 @@
---- unix/plugins/ScratchPlugin/unixSeriaPort2Ops.c.org 2012-09-24 15:26:44.000000000 +0900
-+++ unix/plugins/ScratchPlugin/unixSeriaPort2Ops.c 2012-09-24 15:26:54.000000000 +0900
-@@ -337,7 +337,7 @@
+--- unix/plugins/ScratchPlugin/unixSeriaPort2Ops.c.orig 2012-07-30 21:58:07 UTC
++++ unix/plugins/ScratchPlugin/unixSeriaPort2Ops.c
+@@ -337,7 +337,7 @@ error:
}
int isSerialPortDev(char *s) {
diff --git a/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c b/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c
index 3d268d5806e7..967d0116f0c6 100644
--- a/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c
+++ b/lang/squeak/files/patch-unix_plugins_SerialPlugin_sqUnixSerial.c
@@ -1,5 +1,5 @@
---- unix/plugins/SerialPlugin/sqUnixSerial.c.org 2012-09-24 15:29:28.000000000 +0900
-+++ unix/plugins/SerialPlugin/sqUnixSerial.c 2012-09-24 15:29:38.000000000 +0900
+--- unix/plugins/SerialPlugin/sqUnixSerial.c.orig 2011-03-14 05:01:56 UTC
++++ unix/plugins/SerialPlugin/sqUnixSerial.c
@@ -21,7 +21,7 @@
#define PORT_NAME_SIZE 64
@@ -9,3 +9,14 @@
/* stopBits 0=1.5, 1=1, 2=2 */
/* I don't know how to get 1.5 stop bits. Oh well. So you get 2 instead */
+@@ -94,10 +94,8 @@ static drDecode dataRateDecode[] = {
+ #endif
+ #if defined(B500000) /* missing on GNU/Linux prior to 2.2 */
+ { 500000, B500000 },
+- { 576000, B576000 },
+ { 921600, B921600 },
+ { 1000000, B1000000 },
+- { 1152000, B1152000 },
+ { 1500000, B1500000 },
+ { 2000000, B2000000 },
+ #endif
diff --git a/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake b/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake
index d5dd37d59798..091ceb8b1eeb 100644
--- a/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake
+++ b/lang/squeak/files/patch-unix_plugins_UUIDPlugin_config.cmake
@@ -1,6 +1,6 @@
---- unix/plugins/UUIDPlugin/config.cmake.orig 2012-09-13 21:09:00.000000000 +0200
-+++ unix/plugins/UUIDPlugin/config.cmake 2013-10-27 14:10:07.948211424 +0100
-@@ -4,8 +4,8 @@
+--- unix/plugins/UUIDPlugin/config.cmake.orig 2012-09-13 19:09:00 UTC
++++ unix/plugins/UUIDPlugin/config.cmake
+@@ -4,8 +4,8 @@ CONFIG_DEFINE (HAVE_UUID_H)
PLUGIN_FIND_INCLUDE (SYS_UUID sys/uuid.h)
CONFIG_DEFINE (HAVE_SYS_UUID_H)
@@ -10,3 +10,4 @@
+#---CONFIG_DEFINE (HAVE_UUID_UUID_H)
PLUGIN_FIND_LIBRARY (UUID uuid)
+
diff --git a/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c b/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c
index 8eaf251b3059..ba95a682516d 100644
--- a/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c
+++ b/lang/squeak/files/patch-unix_vm-sound-pulse_sqUnixSoundPulseAudio.c
@@ -1,4 +1,4 @@
---- unix/vm-sound-pulse/sqUnixSoundPulseAudio.c.orig 2012-08-08 10:34:42 +0800
+--- unix/vm-sound-pulse/sqUnixSoundPulseAudio.c.orig 2012-08-08 02:34:42 UTC
+++ unix/vm-sound-pulse/sqUnixSoundPulseAudio.c
@@ -995,10 +995,10 @@ DBGMSG("<sound_StartRecording()");
static sqInt sound_StopRecording(void) {
diff --git a/lang/squeak/files/patch-unix_vm_build.cmake b/lang/squeak/files/patch-unix_vm_build.cmake
index 5a940fc3c444..d478131c3023 100644
--- a/lang/squeak/files/patch-unix_vm_build.cmake
+++ b/lang/squeak/files/patch-unix_vm_build.cmake
@@ -1,6 +1,6 @@
---- unix/vm/build.cmake.orig 2013-06-09 22:54:13.000000000 +0200
-+++ unix/vm/build.cmake 2013-06-09 22:55:18.000000000 +0200
-@@ -90,4 +90,4 @@
+--- unix/vm/build.cmake.orig 2012-09-17 01:03:14 UTC
++++ unix/vm/build.cmake
+@@ -90,4 +90,4 @@ ADD_CUSTOM_TARGET (squeak.1
COMMAND sh ${bld}/config ${unix}/doc/squeak.1 ${bld}/squeak.1
)
ADD_DEPENDENCIES (squeakvm${scriptsuffix} squeak.1)
diff --git a/lang/squeak/files/patch-unix_vm_sqUnixMain.c b/lang/squeak/files/patch-unix_vm_sqUnixMain.c
index 269d2a0b98bb..23f85dc89007 100644
--- a/lang/squeak/files/patch-unix_vm_sqUnixMain.c
+++ b/lang/squeak/files/patch-unix_vm_sqUnixMain.c
@@ -1,6 +1,6 @@
---- unix/vm/sqUnixMain.c.bak 2013-12-05 13:49:51 -0800
+--- unix/vm/sqUnixMain.c.orig 2012-09-17 01:03:14 UTC
+++ unix/vm/sqUnixMain.c
-@@ -1334,8 +1334,8 @@
+@@ -1334,8 +1334,8 @@ void imgInit(void)
|| defined(POWERPC) || defined(__POWERPC) || defined (__POWERPC__) )
void mtfsfi(unsigned long long fpscr)
{