aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-16 11:53:42 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-16 11:53:42 +0000
commitfa93bad1215e901cfebdeeb3dcf02440416def7a (patch)
treee8621b27d6d0fe43816541a11be8f968bb405a75 /lang
parent242e23680e5ed01e00b6fdff4ecf489b51be881a (diff)
downloadports-fa93bad1215e901cfebdeeb3dcf02440416def7a.tar.gz
ports-fa93bad1215e901cfebdeeb3dcf02440416def7a.zip
Notes
Diffstat (limited to 'lang')
-rw-r--r--lang/adacontrol/pkg-plist5
-rw-r--r--lang/asis/Makefile12
-rw-r--r--lang/gcc-aux/Makefile15
-rw-r--r--lang/gcc47-aux/Makefile14
-rw-r--r--lang/gnat_util/Makefile8
-rw-r--r--lang/gnatdroid-armv5/Makefile28
-rw-r--r--lang/gnatdroid-armv7/Makefile36
-rw-r--r--lang/gnatdroid-binutils/pkg-plist12
-rw-r--r--lang/gnatdroid-sysroot/Makefile4
-rw-r--r--lang/modula3/Makefile17
10 files changed, 48 insertions, 103 deletions
diff --git a/lang/adacontrol/pkg-plist b/lang/adacontrol/pkg-plist
index 6160c60a39f2..a3d5fd4cbb47 100644
--- a/lang/adacontrol/pkg-plist
+++ b/lang/adacontrol/pkg-plist
@@ -10,8 +10,3 @@ share/gps/plug-ins/adactl_ask.gif
share/gps/plug-ins/pfni.py
share/gps/plug-ins/pfni.xml
share/gps/plug-ins/zadactl.xml
-@dirrmtry share/doc/gps/html
-@dirrmtry share/doc/gps
-@dirrmtry share/gprconfig
-@dirrmtry share/gps/plug-ins
-@dirrmtry share/gps
diff --git a/lang/asis/Makefile b/lang/asis/Makefile
index 833c40476900..b75055067406 100644
--- a/lang/asis/Makefile
+++ b/lang/asis/Makefile
@@ -33,16 +33,10 @@ post-extract:
do-build:
# This target is recreated because -j cannot be set, but
# MAKE_JOBS_SAFE=yes is needed for PROCESSORS value
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} gmake ${MAKE_ARGS} all
+ (cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} all)
post-install:
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
- ${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
- -e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \
- -e 's/^/@dirrm /g' >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} >> ${TMPPLIST})
.include <bsd.port.mk>
diff --git a/lang/gcc-aux/Makefile b/lang/gcc-aux/Makefile
index 582e17260aee..2e1b1d90550d 100644
--- a/lang/gcc-aux/Makefile
+++ b/lang/gcc-aux/Makefile
@@ -269,16 +269,11 @@ do-install:
${STAGEDIR}${PREFIX}/share/dejagnu/baseboards
post-stage:
- cd ${STAGEDIR}${PKG_PREFIX}; ${FIND} * -type d -empty | \
- ${SORT} -dr | ${XARGS} ${RMDIR}
- cd ${STAGEDIR}${PREFIX}; ${FIND} ${PORTNAME} share \
- \( -type f -or -type l \) | ${SORT} | \
- ${SED} -e 's/\/man\/man[1578]\/.*[1578]$$/&.gz/' >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} ${PORTNAME} -type d | ${SORT} -r | \
- ${SED} -e 's/^/@dirrm /g' >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} share -type d | ${SORT} -r | \
- ${SED} -e 's/\(.*\)/@unexec rmdir %D\/\1 2>\/dev\/null || true/g' \
- >> ${TMPPLIST}
+ (cd ${STAGEDIR}${PKG_PREFIX}; ${FIND} * -type d -empty | \
+ ${SORT} -dr | ${XARGS} ${RMDIR})
+ (cd ${STAGEDIR}${PREFIX}; ${FIND} ${PORTNAME} share \
+ \( -type f -or -type l \) | ${SORT} | ${SED} \
+ -e 's/\/man\/man[1578]\/.*[1578]$$/&.gz/' >> ${TMPPLIST})
.if ${PORT_OPTIONS:MBOOTSTRAP}
${MKDIR} ${NEWBSDIR}
${CP} -a ${STAGEDIR}${PKG_PREFIX}/bin ${NEWBSDIR}/
diff --git a/lang/gcc47-aux/Makefile b/lang/gcc47-aux/Makefile
index b3662b3f7506..ec886ce0f64b 100644
--- a/lang/gcc47-aux/Makefile
+++ b/lang/gcc47-aux/Makefile
@@ -291,15 +291,15 @@ test-c:
.endif
do-install:
- cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR}
+ (cd ${BUILDDIR} && ${SETENV} ${ADA_MAKE_ENV} \
+ ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR})
post-stage:
${MV} ${STAGEDIR}${PKG_PREFIX}/share/man ${STAGEDIR}/${PKG_PREFIX}
- cd ${STAGEDIR}${PKG_PREFIX}; ${FIND} * -type d -empty | \
- ${SORT} -dr | ${XARGS} ${RMDIR}
- cd ${STAGEDIR}${PREFIX}; ${FIND} ${PORTNAME} \( -type f -or -type l \) | \
- ${AWK} ${AWKMANPAGE} | ${SORT} >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} ${PORTNAME} -type d | ${SORT} -r | \
- ${SED} -E -e 's/^/@dirrm /g' >> ${TMPPLIST}
+ (cd ${STAGEDIR}${PKG_PREFIX}; ${FIND} * -type d -empty | \
+ ${SORT} -dr | ${XARGS} ${RMDIR})
+ (cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} ${PORTNAME} \( -type f -or -type l \) | \
+ ${AWK} ${AWKMANPAGE} | ${SORT} >> ${TMPPLIST})
.include <bsd.port.mk>
diff --git a/lang/gnat_util/Makefile b/lang/gnat_util/Makefile
index 5dc2e645ce45..9a8009b1a21f 100644
--- a/lang/gnat_util/Makefile
+++ b/lang/gnat_util/Makefile
@@ -38,11 +38,7 @@ post-install:
# impunit is needed for GPS menus, just provide the source files
${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/gcc/ada/impunit.* \
${STAGEDIR}${PREFIX}/include/gnat_util
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
- ${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e 's/^/@dirrm /g' \
- >> ${TMPPLIST}
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} >> ${TMPPLIST})
.include <bsd.port.mk>
diff --git a/lang/gnatdroid-armv5/Makefile b/lang/gnatdroid-armv5/Makefile
index 20040102b383..e433c33456e0 100644
--- a/lang/gnatdroid-armv5/Makefile
+++ b/lang/gnatdroid-armv5/Makefile
@@ -114,8 +114,8 @@ post-extract:
do-configure:
${MKDIR} ${BUILD_WRKSRC}
- cd ${BUILD_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${CFG_SCRIPT} ${ADA_CONFIG_ARGS}
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${CFG_SCRIPT} ${ADA_CONFIG_ARGS})
do-install:
# Buggy makefile; seems to have forgotten this is a cross compiler
@@ -125,26 +125,24 @@ do-install:
${CP} -a ${BUILD_WRKSRC}/gcc/${X}-cross ${BUILD_WRKSRC}/gcc/${X}
. endif
.endfor
- cd ${BUILD_WRKSRC} && ${SETENV} ${INSTALL_ENV} \
- ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR}
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${INSTALL_ENV} \
+ ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR})
${MV} ${STAGEDIR}${PREFIX}/bin/ada \
${STAGEDIR}${PREFIX}/bin/${DROID_TARGET}-ada
post-install:
.for loop in A B
- cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty | \
- ${SORT} -dr | ${XARGS} ${RMDIR}
+ (cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty | \
+ ${SORT} -dr | ${XARGS} ${RMDIR})
.endfor
- cd ${STAGEDIR}${PREFIX}; \
- ${FIND} * \( -type f -or -type l \) | ${SORT} | \
- ${SED} -e '/^bin\//d' -e '/^${DROID_TARGET}\/bin\//d' \
- >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${SORT} -dr | \
- ${SED} -e 's/^/@dirrmtry /g' >> ${TMPPLIST}
+ (cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} * \( -type f -or -type l \) | ${SORT} | \
+ ${SED} -e '/^bin\//d' -e '/^${DROID_TARGET}\/bin\//d' \
+ >> ${TMPPLIST})
acats: build
- cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
- PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
- gmake -sk check-acats
+ (cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
+ PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
+ ${GMAKE} -sk check-acats)
.include <bsd.port.mk>
diff --git a/lang/gnatdroid-armv7/Makefile b/lang/gnatdroid-armv7/Makefile
index 355a88f896dc..8319ebd07c87 100644
--- a/lang/gnatdroid-armv7/Makefile
+++ b/lang/gnatdroid-armv7/Makefile
@@ -114,8 +114,8 @@ post-extract:
do-configure:
${MKDIR} ${BUILD_WRKSRC}
- cd ${BUILD_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${CFG_SCRIPT} ${ADA_CONFIG_ARGS}
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${CFG_SCRIPT} ${ADA_CONFIG_ARGS})
do-install:
# Buggy makefile; seems to have forgotten this is a cross compiler
@@ -125,31 +125,29 @@ do-install:
${CP} -a ${BUILD_WRKSRC}/gcc/${X}-cross ${BUILD_WRKSRC}/gcc/${X}
. endif
.endfor
- cd ${BUILD_WRKSRC} && ${SETENV} ${INSTALL_ENV} \
- ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR}
+ (cd ${BUILD_WRKSRC} && ${SETENV} ${INSTALL_ENV} \
+ ${MAKE_CMD} install-strip DESTDIR=${STAGEDIR})
${MV} ${STAGEDIR}${PREFIX}/bin/ada \
${STAGEDIR}${PREFIX}/bin/${DROID_TARGET}-ada
post-stage:
.for loop in A B
- cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty | \
- ${SORT} -dr | ${XARGS} ${RMDIR}
+ (cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d -empty | \
+ ${SORT} -dr | ${XARGS} ${RMDIR})
.endfor
- cd ${STAGEDIR}${PREFIX}; \
- ${FIND} * \( -type f -or -type l \) | ${SORT} | \
- ${SED} -e '/^bin\//d' -e '/^${DROID_TARGET}\/bin\//d' \
- >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${SORT} -dr | \
- ${SED} -e 's/^/@dirrmtry /g' >> ${TMPPLIST}
+ (cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} * \( -type f -or -type l \) | ${SORT} | \
+ ${SED} -e '/^bin\//d' -e '/^${DROID_TARGET}\/bin\//d' \
+ >> ${TMPPLIST})
acats: build
- cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
- PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
- gmake -sk check-acats
+ (cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
+ PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
+ ${GMAKE} -sk check-acats)
gnatdg: build
- cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
- PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
- gmake -sk check-gnat RUNTESTFLAGS=--target_board=gnatdroid
-
+ (cd ${BUILD_WRKSRC}/gcc && ${SETENV} \
+ PATH=${LOCALBASE}/gcc-aux/bin:${PATH}:${PREFIX}/bin \
+ ${GMAKE} -sk check-gnat RUNTESTFLAGS=--target_board=gnatdroid)
+
.include <bsd.port.mk>
diff --git a/lang/gnatdroid-binutils/pkg-plist b/lang/gnatdroid-binutils/pkg-plist
index 3f8ee020efca..b5956c0b1de2 100644
--- a/lang/gnatdroid-binutils/pkg-plist
+++ b/lang/gnatdroid-binutils/pkg-plist
@@ -49,12 +49,6 @@
%%BRANCH1%%/bin/%%TARGET%%-size
%%BRANCH1%%/bin/%%TARGET%%-strings
%%BRANCH1%%/bin/%%TARGET%%-strip
-@dirrm %%BRANCH1%%/%%TARGET%%/bin
-@dirrm %%BRANCH1%%/%%TARGET%%/lib/ldscripts
-@dirrm %%BRANCH1%%/%%TARGET%%/lib
-@dirrm %%BRANCH1%%/%%TARGET%%
-@dirrm %%BRANCH1%%/bin
-@dirrm %%BRANCH1%%
%%BRANCH2%%/%%TARGET%%/bin/ar
%%BRANCH2%%/%%TARGET%%/bin/as
%%BRANCH2%%/%%TARGET%%/bin/ld
@@ -106,9 +100,3 @@
%%BRANCH2%%/bin/%%TARGET%%-size
%%BRANCH2%%/bin/%%TARGET%%-strings
%%BRANCH2%%/bin/%%TARGET%%-strip
-@dirrm %%BRANCH2%%/%%TARGET%%/bin
-@dirrm %%BRANCH2%%/%%TARGET%%/lib/ldscripts
-@dirrm %%BRANCH2%%/%%TARGET%%/lib
-@dirrm %%BRANCH2%%/%%TARGET%%
-@dirrm %%BRANCH2%%/bin
-@dirrm %%BRANCH2%%
diff --git a/lang/gnatdroid-sysroot/Makefile b/lang/gnatdroid-sysroot/Makefile
index ee35fc78360f..171ea1aa8522 100644
--- a/lang/gnatdroid-sysroot/Makefile
+++ b/lang/gnatdroid-sysroot/Makefile
@@ -57,8 +57,6 @@ do-install:
post-install:
@(cd ${STAGEDIR}${PREFIX}; ${FIND} usr \( -type f -or -type l \) | \
- ${SORT} >> ${TMPPLIST})
- @(cd ${STAGEDIR}${PREFIX}; ${FIND} usr -type d | ${SORT} -r | \
- ${SED} -e 's/^/@dirrm /g' >> ${TMPPLIST})
+ ${SORT} >> ${TMPPLIST})
.include <bsd.port.mk>
diff --git a/lang/modula3/Makefile b/lang/modula3/Makefile
index fd5420443aa6..b4059fe597bc 100644
--- a/lang/modula3/Makefile
+++ b/lang/modula3/Makefile
@@ -144,23 +144,6 @@ post-install:
${SORT} | ${SED} -e 's/^man\/man[1578]\/.*[1578]$$/&.gz/' \
> ${TMPPLIST}
@echo ${PLIST_FILES} | awk '{print $$1}' RS=' ' >> ${TMPPLIST}
- cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${SORT} -r | \
- ${SED} -e '/^bin$$/d' -e '/^lib$$/d' -e '/^pkg$$/d' \
- -e '/^share\/examples$$/d' -e '/^share\/doc$$/d' -e '/^share$$/d' \
- -e '/^etc$$/d' -e '/^man\/man[1578]$$/d' -e '/^man$$/d' \
- -e 's/^/@dirrm /g' >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share/examples 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/share 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/bin 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/etc 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/lib 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/man/man8 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/man/man7 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/man/man5 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/man/man1 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/man 2>/dev/null || true" >> ${TMPPLIST}
- @echo "@unexec rmdir %D/pkg 2>/dev/null || true" >> ${TMPPLIST}
# to create a new bootstrap, invoke "make stage NEW_BOOTSTRAP=1"
.if defined(NEW_BOOTSTRAP)