aboutsummaryrefslogtreecommitdiff
path: root/mail/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-05-01 15:41:41 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-05-01 15:41:41 +0000
commite53d3081051230f309ceac94a6192224e8d90b8f (patch)
tree0c726222db99620e94cdb54c17513a85966886c9 /mail/Makefile
parent839cf825f133a838188e07b35622c6bba31a430a (diff)
downloadports-e53d3081051230f309ceac94a6192224e8d90b8f.tar.gz
ports-e53d3081051230f309ceac94a6192224e8d90b8f.zip
Add mail/py-email-validator: Robust email address syntax and deliverability validation library
This library validates that address are of the form x@y.com. This is the sort of validation you would want for a login form on a website. Key features: - Good for validating email addresses used for logins/identity. - Friendly error messages when validation fails (appropriate to show to end users). - (optionally) Checks deliverability: Does the domain name resolve? - Supports internationalized domain names and (optionally) internationalized local parts. - Normalizes email addresses (super important for internationalized addresses!) WWW: https://github.com/JoshData/python-email-validator PR: 246039 Submitted by: Goran Mekić <meka@tilda.center>
Notes
Notes: svn path=/head/; revision=533557
Diffstat (limited to 'mail/Makefile')
-rw-r--r--mail/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 72eb1ebde97d..c15ba0078594 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -504,6 +504,7 @@
SUBDIR += py-cyruslib
SUBDIR += py-dkimpy
SUBDIR += py-email_reply_parser
+ SUBDIR += py-email-validator
SUBDIR += py-flask-mail
SUBDIR += py-flufl.bounce
SUBDIR += py-fuglu