aboutsummaryrefslogtreecommitdiff
path: root/mail/abook
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2012-12-17 03:29:29 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2012-12-17 03:29:29 +0000
commitc7384baf40cb8e65831fc96b8a2ce00e89e95e44 (patch)
treed074b78b3fba30b15f24a904f14826e291ab576a /mail/abook
parent003b16565e67ccb1cda138d28a43f1ab4350d0b1 (diff)
downloadports-c7384baf40cb8e65831fc96b8a2ce00e89e95e44.tar.gz
ports-c7384baf40cb8e65831fc96b8a2ce00e89e95e44.zip
- Support USE_READLINE.
- Support USE_NCURSES. - Add LICENSE. - Add MAKE_JOBS_SAFE. - Trim header. PR: ports/172029 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=309057
Diffstat (limited to 'mail/abook')
-rw-r--r--mail/abook/Makefile38
1 files changed, 19 insertions, 19 deletions
diff --git a/mail/abook/Makefile b/mail/abook/Makefile
index 85f3b84c5827..e4ca050ac945 100644
--- a/mail/abook/Makefile
+++ b/mail/abook/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: abook
-# Date created: June 6th 2000
-# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
-#
+# Created by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
# $FreeBSD$
-#
PORTNAME= abook
PORTVERSION= 0.5.6
@@ -14,33 +10,37 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An addressbook program with mutt mail client support
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= NLS DOCS
+
+USE_NCURSES= yes
+USE_READLINE= yes
GNU_CONFIGURE= yes
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
MAN1= abook.1
MAN5= abookrc.5
PORTDOCS= ANNOUNCE AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README \
THANKS TODO
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if exists(${LOCALBASE}/lib/libreadline.so.6)
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>