aboutsummaryrefslogtreecommitdiff
path: root/mail/amavis-logwatch
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-11-06 12:10:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-11-06 12:10:00 +0000
commit8bf89fab9ec7a00f3cab9a509c2765fd63f0ccf9 (patch)
tree0d44c63501778b19cedb997f31be6200bff6ef4c /mail/amavis-logwatch
parent71abe8b0fdc1ed48173fa4d8d7ec738973ca920c (diff)
downloadports-8bf89fab9ec7a00f3cab9a509c2765fd63f0ccf9.tar.gz
ports-8bf89fab9ec7a00f3cab9a509c2765fd63f0ccf9.zip
The amavis-logwatch(1) utility is an Amavisd-new log parser
that produces summaries, details, and statistics regarding the operation of Amavisd-new (henceforth, simply called Amavis). A key feature of amavis-logwatch is its ability to produce a very wide range of reports with data grouped and sorted as much as possible to reduce noise and highlight patterns. Brief summary reports provide a quick overview of general Amavis operations and message delivery, calling out warnings that may require attention. Detailed reports provide easy to scan, hierarchically-arranged and organized information, with as much or little detail as desired. WWW: http://logreporters.sourceforge.net/ PR: ports/162223 Submitted by: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
Notes
Notes: svn path=/head/; revision=285142
Diffstat (limited to 'mail/amavis-logwatch')
-rw-r--r--mail/amavis-logwatch/Makefile52
-rw-r--r--mail/amavis-logwatch/distinfo2
-rw-r--r--mail/amavis-logwatch/pkg-descr14
-rw-r--r--mail/amavis-logwatch/pkg-plist5
4 files changed, 73 insertions, 0 deletions
diff --git a/mail/amavis-logwatch/Makefile b/mail/amavis-logwatch/Makefile
new file mode 100644
index 000000000000..bb8a07dfce0e
--- /dev/null
+++ b/mail/amavis-logwatch/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: amavis-logwatch
+# Date created: 2011-11-01
+# Whom: Masaki TAGAWA <masaki@club.kyutech.ac.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= amavis-logwatch
+PORTVERSION= 1.50.04
+CATEGORIES= mail
+MASTER_SITES= SF/logreporters/${PORTNAME}/release/${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= masaki@club.kyutech.ac.jp
+COMMENT= Amavisd-new log parser
+
+LICENSE= GPLv2
+
+PORTDOCS= Bugs Changes README
+PORTEXAMPLES= ${PORTNAME}.conf
+
+MAN1= ${PORTNAME}.1
+
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+
+post-patch:
+ @cd ${WRKSRC} && ${REINPLACE_CMD} -e '\
+ s!/usr/local/etc!${ETCDIR}! \
+ ' ${PORTNAME} ${PORTNAME}.1 README
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ @${CP} ${WRKSRC}/${PORTNAME}.conf ${WRKSRC}/${PORTNAME}.conf.sample
+ @${MKDIR} ${ETCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf.sample ${ETCDIR}
+
+post-install:
+ @if [ ! -f ${ETCDIR}/${PORTNAME}.conf ]; then \
+ ${CP} -p ${ETCDIR}/${PORTNAME}.conf.sample ${ETCDIR}/${PORTNAME}.conf; \
+ fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/amavis-logwatch/distinfo b/mail/amavis-logwatch/distinfo
new file mode 100644
index 000000000000..5b789bdcbc6c
--- /dev/null
+++ b/mail/amavis-logwatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (amavis-logwatch-1.50.04.tgz) = b7807dbc715152373207e1f15be72b1ea1fc392ab4e9d135c59e98e5c6ed5a08
+SIZE (amavis-logwatch-1.50.04.tgz) = 82384
diff --git a/mail/amavis-logwatch/pkg-descr b/mail/amavis-logwatch/pkg-descr
new file mode 100644
index 000000000000..cd569b24aa4a
--- /dev/null
+++ b/mail/amavis-logwatch/pkg-descr
@@ -0,0 +1,14 @@
+The amavis-logwatch(1) utility is an Amavisd-new log parser
+that produces summaries, details, and statistics regarding
+the operation of Amavisd-new (henceforth, simply called Amavis).
+
+A key feature of amavis-logwatch is its ability to produce
+a very wide range of reports with data grouped and sorted as
+much as possible to reduce noise and highlight patterns. Brief
+summary reports provide a quick overview of general Amavis
+operations and message delivery, calling out warnings that
+may require attention. Detailed reports provide easy to scan,
+hierarchically-arranged and organized information, with as
+much or little detail as desired.
+
+WWW: http://logreporters.sourceforge.net/
diff --git a/mail/amavis-logwatch/pkg-plist b/mail/amavis-logwatch/pkg-plist
new file mode 100644
index 000000000000..4b055a90204b
--- /dev/null
+++ b/mail/amavis-logwatch/pkg-plist
@@ -0,0 +1,5 @@
+@unexec if cmp -s %D/%%ETCDIR%%/amavis-logwatch.conf.sample %D/%%ETCDIR%%/amavis-logwatch.conf; then rm -f %D/%%ETCDIR%%/amavis-logwatch.conf; fi
+%%ETCDIR%%/amavis-logwatch.conf.sample
+@exec if [ ! -f %B/amavis-logwatch.conf ] ; then cp -p %B/%f %B/amavis-logwatch.conf; fi
+@dirrmtry %%ETCDIR%%
+bin/amavis-logwatch