aboutsummaryrefslogtreecommitdiff
path: root/mail/archiveopteryx
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-10 19:37:13 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-10 19:37:13 +0000
commit060817b6d6cb710c5d01ddcfc10436145837da61 (patch)
tree9c08c1940c29a0a72e288ba5cb8f2384b08818c4 /mail/archiveopteryx
parent931da8d47263e27157fbd40b6547a6ebc2281276 (diff)
downloadports-060817b6d6cb710c5d01ddcfc10436145837da61.tar.gz
ports-060817b6d6cb710c5d01ddcfc10436145837da61.zip
mail/archiveopteryx(-devel): document SSL requirement, sed in related flags
While here, couple OSVERSION with OPSYS Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421731
Diffstat (limited to 'mail/archiveopteryx')
-rw-r--r--mail/archiveopteryx/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index fa87c589d909..f9887c45473c 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -16,8 +16,7 @@ BROKEN_powerpc64= Does not build
BUILD_DEPENDS= jam:devel/jam
-USES= perl5 tar:bzip2 pgsql:9.1+
-USE_OPENSSL= yes
+USES= perl5 pgsql:9.1+ ssl tar:bzip2
USE_PERL5= build
PORTDOCS= COPYING README bsd.txt
@@ -36,14 +35,18 @@ JAM?= ${LOCALBASE}/bin/jam
.include <bsd.port.pre.mk>
# force Clang when on FreeBSD 10+
-.if ${OSVERSION} >= 1000000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
JAMARG= "-sCLANG=1"
.endif
post-patch:
@${GREP} -Rl '%%[[:alpha:]]\+%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e 's,%%PREFIX%%,${PREFIX},g'
- ${REINPLACE_CMD} "s|INSTALLROOT ?= \"\" ;|INSTALLROOT = \"${STAGEDIR}\" ;|" ${WRKSRC}/Jamsettings
+ ${REINPLACE_CMD} -e "s|\(C++FLAGS =\)|\1 -I${OPENSSLINC}|g" \
+ -e"s|INSTALLROOT ?= \"\" ;|INSTALLROOT = \"${STAGEDIR}\" ;|" \
+ ${WRKSRC}/Jamsettings
+ ${REINPLACE_CMD} -e "s|\(-lcrypto\)|-L${OPENSSLLIB} \1|g" \
+ ${WRKSRC}/server/Jamfile
do-build:
@cd ${WRKSRC} && ${JAM} ${JAMARG}