aboutsummaryrefslogtreecommitdiff
path: root/mail/archiveopteryx
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2018-04-14 17:14:12 +0000
committerMark Felder <feld@FreeBSD.org>2018-04-14 17:14:12 +0000
commit305c4394a7d937e4e6aa716260109e4ddfdbb94d (patch)
treed018ac7f01af24f3b113bdc89365c7f917b57b64 /mail/archiveopteryx
parent45a5d4d5da459cf51598753857bf670077c0be40 (diff)
downloadports-305c4394a7d937e4e6aa716260109e4ddfdbb94d.tar.gz
ports-305c4394a7d937e4e6aa716260109e4ddfdbb94d.zip
mail/archiveopteryx: Fix build with modern clang
MFH: 2018Q2
Notes
Notes: svn path=/head/; revision=467334
Diffstat (limited to 'mail/archiveopteryx')
-rw-r--r--mail/archiveopteryx/Makefile4
-rw-r--r--mail/archiveopteryx/files/patch-core__md5.cpp24
2 files changed, 22 insertions, 6 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index a4df6f534ce2..ea4da9bdecf5 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -3,7 +3,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.2.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/download/
@@ -12,8 +12,6 @@ COMMENT= Advanced PostgreSQL-based IMAP/POP server
LICENSE= MIT
-BROKEN_armv6= fails to build: core/md5.cpp:55:5: 'register' storage class specifier is deprecated and incompatible with C++17
-BROKEN_armv7= fails to build: core/md5.cpp:55:5: 'register' storage class specifier is deprecated and incompatible with C++17
BROKEN_powerpc64= fails to build: /bin/sh: clang: not found
BUILD_DEPENDS= jam:devel/jam
diff --git a/mail/archiveopteryx/files/patch-core__md5.cpp b/mail/archiveopteryx/files/patch-core__md5.cpp
index 7cbf813b392a..675a9cd8e8a7 100644
--- a/mail/archiveopteryx/files/patch-core__md5.cpp
+++ b/mail/archiveopteryx/files/patch-core__md5.cpp
@@ -1,6 +1,15 @@
---- ./core/md5.cpp.orig 2014-03-06 13:46:23.918398965 -0600
-+++ ./core/md5.cpp 2014-03-06 13:46:30.784414914 -0600
-@@ -149,12 +149,9 @@
+--- core/md5.cpp.orig 2014-03-10 13:44:59 UTC
++++ core/md5.cpp
+@@ -52,7 +52,7 @@ void MD5::init()
+
+ void MD5::add( const char *str, uint len )
+ {
+- register uint32 t;
++ uint32 t;
+
+ /* It's not possible to add() data, call hash(), then add more data
+ and call hash() again, because hash() destroys the accumulated
+@@ -149,12 +149,9 @@ EString MD5::hash()
}
swapBytes( in, 14 );
@@ -13,3 +22,12 @@
transform();
swapBytes( (char *)buf, 4 );
+@@ -247,7 +244,7 @@ EString MD5::HMAC( const EString &secret
+
+ void MD5::transform()
+ {
+- register uint32 a, b, c, d;
++ uint32 a, b, c, d;
+ uint32 *inw = (uint32 *)in;
+
+ a = buf[0];