aboutsummaryrefslogtreecommitdiff
path: root/mail/archiveopteryx
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-03-14 17:55:59 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-03-14 17:55:59 +0000
commit739e43443644a9a04e45e638c20bd4608070d856 (patch)
tree5964efe13a6517682e68b00d393552a01830e359 /mail/archiveopteryx
parent070332fe15d8768ee5d98ad0eeb37b8406a640f4 (diff)
downloadports-739e43443644a9a04e45e638c20bd4608070d856.tar.gz
ports-739e43443644a9a04e45e638c20bd4608070d856.zip
- drop invalid post-deinstall target, and adjust pkg-{de}install, respectively
PR: ports/166060 Submitted by: jgh@ Approved by: maintainer, feld@feld.me Feature safe: yes
Notes
Notes: svn path=/head/; revision=293309
Diffstat (limited to 'mail/archiveopteryx')
-rw-r--r--mail/archiveopteryx/Makefile7
-rw-r--r--mail/archiveopteryx/pkg-deinstall12
-rw-r--r--mail/archiveopteryx/pkg-install12
3 files changed, 4 insertions, 27 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index 0da691709aed..4071ad45145a 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -7,6 +7,7 @@
PORTNAME= archiveopteryx
PORTVERSION= 3.1.3
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://archiveopteryx.org/%SUBDIR%/
MASTER_SITE_SUBDIR= download
@@ -50,11 +51,7 @@ do-install:
@cd ${WRKSRC} && ${JAM} install
post-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-post-deinstall:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
-
-
.include <bsd.port.post.mk>
diff --git a/mail/archiveopteryx/pkg-deinstall b/mail/archiveopteryx/pkg-deinstall
index aca504aa7d9f..5edef8a57b8c 100644
--- a/mail/archiveopteryx/pkg-deinstall
+++ b/mail/archiveopteryx/pkg-deinstall
@@ -1,20 +1,10 @@
#!/bin/sh
-PKGNAME=$1
-TARGET=$2
-
RMDIR=/bin/rmdir
-if [ $# -ne 2 ]; then
- echo "Usage: $0 [PKGNAME] [DEINSTALL | POST-DEINSTALL]"
- exit 1
-fi
-
-if [ "$TARGET" = POST-DEINSTALL ]; then
+if [ "$2" = POST-DEINSTALL ]; then
for i in /var/db/aox/jail /var/db/aox/messages /var/run/aox; do
${RMDIR} ${i} 2>/dev/null
done
${RMDIR} /var/db/aox 2>/dev/null
fi
-
-exit 0
diff --git a/mail/archiveopteryx/pkg-install b/mail/archiveopteryx/pkg-install
index 35d64789a865..0e6b9d4974a3 100644
--- a/mail/archiveopteryx/pkg-install
+++ b/mail/archiveopteryx/pkg-install
@@ -1,8 +1,5 @@
#!/bin/sh
-PKGNAME=$1
-TARGET=$2
-
MKDIR=/bin/mkdir
CHOWN=/usr/sbin/chown
CHMOD=/bin/chmod
@@ -10,12 +7,7 @@ CHMOD=/bin/chmod
AOXGROUP=aox
AOXUSER=aox
-if [ $# -ne 2 ]; then
- echo "Usage: $0 [PKGNAME] [PRE-INSTALL | POST-INSTALL]"
- exit 1
-fi
-
-if [ "$TARGET" = POST-INSTALL ]; then
+if [ "$2" = POST-INSTALL ]; then
for i in /var/db/aox/jail /var/db/aox/messages; do
${MKDIR} -m 700 -p ${i}
done
@@ -24,5 +16,3 @@ if [ "$TARGET" = POST-INSTALL ]; then
${MKDIR} /var/run/aox
${CHOWN} ${AOXUSER}:${AOXGROUP} /var/db/aox /var/run/aox /var/db/aox/messages
fi
-
-exit 0