aboutsummaryrefslogtreecommitdiff
path: root/mail/archiveopteryx
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-08-11 14:02:57 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2011-08-11 14:02:57 +0000
commit7fe549e4358a5ec168b82523da05e2c1acfcc2d1 (patch)
tree22d04a93ea2862c5ae3eb756b3f80cf44471b660 /mail/archiveopteryx
parent507ecd1f0c3d69e139967ed1df3ae4dae7b704aa (diff)
downloadports-7fe549e4358a5ec168b82523da05e2c1acfcc2d1.tar.gz
ports-7fe549e4358a5ec168b82523da05e2c1acfcc2d1.zip
- Unbreak on 9.x
- Fix jail permissions in pkg-install PR: ports/159655 Submitted by: Mark Felder <feld@feld.me>
Notes
Notes: svn path=/head/; revision=279493
Diffstat (limited to 'mail/archiveopteryx')
-rw-r--r--mail/archiveopteryx/Makefile5
-rw-r--r--mail/archiveopteryx/files/patch-core_configuration.cpp11
-rw-r--r--mail/archiveopteryx/pkg-install4
3 files changed, 14 insertions, 6 deletions
diff --git a/mail/archiveopteryx/Makefile b/mail/archiveopteryx/Makefile
index ba53b2915e10..66f027ace8b1 100644
--- a/mail/archiveopteryx/Makefile
+++ b/mail/archiveopteryx/Makefile
@@ -39,10 +39,6 @@ JAM?= ${LOCALBASE}/bin/jam
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900000
-BROKEN= does not build on FreeBSD 9.X
-.endif
-
post-patch:
@${GREP} -Rl '%%[[:alpha:]]\+%%' ${WRKSRC} |${XARGS} ${REINPLACE_CMD} \
-e 's,%%PREFIX%%,${PREFIX},g'
@@ -60,4 +56,5 @@ post-install:
post-deinstall:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} POST-DEINSTALL
+
.include <bsd.port.post.mk>
diff --git a/mail/archiveopteryx/files/patch-core_configuration.cpp b/mail/archiveopteryx/files/patch-core_configuration.cpp
new file mode 100644
index 000000000000..5fab17a925b5
--- /dev/null
+++ b/mail/archiveopteryx/files/patch-core_configuration.cpp
@@ -0,0 +1,11 @@
+--- core/configuration.cpp.orig 2011-08-10 13:45:01.165003888 -0500
++++ core/configuration.cpp 2011-08-10 13:45:35.358002044 -0500
+@@ -684,7 +684,7 @@
+ in6.sin6_addr.s6_addr[i] = 0;
+ ++i;
+ }
+- in6.sin6_addr.s6_addr[15] = ntohs( 1 );
++ in6.sin6_addr.s6_addr[15] = 1;
+ in6.sin6_scope_id = 0;
+ if ( ::bind( s, (struct sockaddr *)&in6, sizeof( in6 ) ) < 0 ) {
+ if ( errno == EADDRINUSE )
diff --git a/mail/archiveopteryx/pkg-install b/mail/archiveopteryx/pkg-install
index 06fc7523da29..35d64789a865 100644
--- a/mail/archiveopteryx/pkg-install
+++ b/mail/archiveopteryx/pkg-install
@@ -18,11 +18,11 @@ fi
if [ "$TARGET" = POST-INSTALL ]; then
for i in /var/db/aox/jail /var/db/aox/messages; do
${MKDIR} -m 700 -p ${i}
- ${CHOWN} ${AOXUSER}:${AOXGROUP} ${i}
done
+ ${CHOWN} root:wheel /var/db/aox/jail
${CHMOD} 700 /var/db/aox
${MKDIR} /var/run/aox
- ${CHOWN} ${AOXUSER}:${AOXGROUP} /var/db/aox /var/run/aox
+ ${CHOWN} ${AOXUSER}:${AOXGROUP} /var/db/aox /var/run/aox /var/db/aox/messages
fi
exit 0