aboutsummaryrefslogtreecommitdiff
path: root/mail/assp
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-07-06 15:32:47 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-07-06 15:32:47 +0000
commit3cbb2fa02ce3562678ab3c217f7283ff0ee04e64 (patch)
treeeabba174cb874fbe686072cdede5db5a618ea2b7 /mail/assp
parent95275cebf5c8df9d60be55e7e2dc14b7453918a7 (diff)
downloadports-3cbb2fa02ce3562678ab3c217f7283ff0ee04e64.tar.gz
ports-3cbb2fa02ce3562678ab3c217f7283ff0ee04e64.zip
- Update to 1.9.9.14158
- Stagify - Add missing dependency when MYSQL option is enabled - Assign maintainership to submitter PR: 191635 Sumitted by: rnejdl@ringofsaturn.com
Notes
Notes: svn path=/head/; revision=360926
Diffstat (limited to 'mail/assp')
-rw-r--r--mail/assp/Makefile61
-rw-r--r--mail/assp/distinfo4
-rw-r--r--mail/assp/files/patch-assp.pl16
-rw-r--r--mail/assp/files/pkg-install.in25
-rw-r--r--mail/assp/pkg-plist45
5 files changed, 72 insertions, 79 deletions
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index cb14ab555473..c77736c83fdb 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= assp
-PORTVERSION= 1.9.9.13257
+PORTVERSION= 1.9.9.14158
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://www.ringofsaturn.com/distfiles/
DISTNAME= ${PORTNAME:tu}_${PORTVERSION}_Install
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= Anti-Spam SMTP Proxy
-USES= perl5 zip
+RUN_DEPENDS= p5-Net-DNS>=0.68:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-libwww>=6.04:${PORTSDIR}/www/p5-libwww \
+ p5-HTML-Parser>=3.69:${PORTSDIR}/www/p5-HTML-Parser
+
+USES= perl5 zip:infozip
NO_BUILD= yes
USE_PERL5= run
-MAN8= assp.8 assplog.8
-
ASSP_USER= assp
ASSP_GROUP= assp
USERS= ${ASSP_USER}
@@ -24,9 +26,10 @@ GROUPS= ${ASSP_GROUP}
ASSP_HOME= /var/db/assp
ASSP_LOG= /var/log/assp
-PLIST_SUB= ASSP_HOME="${ASSP_HOME}" ASSP_LOG="${ASSP_LOG}"
+PLIST_SUB= ASSP_HOME="${ASSP_HOME}" ASSP_LOG="${ASSP_LOG}" \
+ ASSP_USER="${ASSP_USER}" ASSP_GROUP="${ASSP_GROUP}"
-SUB_FILES= 510.assp assp.8 assplog.8 assplog.pl pkg-install
+SUB_FILES= 510.assp assp.8 assplog.8 assplog.pl
SUB_LIST= ASSP_USER="${ASSP_USER}" ASSP_GROUP="${ASSP_GROUP}" \
ASSP_HOME="${ASSP_HOME}" ASSP_LOG="${ASSP_LOG}" \
DATADIR="${DATADIR}" PERL="${PERL}"
@@ -53,14 +56,9 @@ IPV6_DESC= IPv6 sockets support
OPTIONS_DEFAULT= EMVALID SPF SRS SEND FBACKW CLAMAV DNSBL MATCHRE SENDERB MIMEMOD SSL IPV6
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ASSP_1.9.9_13227_install/${PORTNAME:tu}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/ASSP_1.9.9_14158_install/${PORTNAME:tu}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-RUN_DEPENDS+= p5-Net-DNS>=0.68:${PORTSDIR}/dns/p5-Net-DNS \
- p5-libwww>=6.04:${PORTSDIR}/www/p5-libwww \
- p5-HTML-Parser>=3.69:${PORTSDIR}/www/p5-HTML-Parser
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEMVALID}
RUN_DEPENDS+= p5-Email-Valid>=0.190:${PORTSDIR}/mail/p5-Email-Valid
@@ -99,6 +97,7 @@ RUN_DEPENDS+= p5-Net-DNS>=0.68:${PORTSDIR}/dns/p5-Net-DNS
.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= p5-Tie-DBI>=1.05:${PORTSDIR}/databases/p5-Tie-DBI
+RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if ${PORT_OPTIONS:MMATCHRE}
@@ -127,28 +126,28 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/*.pl
do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/assp.pl ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/rebuildspamdb.pl ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/stat.pl ${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR}/images \
+ ${STAGEDIR}${DATADIR}/logs ${STAGEDIR}${DATADIR}/reports
+ ${INSTALL_SCRIPT} ${WRKSRC}/assp.pl ${STAGEDIR}${DATADIR}
+ (cd ${STAGEDIR} && ${LN} -sf ${DATADIR}/assp.pl ${STAGEDIR}${PREFIX}/sbin/assp)
+ ${INSTALL_SCRIPT} ${WRKSRC}/rebuildspamdb.pl ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/stat.pl ${STAGEDIR}${DATADIR}
( cd ${WRKSRC} && ${COPYTREE_SHARE} "files images reports" \
- ${DATADIR}/ "! -name '*.orig' ! -name '*.bak'" )
+ ${STAGEDIR}${DATADIR}/ "! -name '*.orig' ! -name '*.bak'" )
- ${INSTALL_SCRIPT} ${WRKDIR}/assplog.pl ${PREFIX}/sbin/assplog
+ ${INSTALL_SCRIPT} ${WRKDIR}/assplog.pl ${STAGEDIR}${PREFIX}/sbin/assplog
- ${INSTALL_MAN} ${WRKDIR}/assp.8 ${MAN8PREFIX}/man/man8
- ${INSTALL_MAN} ${WRKDIR}/assplog.8 ${MAN8PREFIX}/man/man8
-
- ${MKDIR} ${PREFIX}/etc/periodic/daily
- ${INSTALL_SCRIPT} ${WRKDIR}/510.assp ${PREFIX}/etc/periodic/daily/
+ ${INSTALL_MAN} ${WRKDIR}/assp.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKDIR}/assplog.8 ${STAGEDIR}${MAN8PREFIX}/man/man8
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/periodic/daily
+ ${INSTALL_SCRIPT} ${WRKDIR}/510.assp ${STAGEDIR}${PREFIX}/etc/periodic/daily/
+ ${MKDIR} ${STAGEDIR}${ASSP_HOME}
+ ${MKDIR} ${STAGEDIR}${ASSP_LOG}
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/*.htm ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.htm ${STAGEDIR}${DOCSDIR}
.endif
-post-install:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/mail/assp/distinfo b/mail/assp/distinfo
index a81cb2504c1c..1c9f92e1789c 100644
--- a/mail/assp/distinfo
+++ b/mail/assp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ASSP_1.9.9.13257_Install.zip) = 657106e254baf1a9da182ed89c0d8a1b342110b0f01686cc7582e6b9e2f19a1c
-SIZE (ASSP_1.9.9.13257_Install.zip) = 1741147
+SHA256 (ASSP_1.9.9.14158_Install.zip) = 1237a965ca3475a5cdabf786d470d295ce70ff030307d903b979b8c7ac80e186
+SIZE (ASSP_1.9.9.14158_Install.zip) = 1347031
diff --git a/mail/assp/files/patch-assp.pl b/mail/assp/files/patch-assp.pl
index 6e7513eb1963..d027144d5648 100644
--- a/mail/assp/files/patch-assp.pl
+++ b/mail/assp/files/patch-assp.pl
@@ -1,16 +1,12 @@
---- assp.pl.orig 2013-08-12 14:12:11.000000000 -0500
-+++ assp.pl 2013-08-12 14:15:10.000000000 -0500
-@@ -2758,15 +2758,15 @@
+--- assp.pl.orig 2014-07-02 16:55:36.000000000 -0500
++++ assp.pl 2014-07-02 16:56:22.000000000 -0500
+@@ -2767,11 +2767,11 @@
'Set the characterset/codepage for the maillog output to your local needs. Best on non Windows systems is "utf8" if available or "System Default" - no conversion. On Windows systems set it to your local codepage or UTF-8 (chcp 65001). To display nonASCII characters in the subject line and maillog files names setup decodeMIME2UTF8 .'],
['decodeMIME2UTF8','Decode MIME Words To UTF-8',1,\&checkbox,'1','(.*)',undef,'If selected, ASSP decodes MIME encoded words to UTF8. This enables support for national languages to be used in Bombs , Scripts , Spamdb , Logging. If not selected, only US-ASCII characters will be used for this functions. This requires an installed Email::MIME module in PERL.'],
['AsAService','Run ASSP as a Windows Service',0,\&checkbox,'','(.*)',undef,'In Windows NT/2000/XP/2003 ASSP can be installed as a service. This setting tells ASSP that this has been done -- it does not install the Windows service for you. Installing ASSP as a service requires several steps which are detailed in the <a href="http://apps.sourceforge.net/mediawiki/assp/index.php?title=Win32">Quick Start for Win32</a> doku page.<br /> Information about the Win32::Daemon module which which is necessary can be found here: <a href="http://www.roth.net/perl/Daemon/">The Official Win32::Daemon Home Page</a><br /><span class="negative"> requires ASSP restart</span>'],
--['AsADaemon','Run ASSP as a Daemon','0:No|1:Yes - externaly controlled|2:Yes - run AutoRestartCmd on restart and wait|3:Yes - run AutoRestartCmd on restart and exit',\&listbox,'0','(.*)',undef,'In Linux/BSD/Unix/OSX fork and close file handles. <br />
-+['AsADaemon','Run ASSP as a Daemon','0:No|1:Yes - externaly controlled|2:Yes - run AutoRestartCmd on restart and wait|3:Yes - run AutoRestartCmd on restart and exit',\&listbox,'1','(.*)',undef,'In Linux/BSD/Unix/OSX fork and close file handles. <br />
- Similar to the command "perl assp.pl &amp;", but better.<br />
- If "externaly controlled" is selected, ASSP simply ends and you have to restart assp from your daemon or watchdog script<br />
- If "run AutoRestartCmd on restart and wait" is selected, assp starts the OS command defined in AutoRestartCmd - assp will <b>NOT !</b> automaticaly terminate - the started command has to terminate/kill and to (re)start assp - like "service assp restart"!<br />
- If "run AutoRestartCmd on restart and exit" is selected, assp starts the OS command defined in AutoRestartCmd and terminates immediatly!<br />
- <span class="negative"> requires ASSP restart</span>',undef,undef,'msg007440','msg007441'],
+-['AsADaemon','Run ASSP as a Daemon',0,\&checkbox,'','(.*)',undef,'In Linux/BSD/Unix/OSX fork and exit. Similar to the command "perl assp.pl &amp;", but better.<br />
++['AsADaemon','Run ASSP as a Daemon',0,\&checkbox,'1','(.*)',undef,'In Linux/BSD/Unix/OSX fork and exit. Similar to the command "perl assp.pl &amp;", but better.<br />
+ <span class="negative"> Changing this requires a restart of ASSP.</span>'],
-['runAsUser','Run as UID',20,\&textinput,'','(\S*)',undef,'The *nix user name to assume after startup (*nix only).<p><small><i>Examples:</i> assp, nobody</small></p>
+['runAsUser','Run as UID',20,\&textinput,'assp','(\S*)',undef,'The *nix user name to assume after startup (*nix only).<p><small><i>Examples:</i> assp, nobody</small></p>
<span class="negative"> Changing this requires a restart of ASSP.</span>'],
diff --git a/mail/assp/files/pkg-install.in b/mail/assp/files/pkg-install.in
deleted file mode 100644
index 7eff4808f261..000000000000
--- a/mail/assp/files/pkg-install.in
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/bin/sh
-# $FreeBSD$
-
-if [ "${2}" = "POST-INSTALL" ]; then
- ASSP_USER=%%ASSP_USER%%
- ASSP_GROUP=%%ASSP_GROUP%%
- ASSP_HOME=%%ASSP_HOME%%
- ASSP_LOG=%%ASSP_LOG%%
- DATADIR=${PKG_PREFIX}/share/assp
-
- chmod -R 755 ${DATADIR}/files
- chown -R ${ASSP_USER}:${ASSP_GROUP} ${DATADIR}/files
-
- ln -sf ${DATADIR}/assp.pl ${PKG_PREFIX}/sbin/assp
-
- install -d -m 750 -o ${ASSP_USER} -g ${ASSP_GROUP} ${ASSP_LOG}
- install -d -m 700 -o ${ASSP_USER} -g ${ASSP_GROUP} ${ASSP_HOME}
-
- ln -sf ${DATADIR}/files ${ASSP_HOME}
- ln -sf ${DATADIR}/images ${ASSP_HOME}
- ln -sf ${DATADIR}/reports ${ASSP_HOME}
- ln -sf ${DATADIR}/rebuildspamdb.pl ${ASSP_HOME}
- ln -sf ${ASSP_LOG} ${ASSP_HOME}/logs
-
-fi
diff --git a/mail/assp/pkg-plist b/mail/assp/pkg-plist
index 8c8d12ea5aeb..0ae623669de2 100644
--- a/mail/assp/pkg-plist
+++ b/mail/assp/pkg-plist
@@ -2,10 +2,13 @@ etc/periodic/daily/510.assp
sbin/assp
sbin/assplog
%%DATADIR%%/assp.pl
+@owner %%ASSP_USER%%
+@group %%ASSP_GROUP%%
%%DATADIR%%/files/URIBLCCTLDS.txt
%%DATADIR%%/files/blackaddresses.txt
%%DATADIR%%/files/blackdomains.txt
%%DATADIR%%/files/blackre.txt
+%%DATADIR%%/files/blacksenderbase.txt
%%DATADIR%%/files/blockreportlist.txt
%%DATADIR%%/files/bombdatare.txt
%%DATADIR%%/files/bombheaderre.txt
@@ -17,11 +20,13 @@ sbin/assplog
%%DATADIR%%/files/deny.txt
%%DATADIR%%/files/denyalways.txt
%%DATADIR%%/files/dnsbls.txt
+%%DATADIR%%/files/dnsrws.txt
%%DATADIR%%/files/droplist.txt
%%DATADIR%%/files/groups.txt
%%DATADIR%%/files/invalidhelo.txt
%%DATADIR%%/files/invalidptr.txt
%%DATADIR%%/files/ipnp.txt
+%%DATADIR%%/files/ipnpexclude.txt
%%DATADIR%%/files/noblocking.txt
%%DATADIR%%/files/nodelay.txt
%%DATADIR%%/files/nodelayhelosre.txt
@@ -34,16 +39,20 @@ sbin/assplog
%%DATADIR%%/files/preheaderre.txt
%%DATADIR%%/files/rcptreplrules.txt
%%DATADIR%%/files/redre.txt
+%%DATADIR%%/files/samesubjectskip.txt
%%DATADIR%%/files/strictspf.txt
%%DATADIR%%/files/subjectre.txt
%%DATADIR%%/files/suspiciousre.txt
%%DATADIR%%/files/suspiciousvirus.txt
%%DATADIR%%/files/tlds-alpha-by-domain.txt
-%%DATADIR%%/files/uriblwhite.txt
%%DATADIR%%/files/uriblserviceprovider.txt
+%%DATADIR%%/files/uriblwhite.txt
+%%DATADIR%%/files/validhelo.txt
%%DATADIR%%/files/validptr.txt
%%DATADIR%%/files/whiteptr.txt
-%%DATADIR%%/files/whiteorg.txt
+%%DATADIR%%/files/whitesenderbase.txt
+@owner
+@group
%%DATADIR%%/images/assp.css
%%DATADIR%%/images/blockreport.css
%%DATADIR%%/images/blockreport.gif
@@ -77,6 +86,7 @@ sbin/assplog
%%DATADIR%%/reports/notspamreport.txt
%%DATADIR%%/reports/npremovereport.txt
%%DATADIR%%/reports/npreport.txt
+%%DATADIR%%/reports/persblackreport.txt
%%DATADIR%%/reports/redremovereport.txt
%%DATADIR%%/reports/redreport.txt
%%DATADIR%%/reports/slremovereport.txt
@@ -89,18 +99,31 @@ sbin/assplog
%%PORTDOCS%%%%DOCSDIR%%/Legacy - ASSP Documentation.htm
%%PORTDOCS%%%%DOCSDIR%%/Regular Expression Tutorial.htm
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm %%DATADIR%%/reports
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/files
-@dirrm %%DATADIR%%
+man/man8/assp.8.gz
+man/man8/assplog.8.gz
+@dirrmtry %%DATADIR%%/reports
+@dirrmtry %%DATADIR%%/logs
+@dirrmtry %%DATADIR%%/images
+@dirrmtry %%DATADIR%%/files
+@dirrmtry %%DATADIR%%
@dirrmtry etc/periodic/daily
@dirrmtry etc/periodic
-@unexec rm -f %%ASSP_HOME%%/logs
-@unexec rm -f %%ASSP_HOME%%/reports
-@unexec rm -f %%ASSP_HOME%%/images
+@exec ln -sf %D/%%DATADIR%%/files %%ASSP_HOME%%/
@unexec rm -f %%ASSP_HOME%%/files
-@unexec rmdir %%ASSP_HOME%% 2>/dev/null || true
+@exec ln -sf %D/%%DATADIR%%/images %%ASSP_HOME%%/
+@unexec rm -f %%ASSP_HOME%%/images
+@exec ln -sf %D/%%DATADIR%%/rebuildspamdb.pl %%ASSP_HOME%%/
+@unexec rm -f %%ASSP_HOME%%/rebuildspamdb.pl
+@exec ln -sf %D/%%DATADIR%%/reports %%ASSP_HOME%%/
+@unexec rm -f %%ASSP_HOME%%/reports
+@exec ln -sf %%ASSP_LOG%% %%ASSP_HOME%%/logs
+@unexec rm -f %%ASSP_HOME%%/logs
+@cwd /
+@owner %%ASSP_USER%%
+@group %%ASSP_GROUP%%
+@mode 750
+@dirrmtry %%ASSP_LOG%%
+@dirrmtry %%ASSP_HOME%%
@unexec if [ -d %%ASSP_HOME%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_HOME%% directory."; fi
-@unexec rmdir %%ASSP_LOG%% 2>/dev/null || true
@unexec if [ -d %%ASSP_LOG%% ]; then echo "If you are deinstalling ASSP completely, remove the %%ASSP_LOG%% directory."; fi
@unexec echo "If you are deinstalling ASSP completely, delete the ASSP user and group."