aboutsummaryrefslogtreecommitdiff
path: root/mail/biabam
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2004-03-30 13:42:35 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2004-03-30 13:42:35 +0000
commit460dd071d43f40bea2c08c4c4f210551f013e0e1 (patch)
tree5f1942b750e42a7ebacc80b62665a05f55992647 /mail/biabam
parent87870f1ab882f34d971bc0570ed4df9f2aad8bc6 (diff)
downloadports-460dd071d43f40bea2c08c4c4f210551f013e0e1.tar.gz
ports-460dd071d43f40bea2c08c4c4f210551f013e0e1.zip
Add bash to RUN_DEPENDS list.
Use REINPLACE_CMD for correct path to bash.
Notes
Notes: svn path=/head/; revision=105700
Diffstat (limited to 'mail/biabam')
-rw-r--r--mail/biabam/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/mail/biabam/Makefile b/mail/biabam/Makefile
index f5227b923f75..24f08f75827e 100644
--- a/mail/biabam/Makefile
+++ b/mail/biabam/Makefile
@@ -5,16 +5,23 @@
# $FreeBSD$
#
-PORTNAME= biabam
-PORTVERSION= 0.9.5
-CATEGORIES= mail
-MASTER_SITES= http://mmj.dk/biabam/
+PORTNAME= biabam
+PORTVERSION= 0.9.5
+CATEGORIES= mail
+MASTER_SITES= http://mmj.dk/biabam/
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A command-line attachment mailer
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A command-line attachment mailer
-NO_BUILD= yes
-PLIST_FILES= bin/biabam
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+PLIST_FILES= bin/biabam
+
+do-patch:
+ @${REINPLACE_CMD} -e 's|\(#!\)\(/bin/bash\)|\1${LOCALBASE}\2|' \
+ ${WRKSRC}/${PORTNAME}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/biabam ${PREFIX}/bin