aboutsummaryrefslogtreecommitdiff
path: root/mail/bsfilter
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-12-19 22:07:20 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-12-19 22:07:20 +0000
commit22aeec3703e9da3803cf1a756702b2bcbbe4335a (patch)
tree7440793cf2253387e3593c64cc8ba61a17a3e5e6 /mail/bsfilter
parent3cb0b326b0d525401055e2609e027fff9da48077 (diff)
downloadports-22aeec3703e9da3803cf1a756702b2bcbbe4335a.tar.gz
ports-22aeec3703e9da3803cf1a756702b2bcbbe4335a.zip
- Update to 1.0.6
PR: ports/75245 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=124529
Diffstat (limited to 'mail/bsfilter')
-rw-r--r--mail/bsfilter/Makefile17
-rw-r--r--mail/bsfilter/distinfo4
-rw-r--r--mail/bsfilter/pkg-message4
3 files changed, 16 insertions, 9 deletions
diff --git a/mail/bsfilter/Makefile b/mail/bsfilter/Makefile
index a17a6a6b9fae..b8016ad510f1 100644
--- a/mail/bsfilter/Makefile
+++ b/mail/bsfilter/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= bsfilter
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.6
CATEGORIES= mail ruby
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
-MASTER_SITE_SUBDIR= bsfilter/10876
+MASTER_SITE_SUBDIR= bsfilter/12638
EXTRACT_SUFX= .tgz
MAINTAINER= info@otsune.com
@@ -20,12 +20,16 @@ RUN_DEPENDS= ${RUBY_ARCHLIBDIR}/gdbm.so:${PORTSDIR}/databases/ruby-gdbm
NO_BUILD= yes
USE_RUBY= yes
-OPTIONS= MECAB "Use japanese/mecab" off \
- KAKASI "Use japanese/kakasi" off
+OPTIONS= CHASEN "Japanese Morphological Analysis Support" Off \
+ MECAB "Part-of-Speech and Morphological Analyzer(i386 only)" Off \
+ KAKASI "Language processing filter/converter" Off
.include <bsd.port.pre.mk>
-.if defined(WITH_MECAB)
+.if defined(WITH_CHASEN)
+RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/chasen.so:${PORTSDIR}/japanese/ruby-chasen
+.endif
+.if ${ARCH} == i386 && defined(WITH_MECAB)
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/MeCab.so:${PORTSDIR}/japanese/ruby-mecab
.endif
.if defined(WITH_KAKASI)
@@ -44,4 +48,7 @@ do-install:
.endfor
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>
diff --git a/mail/bsfilter/distinfo b/mail/bsfilter/distinfo
index 1d261dc4e166..9af7f437ae2c 100644
--- a/mail/bsfilter/distinfo
+++ b/mail/bsfilter/distinfo
@@ -1,2 +1,2 @@
-MD5 (bsfilter-1.0.4.tgz) = 6fb0bb985bd6c4cbac1d5589de03d985
-SIZE (bsfilter-1.0.4.tgz) = 862941
+MD5 (bsfilter-1.0.6.tgz) = da1cfbe99b13e372644fc433306ec55f
+SIZE (bsfilter-1.0.6.tgz) = 863767
diff --git a/mail/bsfilter/pkg-message b/mail/bsfilter/pkg-message
index fe92163d5c8c..6cf88ec33883 100644
--- a/mail/bsfilter/pkg-message
+++ b/mail/bsfilter/pkg-message
@@ -1,12 +1,12 @@
Before actually using it, it is necessary to prepare a word database.
1.The word contained in clean mail is counted.
-% bsfilter --add-clean ~/Maildir/.cur/*
+% bsfilter --add-clean ~/Maildir/cur/*
or
% cd ~/Maildir/cur/ ; ls | xargs bsfilter -c
2.The word in spam is counted.
-% bsfilter --add-spam ~/Maildir/.spam/*
+% bsfilter --add-spam ~/Maildir/.spam/cur/*
or
% cd ~/Maildir/.spam/cur/ ; ls | xargs bsfilter -s