aboutsummaryrefslogtreecommitdiff
path: root/mail/cclient
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-12 11:18:34 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-11-12 11:18:34 +0000
commit74e6c1b88b5558d240afd32332882e98fb2e1a1a (patch)
treeda629869077c6b5a760a603cef5fe66506a48d92 /mail/cclient
parent72f28ff3aabb9c9c7ac3f369aab67a1ded64bcb4 (diff)
downloadports-74e6c1b88b5558d240afd32332882e98fb2e1a1a.tar.gz
ports-74e6c1b88b5558d240afd32332882e98fb2e1a1a.zip
mail/cclient: Unbreak in 11.4 and 12.2
Dimitry sent a more generic patch that workarounds the problem in mail/cclient instead of its consumers. Related to r554904. PR: 250740 Submitted by: dim@FreeBSD.org Reported by: colin@fbug.ksac.uk MFH: 2020Q4 (blanket, build fix)
Notes
Notes: svn path=/head/; revision=554949
Diffstat (limited to 'mail/cclient')
-rw-r--r--mail/cclient/Makefile2
-rw-r--r--mail/cclient/files/patch-src_c-client_c-client.h26
2 files changed, 27 insertions, 1 deletions
diff --git a/mail/cclient/Makefile b/mail/cclient/Makefile
index 76412447fa84..129ecfb2dbd6 100644
--- a/mail/cclient/Makefile
+++ b/mail/cclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cclient
PORTVERSION= 2007f
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= mail devel
MASTER_SITES= ftp://ftp.cac.washington.edu/imap/%SUBDIR%/ \
diff --git a/mail/cclient/files/patch-src_c-client_c-client.h b/mail/cclient/files/patch-src_c-client_c-client.h
new file mode 100644
index 000000000000..d9123468f14c
--- /dev/null
+++ b/mail/cclient/files/patch-src_c-client_c-client.h
@@ -0,0 +1,26 @@
+--- src/c-client/c-client.h.orig 2011-07-23 00:20:18 UTC
++++ src/c-client/c-client.h
+@@ -39,7 +39,23 @@ extern "C" {
+ #endif
+
+ #include "mail.h" /* primary interfaces */
++
++#ifdef __cplusplus /* undo hacks before including OS headers */
++#undef private
++#undef and
++#undef or
++#undef not
++#endif
++
+ #include "osdep.h" /* OS-dependent routines */
++
++#ifdef __cplusplus /* redo hacks after including OS headers */
++#define private cclientPrivate
++#define and cclientAnd
++#define or cclientOr
++#define not cclientNot
++#endif
++
+ #include "rfc822.h" /* RFC822 and MIME routines */
+ #include "smtp.h" /* SMTP sending routines */
+ #include "nntp.h" /* NNTP sending routines */