aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-bsfilter
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-27 21:56:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-27 21:56:26 +0000
commit51cb9164766a420fa52627dfeb7bd27e0a807a41 (patch)
tree780dd237767d546fb377254d9075d80f1bca21c1 /mail/claws-mail-bsfilter
parent1f9bcafcc753be5ff71e82c0d8e8b5c41921eb28 (diff)
downloadports-51cb9164766a420fa52627dfeb7bd27e0a807a41.tar.gz
ports-51cb9164766a420fa52627dfeb7bd27e0a807a41.zip
Check all messages that are received from an IMAP, LOCAL
or POP account for spam using Bsfilter. WWW: http://www.claws-mail.org/plugins.php
Notes
Notes: svn path=/head/; revision=244865
Diffstat (limited to 'mail/claws-mail-bsfilter')
-rw-r--r--mail/claws-mail-bsfilter/Makefile35
-rw-r--r--mail/claws-mail-bsfilter/distinfo3
-rw-r--r--mail/claws-mail-bsfilter/pkg-descr4
-rw-r--r--mail/claws-mail-bsfilter/pkg-plist14
4 files changed, 56 insertions, 0 deletions
diff --git a/mail/claws-mail-bsfilter/Makefile b/mail/claws-mail-bsfilter/Makefile
new file mode 100644
index 000000000000..2b8fbdbe286d
--- /dev/null
+++ b/mail/claws-mail-bsfilter/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: claws-mail-bsfilter
+# Date created: 27 November 2009
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsfilter
+PORTVERSION= 1.0.2
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
+PKGNAMEPREFIX= claws-mail-
+DISTNAME= bsfilter_plugin-${PORTVERSION}
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= bsfilter plugin for claws-mail
+
+BUILD_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
+
+USE_GMAKE= yes
+USE_XORG= x11
+USE_AUTOTOOLS= autoconf:262
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.include <bsd.port.mk>
diff --git a/mail/claws-mail-bsfilter/distinfo b/mail/claws-mail-bsfilter/distinfo
new file mode 100644
index 000000000000..1b5493ad20e5
--- /dev/null
+++ b/mail/claws-mail-bsfilter/distinfo
@@ -0,0 +1,3 @@
+MD5 (bsfilter_plugin-1.0.2.tar.gz) = 78c43b28aea0427aa4b4e3ea89ae1be8
+SHA256 (bsfilter_plugin-1.0.2.tar.gz) = e7e857996ba8aed86ed199ace5c37f9ed35f19c27c5635177ffd104d483236db
+SIZE (bsfilter_plugin-1.0.2.tar.gz) = 373230
diff --git a/mail/claws-mail-bsfilter/pkg-descr b/mail/claws-mail-bsfilter/pkg-descr
new file mode 100644
index 000000000000..f89e64cdbf6b
--- /dev/null
+++ b/mail/claws-mail-bsfilter/pkg-descr
@@ -0,0 +1,4 @@
+Check all messages that are received from an IMAP, LOCAL
+or POP account for spam using Bsfilter.
+
+WWW: http://www.claws-mail.org/plugins.php
diff --git a/mail/claws-mail-bsfilter/pkg-plist b/mail/claws-mail-bsfilter/pkg-plist
new file mode 100644
index 000000000000..a8a790069939
--- /dev/null
+++ b/mail/claws-mail-bsfilter/pkg-plist
@@ -0,0 +1,14 @@
+lib/claws-mail/plugins/bsfilter.a
+lib/claws-mail/plugins/bsfilter.la
+lib/claws-mail/plugins/bsfilter.so
+%%NLS%%share/locale/cs/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/bsfilter_plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/bsfilter_plugin.mo
+@dirrm lib/claws-mail/plugins
+@dirrm lib/claws-mail