aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-python/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-27 21:57:00 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-27 21:57:00 +0000
commit0fb48a40944122c9c5ffe2beab38c8ab86d1584e (patch)
tree09088912f21e98cd46f2844baa1f92a136efff68 /mail/claws-mail-python/Makefile
parent51cb9164766a420fa52627dfeb7bd27e0a807a41 (diff)
downloadports-0fb48a40944122c9c5ffe2beab38c8ab86d1584e.tar.gz
ports-0fb48a40944122c9c5ffe2beab38c8ab86d1584e.zip
Notes
Diffstat (limited to 'mail/claws-mail-python/Makefile')
-rw-r--r--mail/claws-mail-python/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/mail/claws-mail-python/Makefile b/mail/claws-mail-python/Makefile
new file mode 100644
index 000000000000..2c9a7d2cfa40
--- /dev/null
+++ b/mail/claws-mail-python/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: claws-mail-python
+# Date created: 27 November 2009
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= python
+PORTVERSION= 0.2
+CATEGORIES= mail
+MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
+PKGNAMEPREFIX= claws-mail-
+DISTNAME= python_plugin-${PORTVERSION}
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Python plugin for claws-mail
+
+BUILD_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.7.3:${PORTSDIR}/mail/claws-mail
+
+USE_GNOME= pygtk2
+USE_GMAKE= yes
+USE_XORG= x11
+USE_AUTOTOOLS= autoconf:262
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>