aboutsummaryrefslogtreecommitdiff
path: root/mail/cone
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-11 08:34:17 +0000
commit8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f (patch)
tree82565381028ebd8b5a674bafdecce3a45c5c2e6d /mail/cone
parent0a59b351f616abe849539bc2afbc8eba4abe8004 (diff)
downloadports-8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f.tar.gz
ports-8d27ddb9bd993385ce5d7a9b17e2fe231ec8c69f.zip
Add a new macro to deal with conflict between ncurses from base and ncurses from ports.
If a ports is linked against ncurses from base or from the ports, it should then add: USE_NCURSES=yes it is also possible to specify the hard dependency on the ports ncurses or one the base one adding the following macros: WITH_NCURSES_PORT=yes or WITH_NCURSES_BASE=yes PR: ports/155269 Submitted by: me Reviwed by: pav@ Approved by: portmgr (pav@) Exp-run by: portmgr (pav@)
Notes
Notes: svn path=/head/; revision=272515
Diffstat (limited to 'mail/cone')
-rw-r--r--mail/cone/Makefile21
1 files changed, 4 insertions, 17 deletions
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 715c89784b13..0952fd85ab4c 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -30,37 +30,24 @@ USE_GNOME= libxml2
USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
-CPPFLAGS= -I${LOCALBASE}/include
+USE_NCURSES= yes
+CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
CONFIGURE_ARGS= -C --without-db --with-certdb=${PREFIX}/share/cone/rootcerts --prefix=${PREFIX} --exec-prefix=${PREFIX}
-CONFIGURE_ENV= REHASH="${PERL} ${SCRIPTDIR}/c_rehash" LDFLAGS=-L${LOCALBASE}/lib \
- CPPFLAGS="${CPPFLAGS}"
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= REHASH="${PERL} ${SCRIPTDIR}/c_rehash"
MAN1= cone.1 leaf.1 mailtool.1
INSTALL_TARGET= install-strip
.include <bsd.port.pre.mk>
-.if ${OSVERSION} > 700032 || (${OSVERSION} < 700000 && ${OSVERSION} > 602106)
CPPFLAGS+= -D_XOPEN_SOURCE_EXTENDED
-.elif exists(${LOCALBASE}/include/ncurses/ncurses.h) || defined(WITH_NCURSESW)
CPPFLAGS+= -I${WRKDIR} -D_XOPEN_SOURCE_EXTENDED
-LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
post-extract:
${MKDIR} ${WRKDIR}/ncursesw
${LN} -s ${LOCALBASE}/include/ncurses/ncurses.h ${WRKDIR}/ncursesw/curses.h
-.else
-
-CONFIGURE_ARGS+= --disable-unicode
-
-pre-everything::
- @${ECHO_CMD} ""
- @${ECHO_CMD} "to use multilanguage ( unicode ) MUA, please set WITH_NCURSESW"
- @${ECHO_CMD} "or install devel/ncurses first"
- @${ECHO_CMD} ""
-
-.endif
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${PREFIX}/sbin/cone-sysconftool