aboutsummaryrefslogtreecommitdiff
path: root/mail/cone
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-10-28 15:45:45 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-10-28 15:45:45 +0000
commit8df20cbbba8d99848568586e9941fdf73e7c2043 (patch)
tree89f0a0f358d6d58fb94eb6219e84f8bdc6677f9f /mail/cone
parenta8f51ee484c268b677f9173f23349597792e19ef (diff)
downloadports-8df20cbbba8d99848568586e9941fdf73e7c2043.tar.gz
ports-8df20cbbba8d99848568586e9941fdf73e7c2043.zip
- Update to 0.92 [1]
- Fix build without SSLv3 [2] Thanks ro brnrd for providing an updated patch. PR: 202677 [1], 203697 [2] Submitted by: yamagi at yamagi.org [1] Submitted by: cpbsdmail at gmail.com [2] MFH: 2015Q4
Notes
Notes: svn path=/head/; revision=400398
Diffstat (limited to 'mail/cone')
-rw-r--r--mail/cone/Makefile21
-rw-r--r--mail/cone/distinfo4
-rw-r--r--mail/cone/files/patch-cone_cursesmessage.C15
-rw-r--r--mail/cone/files/patch-curses-cursescontainer-C.diff11
-rw-r--r--mail/cone/files/patch-libmail-envelope-h.diff10
-rw-r--r--mail/cone/files/patch-libmail_envelope.H10
-rw-r--r--mail/cone/files/patch-libs_tcpd_libcouriertls.c18
-rw-r--r--mail/cone/pkg-plist20
8 files changed, 63 insertions, 46 deletions
diff --git a/mail/cone/Makefile b/mail/cone/Makefile
index 64e25375d77d..217fd90050fb 100644
--- a/mail/cone/Makefile
+++ b/mail/cone/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cone
-PORTVERSION= 0.90
-PORTREVISION= 4
+PORTVERSION= 0.92
CATEGORIES= mail
# This is for beta versions, leave it in please:
#MASTER_SITES= http://www.courier-mta.org/beta/${PORTNAME}/ \
@@ -16,33 +15,29 @@ COMMENT= Console based mail client with POP3/IMAP/SMAP support
LICENSE= GPLv3
-LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell \
+ libcourier-unicode.so:${PORTSDIR}/devel/courier-unicode
BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= fam gettext gmake iconv ncurses perl5 shebangfix tar:bzip2
USE_GNOME= libxml2
-USE_GCC= yes
SHEBANG_FILES= sysconftool
CPPFLAGS+= -I${LOCALBASE}/include \
- -D_XOPEN_SOURCE_EXTENDED \
- -I${WRKDIR} -D_XOPEN_SOURCE_EXTENDED
+ -D_XOPEN_SOURCE_EXTENDED
LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= -C --without-db --with-certdb=${PREFIX}/share/cone/rootcerts --exec-prefix=${PREFIX}
-CONFIGURE_ENV= REHASH="${PERL} ${SCRIPTDIR}/c_rehash"
-
+CONFIGURE_ARGS+= --with-certdb=${PREFIX}/share/cone/rootcerts --exec-prefix=${PREFIX}
INSTALL_TARGET= install-strip
OPTIONS_DEFINE= DOCS
-post-extract:
- @${MKDIR} ${WRKDIR}/ncursesw
- ${LN} -s ${LOCALBASE}/include/ncurses/ncurses.h ${WRKDIR}/ncursesw/curses.h
-
post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/leaf
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/mailtool
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/cone
${INSTALL_SCRIPT} ${WRKSRC}/sysconftool ${STAGEDIR}${PREFIX}/sbin/cone-sysconftool
${RM} -f ${STAGEDIR}${PREFIX}/share/cone/rootcerts/.0
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/mail/cone/distinfo b/mail/cone/distinfo
index 8bd62927670d..3d5474aa3980 100644
--- a/mail/cone/distinfo
+++ b/mail/cone/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cone-0.90.tar.bz2) = b03edfbf3392fb7b8d93574dad2bc4c7cbfca8890afabac8b99b21a9f46d8733
-SIZE (cone-0.90.tar.bz2) = 3906323
+SHA256 (cone-0.92.tar.bz2) = bfc1170565d931ac9b8a674410f44cb2472c7b755b5bb97e9915d37fdfe9d631
+SIZE (cone-0.92.tar.bz2) = 3774451
diff --git a/mail/cone/files/patch-cone_cursesmessage.C b/mail/cone/files/patch-cone_cursesmessage.C
new file mode 100644
index 000000000000..0f223a09d3d3
--- /dev/null
+++ b/mail/cone/files/patch-cone_cursesmessage.C
@@ -0,0 +1,15 @@
+--- cone/cursesmessage.C.orig 2014-01-06 19:51:56 UTC
++++ cone/cursesmessage.C
+@@ -3761,10 +3761,10 @@ bool CursesMessage::decrypt(std::string
+ gi.passphrase_fd=passphrase_fd.c_str();
+ }
+
+- gi.input_func= &tempSaveText.input_func;
++ gi.input_func= &CursesMessage::DecryptSaveText::input_func;
+ gi.input_func_arg= &tempSaveText;
+
+- gi.output_func= &tempSaveText.output_func;
++ gi.output_func= &CursesMessage::DecryptSaveText::output_func;
+ gi.output_func_arg= &tempSaveText;
+
+ gi.errhandler_func= &tempSaveText.err_func;
diff --git a/mail/cone/files/patch-curses-cursescontainer-C.diff b/mail/cone/files/patch-curses-cursescontainer-C.diff
deleted file mode 100644
index edf4665fd59e..000000000000
--- a/mail/cone/files/patch-curses-cursescontainer-C.diff
+++ /dev/null
@@ -1,11 +0,0 @@
---- curses/cursescontainer.C.orig 2014-06-24 00:25:29.000000000 +0200
-+++ curses/cursescontainer.C 2014-06-24 00:25:42.000000000 +0200
-@@ -10,7 +10,7 @@
- using namespace std;
-
- CursesContainer::CursesContainer(CursesContainer *parent)
-- : Curses(parent), drawIndex(0)
-+ : Curses(parent), drawIndex()
- {
- }
-
diff --git a/mail/cone/files/patch-libmail-envelope-h.diff b/mail/cone/files/patch-libmail-envelope-h.diff
deleted file mode 100644
index 08086a7f38ef..000000000000
--- a/mail/cone/files/patch-libmail-envelope-h.diff
+++ /dev/null
@@ -1,10 +0,0 @@
---- libmail/envelope.H.orig 2014-06-24 00:28:56.000000000 +0200
-+++ libmail/envelope.H 2014-06-24 00:29:36.000000000 +0200
-@@ -8,6 +8,7 @@
-
- #include <vector>
- #include <string>
-+#include <ctime>
-
- #include "namespace.H"
-
diff --git a/mail/cone/files/patch-libmail_envelope.H b/mail/cone/files/patch-libmail_envelope.H
new file mode 100644
index 000000000000..98cbf2154dac
--- /dev/null
+++ b/mail/cone/files/patch-libmail_envelope.H
@@ -0,0 +1,10 @@
+--- libmail/envelope.H.orig 2014-01-06 19:37:10 UTC
++++ libmail/envelope.H
+@@ -8,6 +8,7 @@
+
+ #include <vector>
+ #include <string>
++#include <time.h>
+
+ #include "namespace.H"
+
diff --git a/mail/cone/files/patch-libs_tcpd_libcouriertls.c b/mail/cone/files/patch-libs_tcpd_libcouriertls.c
new file mode 100644
index 000000000000..30f79f141630
--- /dev/null
+++ b/mail/cone/files/patch-libs_tcpd_libcouriertls.c
@@ -0,0 +1,18 @@
+--- libs/tcpd/libcouriertls.c.orig 2014-10-22 08:00:04 UTC
++++ libs/tcpd/libcouriertls.c
+@@ -74,7 +74,15 @@ struct proto_ops op_list[] =
+ { "TLSv1", &TLSv1_method, SSL_OP_ALL },
+ { "TLS1", &TLSv1_method, SSL_OP_ALL },
+ { "SSL3+", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2 },
++#ifndef OPENSSL_NO_SSL3
+ { "SSL3", &SSLv3_method, SSL_OP_ALL },
++#else
++ { "SSL3", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_TLSv1
++#ifdef HAVE_TLSV1_1_METHOD
++ |SSL_OP_NO_TLSv1_1|SSL_OP_NO_TLSv1_2
++#endif /* SSL_OP_NO_TLSv1 */
++ },
++#endif /* OPENSSL_NO_SSL3 */
+ { "SSL23", &SSLv23_method, SSL_OP_ALL },
+ { "", &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_SSLv3 },
+ { NULL, &SSLv23_method, SSL_OP_ALL|SSL_OP_NO_SSLv2|SSL_OP_NO_SSLv3 },
diff --git a/mail/cone/pkg-plist b/mail/cone/pkg-plist
index 52c3e3a3621b..a49e67828e34 100644
--- a/mail/cone/pkg-plist
+++ b/mail/cone/pkg-plist
@@ -1,16 +1,19 @@
bin/cone
bin/leaf
bin/mailtool
-sbin/cone-sysconftool
-etc/cone.dist
+@sample etc/cone.dist etc/cone
libexec/cone
man/man1/cone.1.gz
-man/man1/mailtool.1.gz
man/man1/leaf.1.gz
+man/man1/mailtool.1.gz
+sbin/cone-sysconftool
%%DATADIR%%/APPLICATION.PDF.filter
+%%DATADIR%%/FAQ.html
%%DATADIR%%/IMAGE.GIF.filter
%%DATADIR%%/IMAGE.JPEG.filter
%%DATADIR%%/IMAGE.PNG.filter
+%%DATADIR%%/INSTALL.html
+%%DATADIR%%/README.html
%%DATADIR%%/account-checknewmail.html
%%DATADIR%%/account-copymessagesto.html
%%DATADIR%%/account-createfolder.html
@@ -71,7 +74,6 @@ man/man1/leaf.1.gz
%%DATADIR%%/cppnamespace.html
%%DATADIR%%/emailaddress.html
%%DATADIR%%/envelope.html
-%%DATADIR%%/FAQ.html
%%DATADIR%%/folder-addmessage.html
%%DATADIR%%/folder-clone.html
%%DATADIR%%/folder-create.html
@@ -97,9 +99,10 @@ man/man1/leaf.1.gz
%%DATADIR%%/header-list.html
%%DATADIR%%/header-mime.html
%%DATADIR%%/header-plain.html
-%%DATADIR%%/index.html
+%%DATADIR%%/http.handler
+%%DATADIR%%/https.handler
%%DATADIR%%/icon.gif
-%%DATADIR%%/INSTALL.html
+%%DATADIR%%/index.html
%%DATADIR%%/leaf.html
%%DATADIR%%/libmail-folder.html
%%DATADIR%%/libmail-misc.html
@@ -148,18 +151,15 @@ man/man1/leaf.1.gz
%%DATADIR%%/misc.html
%%DATADIR%%/moredocs.html
%%DATADIR%%/native.html
-%%DATADIR%%/README.html
%%DATADIR%%/search.html
%%DATADIR%%/smap1.html
%%DATADIR%%/smapconcurrency.html
-%%DATADIR%%/smapfolders.html
%%DATADIR%%/smapcopymovemessages.html
+%%DATADIR%%/smapfolders.html
%%DATADIR%%/smaplogout.html
%%DATADIR%%/smapmessagecontents.html
%%DATADIR%%/smapsyntax.html
%%DATADIR%%/smapusingfolders.html
%%DATADIR%%/store.html
%%DATADIR%%/synchronous.html
-%%DATADIR%%/http.handler
-%%DATADIR%%/https.handler
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog