aboutsummaryrefslogtreecommitdiff
path: root/mail/courier-authlib-vchkpw
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2004-12-19 11:25:28 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2004-12-19 11:25:28 +0000
commitc16332dab7b02117be3c4acaa6e30ecc3845b910 (patch)
tree445b396957bf68e2b06a89be6539192b85a58b0a /mail/courier-authlib-vchkpw
parent359e55db9b7fe83cb717e6b676bffe23b2036f71 (diff)
downloadports-c16332dab7b02117be3c4acaa6e30ecc3845b910.tar.gz
ports-c16332dab7b02117be3c4acaa6e30ecc3845b910.zip
Add courier-authlib
<quote> Copies of this library code used to exist in other tarballs: Courier, Courier-IMAP, and SqWebMail. Building and installing any of these packages would've automatically installed this authentication code. The authentication library is now a separate, standalone package. This authentication library must now be installed, separately, before upgrading to the following builds (or if installing them for the first time): Courier 0.48, Courier-IMAP 4.0, and SqWebMail 5.0. See NEWS for more information. </quote> http://www.courier-mta.org/authlib/
Notes
Notes: svn path=/head/; revision=124478
Diffstat (limited to 'mail/courier-authlib-vchkpw')
-rw-r--r--mail/courier-authlib-vchkpw/Makefile133
-rw-r--r--mail/courier-authlib-vchkpw/distinfo2
-rw-r--r--mail/courier-authlib-vchkpw/files/courier-authdaemond.sh44
-rw-r--r--mail/courier-authlib-vchkpw/files/patch-Makefile.in13
-rw-r--r--mail/courier-authlib-vchkpw/files/patch-ldap13
-rw-r--r--mail/courier-authlib-vchkpw/files/patch-liblog::Makefile.in13
-rw-r--r--mail/courier-authlib-vchkpw/files/patch-mysql182
-rw-r--r--mail/courier-authlib-vchkpw/files/patch-userdb::Makefile.in13
-rw-r--r--mail/courier-authlib-vchkpw/pkg-descr7
-rw-r--r--mail/courier-authlib-vchkpw/pkg-plist58
10 files changed, 478 insertions, 0 deletions
diff --git a/mail/courier-authlib-vchkpw/Makefile b/mail/courier-authlib-vchkpw/Makefile
new file mode 100644
index 000000000000..6b5b5baa743c
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/Makefile
@@ -0,0 +1,133 @@
+# New ports collection makefile for: courier-authdaemon
+# Date created: 19 Dec 2004
+# Whom: Oliver Lehmann
+#
+# $FreeBSD$
+#
+
+PORTNAME= courier-authlib
+PORTVERSION= 0.51
+CATEGORIES= mail
+MASTER_SITES= http://www.courier-mta.org/beta/courier-authlib/
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= Authentication library used by courier ports
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_PERL5= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_RC_SUBR= yes
+USE_LIBTOOL_VER=15
+USE_LIBLTDL= yes
+
+#
+# options available:
+#
+# WITHOUT_PAM: Don't build in PAM support
+# WITH_VPOPMAIL: Build in vpopmail support
+# WITH_MYSQL: Build in mysql support
+# WITH_POSTGRESQL: Build in postgresql support
+# WITH_LDAP: Build in ldap support with openldap
+# WITH_GDBM: Use gdbm files instead of bdb
+#
+
+VPOPMAILDIR?= ${LOCALBASE}/vpopmail
+
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ CXXFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LIBS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-authshadow \
+ --enable-unicode \
+ --enable-ltdl-install=no
+
+.if defined(WITH_GDBM)
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+CONFIGURE_ARGS+= --with-db=gdbm
+.else
+CONFIGURE_ARGS+= --with-db=db
+.endif
+
+.if !defined(WITH_VPOPMAIL)
+CONFIGURE_ARGS+=--without-authvchkpw
+PLIST_SUB+= VPOPMAILFLAG="@comment "
+.else
+CONFIGURE_ARGS+=--with-authvchkpw
+BUILD_DEPENDS+= ${VPOPMAILDIR}/lib/libvpopmail.a:${PORTSDIR}/mail/vpopmail
+PLIST_SUB+= VPOPMAILFLAG=""
+.endif
+
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-authldap
+PLIST_SUB+= LDAPFLAG=""
+.else
+CONFIGURE_ARGS+=--without-authldap
+PLIST_SUB+= LDAPFLAG="@comment "
+.endif
+
+.if !defined(WITH_MYSQL)
+CONFIGURE_ARGS+=--without-authmysql
+PLIST_SUB+= MYSQLFLAG="@comment "
+.else
+USE_MYSQL= YES
+PLIST_SUB+= MYSQLFLAG=""
+CONFIGURE_ARGS+=--with-authmysql \
+ --with-mysql-libs=${LOCALBASE}/lib/mysql \
+ --with-mysql-includes=${LOCALBASE}/include/mysql
+.endif
+
+.if !defined(WITH_POSTGRESQL)
+CONFIGURE_ARGS+=--without-authpgsql
+PLIST_SUB+= PGSQLFLAG="@comment "
+.else
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+PLIST_SUB+= PGSQLFLAG=""
+.endif
+
+.if !defined(WITHOUT_PAM)
+CONFIGURE_ARGS+=--with-authpam
+PLIST_SUB+= PAMFLAG=""
+.else
+CONFIGURE_ARGS+=--without-authpam
+PLIST_SUB+= PAMFLAG="@comment "
+.endif
+
+.include <bsd.port.pre.mk>
+
+RC_SCRIPTS_SUB=PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
+MAN1= courierlogger.1
+
+MAN3= authlib.3 auth_generic.3 auth_login.3 auth_getuserinfo.3 \
+ auth_enumerate.3 auth_passwd.3 auth_getoption.3 auth_sasl.3
+
+MAN8= makeuserdb.8 userdb.8 userdbpw.8
+
+EXTRA_DOCS= README INSTALL AUTHORS ChangeLog
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$VPOPMAILLIBS|& -lcrypt|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|%%INSTALL_MAN%%|${INSTALL_MAN}|' \
+ ${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/liblog/Makefile.in ${WRKSRC}/userdb/Makefile.in
+
+post-install:
+ ${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/courier-authdaemond.sh > ${WRKDIR}/courier-authdaemond.sh
+ ${INSTALL_SCRIPT} ${WRKDIR}/courier-authdaemond.sh ${PREFIX}/etc/rc.d/courier-authdaemond.sh
+ cd ${WRKSRC} && ( ${GMAKE} install-configure ; cd - )
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for a in ${EXTRA_DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/mail/courier-authlib-vchkpw/distinfo b/mail/courier-authlib-vchkpw/distinfo
new file mode 100644
index 000000000000..7146db0d7dff
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/distinfo
@@ -0,0 +1,2 @@
+MD5 (courier-authlib-0.51.tar.bz2) = 89cb2db63b3f6d402e435331e391ef80
+SIZE(courier-authlib-0.51.tar.bz2) = 1964171
diff --git a/mail/courier-authlib-vchkpw/files/courier-authdaemond.sh b/mail/courier-authlib-vchkpw/files/courier-authdaemond.sh
new file mode 100644
index 000000000000..b4af4c0b40fd
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/courier-authdaemond.sh
@@ -0,0 +1,44 @@
+#!/bin/sh
+#
+# An rc.subr-style startup script for courier-authdaemond service.
+
+# PROVIDE: courier_authdaemond
+# REQUIRE: LOGIN
+# KEYWORD: FreeBSD shutdown
+
+# Define these courier_authdaemond_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/courier_authdaemond
+#
+# DO NOT CHANGE THESE DEFAULT VALUES HERE
+
+courier_authdaemond_enable=${courier_authdaemond_enable-"NO"}
+
+. %%RC_SUBR%%
+
+name="courier_authdaemond"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/sbin/authdaemond"
+
+start_cmd="authdaemond_cmd start"
+stop_cmd="authdaemond_cmd stop"
+restart_cmd="authdaemond_cmd stop && authdaemond_cmd start"
+
+load_rc_config $name
+
+authdaemond_cmd () {
+ case $1 in
+ start)
+ echo "Starting ${name}."
+ ${command} start
+ ;;
+ stop)
+ echo "Stopping ${name}."
+ ${command} stop
+ ;;
+ esac
+}
+
+run_rc_command "$1"
+
diff --git a/mail/courier-authlib-vchkpw/files/patch-Makefile.in b/mail/courier-authlib-vchkpw/files/patch-Makefile.in
new file mode 100644
index 000000000000..03046540f679
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in.orig Sat Dec 18 17:25:16 2004
++++ Makefile.in Sat Dec 18 17:27:50 2004
+@@ -992,8 +992,8 @@
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man3dir)/$$inst'"; \
+- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man3dir)/$$inst"; \
++ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man3dir)/$$inst'"; \
++ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man3dir)/$$inst"; \
+ done
+ uninstall-man3:
+ @$(NORMAL_UNINSTALL)
diff --git a/mail/courier-authlib-vchkpw/files/patch-ldap b/mail/courier-authlib-vchkpw/files/patch-ldap
new file mode 100644
index 000000000000..1cae12242d67
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/patch-ldap
@@ -0,0 +1,13 @@
+--- configure.orig Wed Mar 3 05:54:13 2004
++++ configure Tue Mar 16 19:36:40 2004
+@@ -1268,6 +1268,10 @@
+ { (exit 1); exit 1; }; }
+ fi
+
++CFLAGS="$CFLAGS -I%%LOCALBASE%%/include"
++CPPFLAGS="$CPPFLAGS -I%%LOCALBASE%%/include"
++LDFLAGS="-L%%LOCALBASE%%/lib $LDFLAGS"
++
+ ac_ext=c
+ ac_cpp='$CPP $CPPFLAGS'
+ ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'
diff --git a/mail/courier-authlib-vchkpw/files/patch-liblog::Makefile.in b/mail/courier-authlib-vchkpw/files/patch-liblog::Makefile.in
new file mode 100644
index 000000000000..301ba9c2efba
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/patch-liblog::Makefile.in
@@ -0,0 +1,13 @@
+--- liblog/Makefile.in.orig Sat Dec 18 18:31:57 2004
++++ liblog/Makefile.in Sat Dec 18 18:32:18 2004
+@@ -346,8 +346,8 @@
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man1dir)/$$inst'"; \
+- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man1dir)/$$inst"; \
++ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man1dir)/$$inst'"; \
++ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man1dir)/$$inst"; \
+ done
+ uninstall-man1:
+ @$(NORMAL_UNINSTALL)
diff --git a/mail/courier-authlib-vchkpw/files/patch-mysql b/mail/courier-authlib-vchkpw/files/patch-mysql
new file mode 100644
index 000000000000..17f6042e3a47
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/patch-mysql
@@ -0,0 +1,182 @@
+--- configure.orig Sat Dec 18 17:28:54 2004
++++ configure Sat Dec 18 17:30:51 2004
+@@ -23821,9 +23821,9 @@
+ if test "$doauthmysql" = ""
+ then
+ LIBS="$MYSQL_LIBS $LIBS"
+- echo "$as_me:$LINENO: checking for mysql_connect" >&5
+-echo $ECHO_N "checking for mysql_connect... $ECHO_C" >&6
+-if test "${ac_cv_func_mysql_connect+set}" = set; then
++ echo "$as_me:$LINENO: checking for mysql_real_connect" >&5
++echo $ECHO_N "checking for mysql_real_connect... $ECHO_C" >&6
++if test "${ac_cv_func_mysql_real_connect+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ cat >conftest.$ac_ext <<_ACEOF
+@@ -23832,12 +23832,12 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-/* Define mysql_connect to an innocuous variant, in case <limits.h> declares mysql_connect.
++/* Define mysql_real_connect to an innocuous variant, in case <limits.h> declares mysql_real_connect.
+ For example, HP-UX 11i <limits.h> declares gettimeofday. */
+-#define mysql_connect innocuous_mysql_connect
++#define mysql_real_connect innocuous_mysql_real_connect
+
+ /* System header to define __stub macros and hopefully few prototypes,
+- which can conflict with char mysql_connect (); below.
++ which can conflict with char mysql_real_connect (); below.
+ Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
+ <limits.h> exists even on freestanding compilers. */
+
+@@ -23847,7 +23847,7 @@
+ # include <assert.h>
+ #endif
+
+-#undef mysql_connect
++#undef mysql_real_connect
+
+ /* Override any gcc2 internal prototype to avoid an error. */
+ #ifdef __cplusplus
+@@ -23856,14 +23856,14 @@
+ #endif
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char mysql_connect ();
++char mysql_real_connect ();
+ /* The GNU C library defines this for functions which it implements
+ to always fail with ENOSYS. Some functions are actually named
+ something starting with __ and the normal name is an alias. */
+-#if defined (__stub_mysql_connect) || defined (__stub___mysql_connect)
++#if defined (__stub_mysql_real_connect) || defined (__stub___mysql_real_connect)
+ choke me
+ #else
+-char (*f) () = mysql_connect;
++char (*f) () = mysql_real_connect;
+ #endif
+ #ifdef __cplusplus
+ }
+@@ -23872,7 +23872,7 @@
+ int
+ main ()
+ {
+-return f != mysql_connect;
++return f != mysql_real_connect;
+ ;
+ return 0;
+ }
+@@ -23899,19 +23899,19 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- ac_cv_func_mysql_connect=yes
++ ac_cv_func_mysql_real_connect=yes
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+
+-ac_cv_func_mysql_connect=no
++ac_cv_func_mysql_real_connect=no
+ fi
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ fi
+-echo "$as_me:$LINENO: result: $ac_cv_func_mysql_connect" >&5
+-echo "${ECHO_T}$ac_cv_func_mysql_connect" >&6
+-if test $ac_cv_func_mysql_connect = yes; then
++echo "$as_me:$LINENO: result: $ac_cv_func_mysql_real_connect" >&5
++echo "${ECHO_T}$ac_cv_func_mysql_real_connect" >&6
++if test $ac_cv_func_mysql_real_connect = yes; then
+ doauthmysql="yes"
+
+ fi
+@@ -24021,9 +24021,9 @@
+ else
+ saveLIBS="$LIBS"
+ LIBS="$MYSQL_LIBS $LIBS"
+- echo "$as_me:$LINENO: checking for mysql_connect" >&5
+-echo $ECHO_N "checking for mysql_connect... $ECHO_C" >&6
+-if test "${ac_cv_func_mysql_connect+set}" = set; then
++ echo "$as_me:$LINENO: checking for mysql_real_connect" >&5
++echo $ECHO_N "checking for mysql_real_connect... $ECHO_C" >&6
++if test "${ac_cv_func_mysql_real_connect+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ cat >conftest.$ac_ext <<_ACEOF
+@@ -24032,12 +24032,12 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-/* Define mysql_connect to an innocuous variant, in case <limits.h> declares mysql_connect.
++/* Define mysql_real_connect to an innocuous variant, in case <limits.h> declares mysql_real_connect.
+ For example, HP-UX 11i <limits.h> declares gettimeofday. */
+-#define mysql_connect innocuous_mysql_connect
++#define mysql_real_connect innocuous_mysql_real_connect
+
+ /* System header to define __stub macros and hopefully few prototypes,
+- which can conflict with char mysql_connect (); below.
++ which can conflict with char mysql_real_connect (); below.
+ Prefer <limits.h> to <assert.h> if __STDC__ is defined, since
+ <limits.h> exists even on freestanding compilers. */
+
+@@ -24047,7 +24047,7 @@
+ # include <assert.h>
+ #endif
+
+-#undef mysql_connect
++#undef mysql_real_connect
+
+ /* Override any gcc2 internal prototype to avoid an error. */
+ #ifdef __cplusplus
+@@ -24056,14 +24056,14 @@
+ #endif
+ /* We use char because int might match the return type of a gcc2
+ builtin and then its argument prototype would still apply. */
+-char mysql_connect ();
++char mysql_real_connect ();
+ /* The GNU C library defines this for functions which it implements
+ to always fail with ENOSYS. Some functions are actually named
+ something starting with __ and the normal name is an alias. */
+-#if defined (__stub_mysql_connect) || defined (__stub___mysql_connect)
++#if defined (__stub_mysql_real_connect) || defined (__stub___mysql_real_connect)
+ choke me
+ #else
+-char (*f) () = mysql_connect;
++char (*f) () = mysql_real_connect;
+ #endif
+ #ifdef __cplusplus
+ }
+@@ -24072,7 +24072,7 @@
+ int
+ main ()
+ {
+-return f != mysql_connect;
++return f != mysql_real_connect;
+ ;
+ return 0;
+ }
+@@ -24099,19 +24099,19 @@
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; }; then
+- ac_cv_func_mysql_connect=yes
++ ac_cv_func_mysql_real_connect=yes
+ else
+ echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+
+-ac_cv_func_mysql_connect=no
++ac_cv_func_mysql_real_connect=no
+ fi
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ fi
+-echo "$as_me:$LINENO: result: $ac_cv_func_mysql_connect" >&5
+-echo "${ECHO_T}$ac_cv_func_mysql_connect" >&6
+-if test $ac_cv_func_mysql_connect = yes; then
++echo "$as_me:$LINENO: result: $ac_cv_func_mysql_real_connect" >&5
++echo "${ECHO_T}$ac_cv_func_mysql_real_connect" >&6
++if test $ac_cv_func_mysql_real_connect = yes; then
+ LIBAUTHMYSQL="libauthmysql.la"
+ HAVE_AUTHMYSQL=1
+ else
diff --git a/mail/courier-authlib-vchkpw/files/patch-userdb::Makefile.in b/mail/courier-authlib-vchkpw/files/patch-userdb::Makefile.in
new file mode 100644
index 000000000000..c4c62ce68aa3
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/files/patch-userdb::Makefile.in
@@ -0,0 +1,13 @@
+--- userdb/Makefile.in.orig Sat Dec 18 18:33:08 2004
++++ userdb/Makefile.in Sat Dec 18 18:34:09 2004
+@@ -378,8 +378,8 @@
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+- echo " $(INSTALL_DATA) '$$file' '$(DESTDIR)$(man8dir)/$$inst'"; \
+- $(INSTALL_DATA) "$$file" "$(DESTDIR)$(man8dir)/$$inst"; \
++ echo " %%INSTALL_MAN%% '$$file' '$(DESTDIR)$(man8dir)/$$inst'"; \
++ %%INSTALL_MAN%% "$$file" "$(DESTDIR)$(man8dir)/$$inst"; \
+ done
+ uninstall-man8:
+ @$(NORMAL_UNINSTALL)
diff --git a/mail/courier-authlib-vchkpw/pkg-descr b/mail/courier-authlib-vchkpw/pkg-descr
new file mode 100644
index 000000000000..1b44b9f42019
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/pkg-descr
@@ -0,0 +1,7 @@
+The Courier Authentication Library is a generic authentication API that
+encapsulates the process of validating account passwords. In addition to
+reading the traditional account passwords from /etc/passwd, the account
+information can alternatively be obtained from an LDAP directory; a MySQL
+or a PostgreSQL database; or a GDBM or a DB file.
+
+WWW: http://www.courier-mta.org/authlib/
diff --git a/mail/courier-authlib-vchkpw/pkg-plist b/mail/courier-authlib-vchkpw/pkg-plist
new file mode 100644
index 000000000000..196430c46515
--- /dev/null
+++ b/mail/courier-authlib-vchkpw/pkg-plist
@@ -0,0 +1,58 @@
+bin/courierauthconfig
+etc/rc.d/courier-authdaemond.sh
+%%MYSQLFLAG%%etc/authlib/authmysqlrc.dist
+%%PGSQLFLAG%%etc/authlib/authpgsqlrc.dist
+%%LDAPFLAG%%etc/authlib/authldaprc.dist
+etc/authlib/authdaemonrc.dist
+include/courier_auth_config.h
+include/courierauth.h
+include/courierauthsasl.h
+include/courierauthsaslclient.h
+include/courierauthdebug.h
+lib/courier-authlib/libcourierauth.so.0
+lib/courier-authlib/libcourierauth.so
+lib/courier-authlib/libcourierauth.a
+lib/courier-authlib/libcourierauthsasl.so.0
+lib/courier-authlib/libcourierauthsasl.so
+lib/courier-authlib/libcourierauthsasl.a
+lib/courier-authlib/libcourierauthsaslclient.so.0
+lib/courier-authlib/libcourierauthsaslclient.so
+lib/courier-authlib/libcourierauthsaslclient.a
+lib/courier-authlib/libcourierauthcommon.so.0
+lib/courier-authlib/libcourierauthcommon.so
+lib/courier-authlib/libcourierauthcommon.a
+lib/courier-authlib/libauthcustom.so.0
+lib/courier-authlib/libauthcustom.so
+lib/courier-authlib/libauthuserdb.so.0
+lib/courier-authlib/libauthuserdb.so
+%%PAMFLAG%%lib/courier-authlib/libauthpam.so.0
+%%PAMFLAG%%lib/courier-authlib/libauthpam.so
+%%MYSQLFLAG%%lib/courier-authlib/libauthmysql.so.0
+%%MYSQLFLAG%%lib/courier-authlib/libauthmysql.so
+%%PGSQLFLAG%%lib/courier-authlib/libauthpgsql.so.0
+%%PGSQLFLAG%%lib/courier-authlib/libauthpgsql.so
+%%LDAPFLAG%%lib/courier-authlib/libauthldap.so.0
+%%LDAPFLAG%%lib/courier-authlib/libauthldap.so
+%%VPOPMAILFLAG%%lib/courier-authlib/libauthvchkpw.so.0
+%%VPOPMAILFLAG%%lib/courier-authlib/libauthvchkpw.so
+libexec/courier-authlib/authsystem.passwd
+libexec/courier-authlib/authdaemond
+libexec/courier-authlib/makedatprog
+sbin/authtest
+sbin/authdaemond
+sbin/authenumerate
+sbin/courierlogger
+sbin/makeuserdb
+sbin/userdb
+sbin/userdb-test-cram-md5
+sbin/userdbpw
+sbin/vchkpw2userdb
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec rmdir %D/var/authdaemon 2>/dev/null || true
+@unexec rmdir %D/var 2>/dev/null || true
+@dirrm etc/authlib
+@unexec rmdir %D/libexec/authlib 2>/dev/null || true