aboutsummaryrefslogtreecommitdiff
path: root/mail/courier/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-14 12:00:05 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-14 12:00:05 +0000
commit70c6cdd52613f0bde0bba44ff6eebd0fc3a56c9d (patch)
tree7d592214a8c89e0c09f58b4890ee59a355a6acdf /mail/courier/Makefile
parentde968da4a06e1feb6034458daf7904d6c815c575 (diff)
downloadports-70c6cdd52613f0bde0bba44ff6eebd0fc3a56c9d.tar.gz
ports-70c6cdd52613f0bde0bba44ff6eebd0fc3a56c9d.zip
Notes
Diffstat (limited to 'mail/courier/Makefile')
-rw-r--r--mail/courier/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/mail/courier/Makefile b/mail/courier/Makefile
index 06ae632ef426..47e7c9b817ca 100644
--- a/mail/courier/Makefile
+++ b/mail/courier/Makefile
@@ -7,6 +7,7 @@
PORTNAME= courier
PORTVERSION= 0.52.2
+PORTREVISION= 1
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= courier
@@ -59,16 +60,15 @@ CALENDIR= /var/spool/calendar
MIMETYPES= ${LOCALBASE}/etc/mime.types
WITH_TRANSPORT= local esmtp dsn
+USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
-USE_SUBMAKE= yes
-USE_PERL5= yes
+USE_FAM= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_OPENSSL= yes
+USE_PERL5= yes
USE_REINPLACE= yes
-USE_AUTOTOOLS= libtool:15
-USE_FAM= yes
-WANT_FAM_SYSTEM=fam
+USE_SUBMAKE= yes
.if defined(WITH_RCORDER)
USE_RCORDER= courier.sh
@@ -118,7 +118,7 @@ PLIST_SUB+= BINOWN="${BINOWN}" BINGRP="${BINGRP}" \
CACHEOWN="${CACHEOWN}" CACHEDIR="${CACHEDIR}" \
CALENDIR="${CALENDIR}" LOCALSTATEDIR="${LOCALSTATEDIR}"
SUB_LIST:= ${PLIST_SUB}
-SUB_FILES+= pkg-install pkg-message crontab
+SUB_FILES+= pkg-install pkg-message crontab sharedindexupdate
OPTIONS+=LDAP "LDAP-based mail aliasing support"
.if (exists(${LOCALBASE}/lib/libldap.a) && exists(${LOCALBASE}/lib/liblber.a)) || defined(WITH_LDAP)
@@ -272,6 +272,8 @@ pre-patch:
@${CP} ${TEMPLATES}/config.guess ${TEMPLATES}/config.sub ${WRKSRC}
post-patch:
+ @${REINPLACE_CMD} -e 's|^PROG=\./|PROG=exec ./|g' \
+ ${WRKSRC}/courier/module.*/courier.config
@${REINPLACE_CMD} -e 's|@datadir@|@sysconfdir@|g' \
${WRKSRC}/*/mk*cert.* \
${WRKSRC}/*/*/mk*cert.*
@@ -321,7 +323,8 @@ post-build:
post-install:
@${LN} -f ${SYSCONFDIR}/maildrop ${SYSCONFDIR}/maildropfilter
@${INSTALL_DATA} /dev/null ${SYSCONFDIR}/locallowercase
- @${INSTALL_DATA} ${WRKDIR}/crontab ${PREFIX}/etc/courier/
+ @${INSTALL_DATA} ${WRKDIR}/crontab ${SYSCONFDIR}/
+ @${INSTALL_SCRIPT} ${WRKDIR}/sharedindexupdate ${DATADIR}/
.for file in ${OWNER0}
@-${CHOWN} -Rh ${BINOWN}:${BINGRP} ${PREFIX}/${file}
.endfor