aboutsummaryrefslogtreecommitdiff
path: root/mail/couriergraph/Makefile
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2012-08-15 01:04:30 +0000
committerDoug Barton <dougb@FreeBSD.org>2012-08-15 01:04:30 +0000
commitf9b6bb72bd478b12951f554e3e87ee3a3ad40716 (patch)
treeb03e7cfe150ed1b6857b68211969a31d1b599c54 /mail/couriergraph/Makefile
parent0524788414f29b02c458de14f74d7870a4bd1e97 (diff)
downloadports-f9b6bb72bd478b12951f554e3e87ee3a3ad40716.tar.gz
ports-f9b6bb72bd478b12951f554e3e87ee3a3ad40716.zip
Fix problem introduced in r302141. The directory for the unpacked source
files is unversioned, so it conflicts with the name of the rc.d script in WRKDIR after SUB_FILES is applied.
Notes
Notes: svn path=/head/; revision=302555
Diffstat (limited to 'mail/couriergraph/Makefile')
-rw-r--r--mail/couriergraph/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/mail/couriergraph/Makefile b/mail/couriergraph/Makefile
index 2c3bcb98913e..1bb49bb9a11b 100644
--- a/mail/couriergraph/Makefile
+++ b/mail/couriergraph/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool \
NO_BUILD= yes
USE_PERL5= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
DATADIR?= /var/db/couriergraph
COURIERGRAPH_USER?= ${WWWOWN}
@@ -42,6 +41,9 @@ pre-everything::
@${ECHO_MSG} "COURIERGRAPH_GROUP=www Group to run couriergraph (Default: ${WWWGRP})"
@${ECHO_MSG}
+post-extract:
+ @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}," ${WRKSRC}/couriergraph.cgi
@${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR}," ${WRKSRC}/couriergraph.pl