aboutsummaryrefslogtreecommitdiff
path: root/mail/crm114/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-24 14:17:04 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-24 14:17:04 +0000
commit2203e2a3736eccbf2a3d66dff04804f156079209 (patch)
tree88ac47438c28ca08f91a16db598ac4e38d185a49 /mail/crm114/Makefile
parent2e5b029f12b4659db544431d74398eef850e4ec9 (diff)
downloadports-2203e2a3736eccbf2a3d66dff04804f156079209.tar.gz
ports-2203e2a3736eccbf2a3d66dff04804f156079209.zip
Add crm114 20040212,
CRM114 is a system to examine incoming e-mail, system log streams, data files or other data streams, and to sort, filter, or alter the incoming files or data streams according to the user's wildest desires. Criteria for categorization of data can be by satisfaction of regexes, by sparse binary polynomial matching with a Bayesian Chain Rule evaluator, or by other means. Accuracy of the SBPH/BCR classifier has been seen in excess of 99 per cent, for 1/4 megabyte of learning text. In other words, CRM114 learns, and it learns fast. WWW: http://crm114.sourceforge.net PR: ports/63304 Submitted by: Meno Abels <meno.abels@adviser.com>
Notes
Notes: svn path=/head/; revision=101979
Diffstat (limited to 'mail/crm114/Makefile')
-rw-r--r--mail/crm114/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
new file mode 100644
index 000000000000..c60e69706550
--- /dev/null
+++ b/mail/crm114/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: crm114
+# Date created: 23 February 2004
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crm114
+PORTVERSION= 20040212
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= crm114
+DISTNAME= ${PORTNAME}-${PORTVERSION}-BlameJetlag.src
+
+MAINTAINER= Meno.Abels@Adviser.com
+COMMENT= An Markov based SpamFilter
+
+LIB_DEPENDS= tre.4:${PORTSDIR}/textproc/libtre
+
+USE_GETTEXT= yes
+USE_ICONV= yes
+
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" prefix="${PREFIX}" \
+ LDFLAGS="${LDFLAGS}" LIBS="${LIBS}" \
+ INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib -liconv -lintl
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in CRM114_Mailfilter_HOWTO.txt FAQ.txt INTRO.txt QUICKREF.txt README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>