aboutsummaryrefslogtreecommitdiff
path: root/mail/dbmail
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2020-03-29 09:36:30 +0000
committerDima Panov <fluffy@FreeBSD.org>2020-03-29 09:36:30 +0000
commit9309a003e2fc7333bab3eb4612ce1c7a2dd5abdb (patch)
treec7802e70cd14d408719d8875ef85fd7feee24056 /mail/dbmail
parentda14de5540554099ccbbfe78f2cf234e31607f91 (diff)
downloadports-9309a003e2fc7333bab3eb4612ce1c7a2dd5abdb.tar.gz
ports-9309a003e2fc7333bab3eb4612ce1c7a2dd5abdb.zip
mail/dbmail: chase databases/libzdb update with new layout
Notes
Notes: svn path=/head/; revision=529785
Diffstat (limited to 'mail/dbmail')
-rw-r--r--mail/dbmail/Makefile2
-rw-r--r--mail/dbmail/files/patch-acinclude.m419
-rw-r--r--mail/dbmail/files/patch-src_dbmail.h.in16
3 files changed, 27 insertions, 10 deletions
diff --git a/mail/dbmail/Makefile b/mail/dbmail/Makefile
index 2800ba592d02..096073f36421 100644
--- a/mail/dbmail/Makefile
+++ b/mail/dbmail/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dbmail
PORTVERSION= 3.2.3
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= mail
MASTER_SITES= http://git.dbmail.eu/paul/dbmail/snapshot/ \
http://www.dbmail.org/download/3.2/
diff --git a/mail/dbmail/files/patch-acinclude.m4 b/mail/dbmail/files/patch-acinclude.m4
index a39a006698bc..92b369f9eee6 100644
--- a/mail/dbmail/files/patch-acinclude.m4
+++ b/mail/dbmail/files/patch-acinclude.m4
@@ -1,6 +1,6 @@
--- acinclude.m4.orig 2015-01-25 10:20:50 UTC
+++ acinclude.m4
-@@ -221,7 +221,7 @@ if ( test [ "x$lookforldap" != "xno" ] |
+@@ -221,7 +221,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lo
dnl See if we already have the paths we need in the environment.
dnl ...but only if --with-ldap was given without a specific path.
if ( test [ "x$lookforldap" = "xyes" ] || test [ "x$lookforauthldap" = "xyes" ] ); then
@@ -9,7 +9,7 @@
if test [ "x$LDAPLIB" != "xfailed" ]; then
break
fi
-@@ -233,7 +233,7 @@ if ( test [ "x$lookforldap" != "xno" ] |
+@@ -233,7 +233,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lo
SAVE_CFLAGS=$CFLAGS
dnl The headers might be in a funny place, so we need to use -Ipath
CFLAGS="$CFLAGS -L$TEST_PATH $LDAPINC"
@@ -18,7 +18,7 @@
CFLAGS=$SAVE_CFLAGS
if test [ "x$LDAPLIB" != "xfailed" ]; then
break 2
-@@ -247,7 +247,7 @@ if ( test [ "x$lookforldap" != "xno" ] |
+@@ -247,7 +247,7 @@ if ( test [ "x$lookforldap" != "xno" ] || test [ "x$lo
AC_MSG_ERROR([Could not find LDAP library.])
else
AC_DEFINE([AUTHLDAP], 1, [Define if LDAP will be used.])
@@ -27,7 +27,16 @@
AC_SUBST(LDAPLIB)
AC_SUBST(LDAPINC)
AUTHALIB="modules/.libs/libauth_ldap.a"
-@@ -339,7 +339,7 @@ AC_DEFUN([DM_CHECK_EVENT], [
+@@ -291,6 +291,8 @@ AC_DEFUN([DM_CHECK_ZDB], [dnl
+ [ZDBLIB="-lzdb"],
+ [ZDBLIB="failed"],
+ [[
++#include <stdbool.h>
++#include <zdb.h>
+ #include <URL.h>
+ #include <ResultSet.h>
+ #include <PreparedStatement.h>
+@@ -339,7 +341,7 @@ AC_DEFUN([DM_CHECK_EVENT], [
AC_DEFUN([DM_CHECK_SSL], [
AC_CHECK_HEADERS([openssl/ssl.h],
@@ -36,7 +45,7 @@
if test [ "x$SSLLIB" = "xfailed" ]; then
AC_MSG_ERROR([Could not find OPENSSL library.])
else
-@@ -539,15 +539,15 @@ AC_DEFUN([CMU_SOCKETS], [
+@@ -539,15 +541,15 @@ AC_DEFUN([CMU_SOCKETS], [
save_LIBS="$LIBS"
SOCKETLIB=""
AC_CHECK_FUNC(connect, :,
diff --git a/mail/dbmail/files/patch-src_dbmail.h.in b/mail/dbmail/files/patch-src_dbmail.h.in
index 875a8062f011..6bb73f4632a9 100644
--- a/mail/dbmail/files/patch-src_dbmail.h.in
+++ b/mail/dbmail/files/patch-src_dbmail.h.in
@@ -1,14 +1,22 @@
--- src/dbmail.h.in.orig 2015-01-25 10:20:50 UTC
+++ src/dbmail.h.in
-@@ -155,6 +155,11 @@
- #include <endian.h>
+@@ -97,6 +97,7 @@
+ #include <ldap.h>
#endif
++#include <zdb.h>
+ #include <URL.h>
+ #include <ResultSet.h>
+ #include <PreparedStatement.h>
+@@ -156,6 +157,11 @@
+ #ifdef HAVE_ENDIAN_H
+ #include <endian.h>
+ #endif
++
+#ifdef HAVE_CONFIG_H
+#include "config.h"
+#endif
+
-+
+
#define GETCONFIGVALUE(key, sect, var) \
config_get_value(key, sect, var); \
- if (strlen(var) > 0) \