aboutsummaryrefslogtreecommitdiff
path: root/mail/deforaos-mailer
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-12 04:53:28 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-12 04:53:28 +0000
commit6cc6c422fc3245af8fcd7bc3f1f98100253366f9 (patch)
tree1040f612de8905485a9a996a8bec282f3cad6172 /mail/deforaos-mailer
parent6827982b412ae5a4e6536fed711f9ca169bdb07c (diff)
downloadports-6cc6c422fc3245af8fcd7bc3f1f98100253366f9.tar.gz
ports-6cc6c422fc3245af8fcd7bc3f1f98100253366f9.zip
mail/deforaos-mailer: Support non-base SSL including no SSLv3 (LibreSSL)
Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=421905
Diffstat (limited to 'mail/deforaos-mailer')
-rw-r--r--mail/deforaos-mailer/Makefile3
-rw-r--r--mail/deforaos-mailer/files/patch-src_mailer.c14
-rw-r--r--mail/deforaos-mailer/files/patch-tests_Makefile11
3 files changed, 26 insertions, 2 deletions
diff --git a/mail/deforaos-mailer/Makefile b/mail/deforaos-mailer/Makefile
index b27c89f1dd50..b7df55453ab3 100644
--- a/mail/deforaos-mailer/Makefile
+++ b/mail/deforaos-mailer/Makefile
@@ -18,10 +18,9 @@ LIB_DEPENDS= libSystem.so:devel/deforaos-libsystem \
libDesktop.so:x11/deforaos-libdesktop
USE_GNOME= gtk20
-USES= desktop-file-utils pkgconfig
+USES= desktop-file-utils pkgconfig ssl
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-USE_OPENSSL= yes
MAKE_ARGS+= PREFIX=${PREFIX}
MAKE_ENV+= MANDIR=${STAGEDIR}${MANPREFIX}/man
diff --git a/mail/deforaos-mailer/files/patch-src_mailer.c b/mail/deforaos-mailer/files/patch-src_mailer.c
new file mode 100644
index 000000000000..e2d85d03d5c1
--- /dev/null
+++ b/mail/deforaos-mailer/files/patch-src_mailer.c
@@ -0,0 +1,14 @@
+--- src/mailer.c.orig 2016-02-20 14:36:22 UTC
++++ src/mailer.c
+@@ -373,7 +373,11 @@ Mailer * mailer_new(void)
+ /* ssl */
+ SSL_load_error_strings();
+ SSL_library_init();
++#ifndef OPENSSL_NO_SSL3
+ if((mailer->ssl_ctx = SSL_CTX_new(SSLv3_client_method())) == NULL
++#else
++ if((mailer->ssl_ctx = SSL_CTX_new(SSLv23_client_method())) == NULL
++#endif
+ || SSL_CTX_set_cipher_list(mailer->ssl_ctx,
+ SSL_DEFAULT_CIPHER_LIST) != 1
+ || SSL_CTX_load_verify_locations(mailer->ssl_ctx, NULL,
diff --git a/mail/deforaos-mailer/files/patch-tests_Makefile b/mail/deforaos-mailer/files/patch-tests_Makefile
new file mode 100644
index 000000000000..12ef3566a4fb
--- /dev/null
+++ b/mail/deforaos-mailer/files/patch-tests_Makefile
@@ -0,0 +1,11 @@
+--- tests/Makefile.orig 2016-09-12 04:36:41 UTC
++++ tests/Makefile
+@@ -27,7 +27,7 @@ $(OBJDIR)date$(EXEEXT): $(date_OBJS)
+ $(CC) -o $(OBJDIR)date$(EXEEXT) $(date_OBJS) $(date_LDFLAGS)
+
+ email_OBJS = $(OBJDIR)email.o
+-email_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS)
++email_CFLAGS = $(CPPFLAGSF) $(CPPFLAGS) $(CFLAGSF) $(CFLAGS) `pkg-config --cflags openssl`
+ email_LDFLAGS = $(LDFLAGSF) $(LDFLAGS) -L$(OBJDIR)../src -Wl,-rpath,$(OBJDIR)../src -lMailer
+
+ $(OBJDIR)email$(EXEEXT): $(email_OBJS)