aboutsummaryrefslogtreecommitdiff
path: root/mail/dma/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-09-16 13:44:26 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-09-16 13:44:26 +0000
commitfff82c442ccae8ea21caa3d81a6f741bfa270c2c (patch)
tree26a6350dcd2dada724c112e59091a73be1fa83fb /mail/dma/Makefile
parent01067bb348f507bb8cab127bfbf19ef7e75c5380 (diff)
downloadports-fff82c442ccae8ea21caa3d81a6f741bfa270c2c.tar.gz
ports-fff82c442ccae8ea21caa3d81a6f741bfa270c2c.zip
Notes
Diffstat (limited to 'mail/dma/Makefile')
-rw-r--r--mail/dma/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 2b8421db770f..3e771f810484 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -1,38 +1,28 @@
-# New ports collection makefile for: dma
-# Date created: 2009-01-17
-# Whom: Daniel Roethlisberger <daniel@roe.ch>
-#
+# Created by: Daniel Roethlisberger <daniel@roe.ch>
# $FreeBSD$
#
# Based on a tarball from https://github.com/corecode/dma/tarball/<version>
# rather than from Dragonfly.
-#
PORTNAME= dma
-PORTVERSION= v0.7
-PORTREVISION= 1
+PORTVERSION= v0.9
PORTEPOCH= 1
CATEGORIES= mail ipv6
-#MASTER_SITES= https://github.com/ # 302 temp move
-MASTER_SITES= https://nodeload.github.com/${GITHUB_USER}/${PORTNAME}/tarball/
-DISTNAME= ${PORTVERSION}
EXTRACT_SUFX=
-DIST_SUBDIR= ${PORTNAME}
MAINTAINER= bzeeb+freebsdports@zabbadoz.net
COMMENT= DragonFly Mail Agent, a small MTA for local/outbound mail
LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
-
-WRKSRC= ${WRKDIR}/${GITHUB_USER}-${PORTNAME}-${GITHUB_HASH}
USE_OPENSSL= yes
MAN8= dma.8
-GITHUB_HASH= db9a42b
-GITHUB_USER= corecode
+USE_GITHUB= yes
+GH_COMMIT= 2bb8bcb
+GH_ACCOUNT= corecode
+GH_TAGNAME= ${GH_COMMIT}
CFLAGS+= -I${OPENSSLINC} \
-DCONF_PATH='\"${PREFIX}/etc/dma\"' \
@@ -48,6 +38,10 @@ CONFFILES+= dma.conf auth.conf
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 900000
+IGNORE= Does not build in 8.x
+.endif
+
pre-patch:
@${MKDIR} ${WRKSRC}/dma ${WRKSRC}/dma-mbox-create
@${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.dist
@@ -57,6 +51,9 @@ post-patch:
${WRKSRC}/dma.8
@${REINPLACE_CMD} -e 's, /etc/dma, ${PREFIX}/etc/dma,g' \
${WRKSRC}/dma.conf
+.if ${OSVERSION} < 1000013
+ @${REINPLACE_CMD} -e 's,^YFLAGS.*,,' ${WRKSRC}/dma/Makefile
+.endif
do-install:
${INSTALL} -o root -g mail -m 2555 ${WRKSRC}/dma/dma ${PREFIX}/libexec