aboutsummaryrefslogtreecommitdiff
path: root/mail/dma
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2021-02-11 14:08:44 +0000
committerRenato Botelho <garga@FreeBSD.org>2021-02-11 14:08:44 +0000
commit07fa21db682be2afe108f3580d9467cde3b35097 (patch)
treec2f2d99179c5bd47d68890f52942ce7fcabbeb78 /mail/dma
parentb5050e7e6cd39a91d7988a599f406c1a9c8a2330 (diff)
downloadports-07fa21db682be2afe108f3580d9467cde3b35097.tar.gz
ports-07fa21db682be2afe108f3580d9467cde3b35097.zip
mail/dma: Fix compiler warning
- Make verify_server_fingerprint() static and fix compiler warning - While here, re-generate other patches with `make makepatch` Sponsored by: Rubicon Communications, LLC ("Netgate")
Notes
Notes: svn path=/head/; revision=564953
Diffstat (limited to 'mail/dma')
-rw-r--r--mail/dma/Makefile2
-rw-r--r--mail/dma/files/patch-crypto.c11
-rw-r--r--mail/dma/files/patch-dma.c8
-rw-r--r--mail/dma/files/patch-mail.c4
-rw-r--r--mail/dma/files/patch-spool.c4
5 files changed, 20 insertions, 9 deletions
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 7b9c303719c1..c9e88eeca655 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -4,7 +4,7 @@
PORTNAME= dma
PORTVERSION= 0.13
DISTVERSIONPREFIX= v
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= mail
diff --git a/mail/dma/files/patch-crypto.c b/mail/dma/files/patch-crypto.c
new file mode 100644
index 000000000000..2cf5b29c17ad
--- /dev/null
+++ b/mail/dma/files/patch-crypto.c
@@ -0,0 +1,11 @@
+--- crypto.c.orig 2021-02-11 13:53:38 UTC
++++ crypto.c
+@@ -78,7 +78,7 @@ init_cert_file(SSL_CTX *ctx, const char *path)
+ return (0);
+ }
+
+-int
++static int
+ verify_server_fingerprint(const X509 *cert)
+ {
+ unsigned char fingerprint[EVP_MAX_MD_SIZE] = {0};
diff --git a/mail/dma/files/patch-dma.c b/mail/dma/files/patch-dma.c
index aac9b3ae6426..0d857513c495 100644
--- a/mail/dma/files/patch-dma.c
+++ b/mail/dma/files/patch-dma.c
@@ -1,6 +1,6 @@
---- dma.c.orig 2016-02-07 12:41:49 UTC
+--- dma.c.orig 2020-02-05 10:59:09 UTC
+++ dma.c
-@@ -340,7 +340,7 @@ retry:
+@@ -341,7 +341,7 @@ retry:
exit(EX_SOFTWARE);
}
if (gettimeofday(&now, NULL) == 0 &&
@@ -9,7 +9,7 @@
snprintf(errmsg, sizeof(errmsg),
"Could not deliver for the last %d seconds. Giving up.",
MAX_TIMEOUT);
-@@ -564,7 +564,7 @@ main(int argc, char **argv)
+@@ -565,7 +565,7 @@ main(int argc, char **argv)
skipopts:
if (logident_base == NULL)
logident_base = "dma";
@@ -18,7 +18,7 @@
act.sa_handler = sighup_handler;
act.sa_flags = 0;
-@@ -596,7 +596,7 @@ skipopts:
+@@ -597,7 +597,7 @@ skipopts:
errlog(EX_SOFTWARE, "could not parse aliases file `%s'", config.aliases);
if ((sender = set_from(&queue, sender)) == NULL)
diff --git a/mail/dma/files/patch-mail.c b/mail/dma/files/patch-mail.c
index 1507e1666cce..53f7037b99bc 100644
--- a/mail/dma/files/patch-mail.c
+++ b/mail/dma/files/patch-mail.c
@@ -1,6 +1,6 @@
---- mail.c.orig 2016-02-07 12:41:49 UTC
+--- mail.c.orig 2020-02-05 10:59:09 UTC
+++ mail.c
-@@ -333,7 +333,7 @@ newaddr:
+@@ -335,7 +335,7 @@ newaddr:
ps->pos = 0;
addr = strdup(ps->addr);
if (addr == NULL)
diff --git a/mail/dma/files/patch-spool.c b/mail/dma/files/patch-spool.c
index e73c3865af9e..c310e36ac393 100644
--- a/mail/dma/files/patch-spool.c
+++ b/mail/dma/files/patch-spool.c
@@ -1,6 +1,6 @@
---- spool.c.orig 2016-02-07 12:41:49 UTC
+--- spool.c.orig 2020-02-05 10:59:09 UTC
+++ spool.c
-@@ -416,7 +416,7 @@ flushqueue_since(unsigned int period)
+@@ -419,7 +419,7 @@ flushqueue_since(unsigned int period)
return (0);
/* Did the flush file get touched within the last period seconds? */