aboutsummaryrefslogtreecommitdiff
path: root/mail/dma
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-01-02 14:01:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-01-02 14:01:24 +0000
commita63851970c5fd08e420f1cbaa8015f7a64a52754 (patch)
tree4d885fd842ac846cdeba2bb393b08bff10eb8bab /mail/dma
parentcf0ad690544e63bab560995da1f3fed73103f280 (diff)
downloadports-a63851970c5fd08e420f1cbaa8015f7a64a52754.tar.gz
ports-a63851970c5fd08e420f1cbaa8015f7a64a52754.zip
- Fix alias file scanning
- submitter is now maintainer Submitted by: bz (by mail)
Notes
Notes: svn path=/head/; revision=267278
Diffstat (limited to 'mail/dma')
-rw-r--r--mail/dma/Makefile4
-rw-r--r--mail/dma/files/patch-aliases_scan.l13
2 files changed, 14 insertions, 3 deletions
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 2cbfb9b96fe2..43b6a5bd4be8 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -11,11 +11,11 @@
PORTNAME= dma
# commit f54b5114efc65d0e31c7b612bd59cc1b7c8cd8dc
PORTVERSION= 20101004
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= LOCAL/bz
-MAINTAINER= bapt@FreeBSD.org
+MAINTAINER= bz@FreeBSD.org
COMMENT= DragonFly Mail Agent, a small MTA for local/outbound mail
USE_BZIP2= yes
diff --git a/mail/dma/files/patch-aliases_scan.l b/mail/dma/files/patch-aliases_scan.l
index d6913f30b0ac..840e92cd41bc 100644
--- a/mail/dma/files/patch-aliases_scan.l
+++ b/mail/dma/files/patch-aliases_scan.l
@@ -1,5 +1,5 @@
--- ./aliases_scan.l.orig 2010-10-04 21:03:33.000000000 +0200
-+++ ./aliases_scan.l 2010-10-18 13:25:47.330077534 +0200
++++ ./aliases_scan.l 2010-12-26 22:03:33.000000000 +0000
@@ -3,8 +3,6 @@
#include <string.h>
#include "aliases_parse.h"
@@ -9,3 +9,14 @@
int yylex(void);
%}
+@@ -13,9 +11,9 @@ int yylex(void);
+
+ %%
+
++^([[:blank:]]*(#.*)?\n)+ ;/* ignore empty lines */
+ [^:,#[:space:][:cntrl:]]+ {yylval.ident = strdup(yytext); return T_IDENT;}
+ [:,\n] return yytext[0];
+-^([[:blank:]]*(#.*)?\n)+ ;/* ignore empty lines */
+ (\n?[[:blank:]]+|#.*)+ ;/* ignore whitespace and continuation */
+ \\\n ;/* ignore continuation. not allowed in comments */
+ . return T_ERROR;