aboutsummaryrefslogtreecommitdiff
path: root/mail/dma
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-04-14 15:49:42 +0000
committerChris Rees <crees@FreeBSD.org>2012-04-14 15:49:42 +0000
commitd44b9bfa19c71e8aa241b67d932a8387262ac53d (patch)
tree39223d73fc96aced4d00845e3ea4a687192fbbc7 /mail/dma
parent6f7e3aa9d228307810182139edd65aef7af05421 (diff)
downloadports-d44b9bfa19c71e8aa241b67d932a8387262ac53d.tar.gz
ports-d44b9bfa19c71e8aa241b67d932a8387262ac53d.zip
Fix a couple of issues:
- Make compile with old and new openssl - Do not try to call git to get the version number - Fix compile on FreeBSD 8.1 - Change maintainer email address PR: ports/165775 Submitted by: bz
Notes
Notes: svn path=/head/; revision=294811
Diffstat (limited to 'mail/dma')
-rw-r--r--mail/dma/Makefile3
-rw-r--r--mail/dma/files/patch-alias_scan.l15
-rw-r--r--mail/dma/files/patch-crypto.c11
-rw-r--r--mail/dma/files/patch-get-version.sh12
4 files changed, 36 insertions, 5 deletions
diff --git a/mail/dma/Makefile b/mail/dma/Makefile
index 343c7605a99e..2b8421db770f 100644
--- a/mail/dma/Makefile
+++ b/mail/dma/Makefile
@@ -10,6 +10,7 @@
PORTNAME= dma
PORTVERSION= v0.7
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= mail ipv6
#MASTER_SITES= https://github.com/ # 302 temp move
@@ -18,7 +19,7 @@ DISTNAME= ${PORTVERSION}
EXTRACT_SUFX=
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= bz@FreeBSD.org
+MAINTAINER= bzeeb+freebsdports@zabbadoz.net
COMMENT= DragonFly Mail Agent, a small MTA for local/outbound mail
LICENSE= BSD
diff --git a/mail/dma/files/patch-alias_scan.l b/mail/dma/files/patch-alias_scan.l
new file mode 100644
index 000000000000..748bd034e771
--- /dev/null
+++ b/mail/dma/files/patch-alias_scan.l
@@ -0,0 +1,15 @@
+!
+! Work around bug in FreeBSD 8.1 due to missing fix for:
+! bin/139319: [patch] flex(1): fix prototypes, esp. when YY_NO_INPUT is defined
+!
+--- aliases_scan.l.orig 2012-01-03 13:54:05.000000000 +0000
++++ aliases_scan.l 2012-04-13 18:23:41.000000000 +0000
+@@ -3,8 +3,6 @@
+ #include <string.h>
+ #include "aliases_parse.h"
+
+-#define YY_NO_INPUT
+-
+ int yylex(void);
+ %}
+
diff --git a/mail/dma/files/patch-crypto.c b/mail/dma/files/patch-crypto.c
index b4fe877a54cd..2d0e229f5547 100644
--- a/mail/dma/files/patch-crypto.c
+++ b/mail/dma/files/patch-crypto.c
@@ -1,11 +1,14 @@
---- ./crypto.c.orig 2012-01-03 13:54:05.000000000 +0000
-+++ ./crypto.c 2012-01-24 22:57:41.000000000 +0000
-@@ -80,7 +80,7 @@
+--- crypto.c.orig 2012-01-03 13:54:05.000000000 +0000
++++ crypto.c 2012-03-06 23:50:42.000000000 +0000
+@@ -80,7 +80,11 @@ int
smtp_init_crypto(int fd, int feature)
{
SSL_CTX *ctx = NULL;
-- const SSL_METHOD *meth = NULL;
++#if (OPENSSL_VERSION_NUMBER >= 0x00909000L)
+ const SSL_METHOD *meth = NULL;
++#else
+ SSL_METHOD *meth = NULL;
++#endif
X509 *cert;
int error;
diff --git a/mail/dma/files/patch-get-version.sh b/mail/dma/files/patch-get-version.sh
new file mode 100644
index 000000000000..858b013be099
--- /dev/null
+++ b/mail/dma/files/patch-get-version.sh
@@ -0,0 +1,12 @@
+--- get-version.sh.orig 2012-03-08 17:37:54.000000000 +0000
++++ get-version.sh 2012-03-08 17:38:41.000000000 +0000
+@@ -1,9 +1,7 @@
+ #!/bin/sh
+
+-gitver=$(git describe 2>/dev/null | tr - .)
+ filever=$(cat VERSION)
+
+-version=${gitver}
+ : ${version:=$filever}
+
+ echo "$version"