aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot-fts-elastic
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2022-04-18 00:23:32 +0000
committerLarry Rosenman <ler@FreeBSD.org>2022-04-18 00:23:32 +0000
commit4b1db7ecfdeb2b61fbdb30b3b738aa85659769ed (patch)
treefdc45c889a105452a0edcca80de0366cf6aff5d6 /mail/dovecot-fts-elastic
parent7878eb5e4506802e15728a11eea87594a61a4670 (diff)
downloadports-4b1db7ecfdeb2b61fbdb30b3b738aa85659769ed.tar.gz
ports-4b1db7ecfdeb2b61fbdb30b3b738aa85659769ed.zip
Diffstat (limited to 'mail/dovecot-fts-elastic')
-rw-r--r--mail/dovecot-fts-elastic/Makefile33
-rw-r--r--mail/dovecot-fts-elastic/distinfo3
-rw-r--r--mail/dovecot-fts-elastic/pkg-descr10
3 files changed, 46 insertions, 0 deletions
diff --git a/mail/dovecot-fts-elastic/Makefile b/mail/dovecot-fts-elastic/Makefile
new file mode 100644
index 000000000000..f87f7f07bbef
--- /dev/null
+++ b/mail/dovecot-fts-elastic/Makefile
@@ -0,0 +1,33 @@
+PORTNAME= fts-elastic
+PORTVERSION= 1.1.0
+PORTREVISION= 1
+CATEGORIES= mail
+PKGNAMEPREFIX= dovecot-
+
+MAINTAINER= bgupta@kde.org
+COMMENT= Dovecot FTS plugin for using ElasticSearch 6 or 7
+
+LICENSE= MIT
+
+BUILD_DEPENDS= dovecot>=2.3.7:mail/dovecot
+LIB_DEPENDS= libjson-c.so:devel/json-c
+RUN_DEPENDS= dovecot>=2.3.7:mail/dovecot
+
+USES= autoreconf libtool
+
+USE_GITHUB= yes
+GH_ACCOUNT= filiphanes
+GH_TAGNAME= ${PORTVERSION}
+
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+LDFLAGS+= -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include
+
+PLIST_FILES= lib/dovecot/lib21_fts_elastic_plugin.a \
+ lib/dovecot/lib21_fts_elastic_plugin.so
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/lib21_fts_elastic_plugin.so
+
+.include <bsd.port.mk>
diff --git a/mail/dovecot-fts-elastic/distinfo b/mail/dovecot-fts-elastic/distinfo
new file mode 100644
index 000000000000..9e84ccbdde2b
--- /dev/null
+++ b/mail/dovecot-fts-elastic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1650235615
+SHA256 (filiphanes-fts-elastic-1.1.0_GH0.tar.gz) = 50aac69510cb504b6c7af7180a1d21fed3aadd47df30e5cd8ad50dfae5c36452
+SIZE (filiphanes-fts-elastic-1.1.0_GH0.tar.gz) = 32351
diff --git a/mail/dovecot-fts-elastic/pkg-descr b/mail/dovecot-fts-elastic/pkg-descr
new file mode 100644
index 000000000000..9a91121d6071
--- /dev/null
+++ b/mail/dovecot-fts-elastic/pkg-descr
@@ -0,0 +1,10 @@
+This projects provides a Dovecot full-text search indexing plugin that uses
+ElasticSearch 6 or 7 as a backend.
+
+Dovecot communicates with ElasticSearch using direct HTTP/JSON queries, and
+does not require ElasticSearch client libraries. It supports automatic indexing
+and searching of e-mail. For mailboxes with more than 10000 messages, it uses
+the Elastic Scroll API.
+
+WWW: https://github.com/filiphanes/fts-elastic
+