aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot-fts-xapian
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-09-12 14:32:12 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-09-12 14:32:12 +0000
commitb75f6793e4831ad5871b0e556c01f722ae665405 (patch)
treea8a18f965bcaa8b416dd203a2e7e261826ba3644 /mail/dovecot-fts-xapian
parent02f1b3250b5794eaa235841757efba587e7dc3b1 (diff)
downloadports-b75f6793e4831ad5871b0e556c01f722ae665405.tar.gz
ports-b75f6793e4831ad5871b0e556c01f722ae665405.zip
Notes
Diffstat (limited to 'mail/dovecot-fts-xapian')
-rw-r--r--mail/dovecot-fts-xapian/Makefile34
-rw-r--r--mail/dovecot-fts-xapian/distinfo3
-rw-r--r--mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp13
-rw-r--r--mail/dovecot-fts-xapian/pkg-descr8
4 files changed, 58 insertions, 0 deletions
diff --git a/mail/dovecot-fts-xapian/Makefile b/mail/dovecot-fts-xapian/Makefile
new file mode 100644
index 000000000000..2fb3f1d03abb
--- /dev/null
+++ b/mail/dovecot-fts-xapian/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= fts-xapian
+PORTVERSION= 1.2.1
+CATEGORIES= mail
+PKGNAMEPREFIX= dovecot-
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Dovecot FTS plugin based on Xapian
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= libxapian.so:databases/xapian-core \
+ libicuuc.so:devel/icu
+BUILD_DEPENDS= dovecot>=2.3.7:mail/dovecot
+RUN_DEPENDS= dovecot>=2.3.7:mail/dovecot
+
+USES= autoreconf libtool pkgconfig
+
+USE_LDCONFIG= yes
+
+USE_GITHUB=yes
+GH_ACCOUNT= grosjo
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+PLIST_FILES= lib/dovecot/lib21_fts_xapian_plugin.a \
+ lib/dovecot/lib21_fts_xapian_plugin.so
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/dovecot/lib21_fts_xapian_plugin.so
+
+.include <bsd.port.mk>
diff --git a/mail/dovecot-fts-xapian/distinfo b/mail/dovecot-fts-xapian/distinfo
new file mode 100644
index 000000000000..8aed9f022c74
--- /dev/null
+++ b/mail/dovecot-fts-xapian/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568284001
+SHA256 (grosjo-fts-xapian-1.2.1-fts-xapian-1.2.1_GH0.tar.gz) = 9c8dbaa3ddf5f489356a3ec40af012c02aaa6af7ae513ade5b208d3d19771277
+SIZE (grosjo-fts-xapian-1.2.1-fts-xapian-1.2.1_GH0.tar.gz) = 27267
diff --git a/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp b/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp
new file mode 100644
index 000000000000..de42b3940487
--- /dev/null
+++ b/mail/dovecot-fts-xapian/files/patch-src_fts-backend-xapian.cpp
@@ -0,0 +1,13 @@
+--- src/fts-backend-xapian.cpp.orig 2019-08-18 16:36:45 UTC
++++ src/fts-backend-xapian.cpp
+@@ -115,9 +115,7 @@ static int fts_backend_xapian_init(struct fts_backend
+ }
+
+ const char * path = mailbox_list_get_root_forced(_backend->ns->list, MAILBOX_LIST_PATH_TYPE_INDEX);
+- long l=strlen(path)+strlen(XAPIAN_FILE_PREFIX)+2;
+- backend->path = (char *)i_malloc(l*sizeof(char));
+- snprintf(backend->path,l,"%s/%s",path,XAPIAN_FILE_PREFIX);
++ backend->path = i_strconcat(path, "/" XAPIAN_FILE_PREFIX, NULL);
+
+ struct stat sb;
+ if(!( (stat(backend->path, &sb)==0) && S_ISDIR(sb.st_mode)))
diff --git a/mail/dovecot-fts-xapian/pkg-descr b/mail/dovecot-fts-xapian/pkg-descr
new file mode 100644
index 000000000000..c10d90f14bd5
--- /dev/null
+++ b/mail/dovecot-fts-xapian/pkg-descr
@@ -0,0 +1,8 @@
+This project intends to provide a straightforward and simple way to configure
+FTS plugin for Dovecot, leveraging the efforts by the Xapian.org team.
+
+This effort came after Dovecot team decided to deprecate "fts_squat" included in
+the dovecot core, and due to the complexity of the Solr plugin capabilitles,
+un-needed for most users.
+
+WWW: https://github.com/grosjo/fts-xapian