aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2018-12-04 11:33:06 +0000
committerLarry Rosenman <ler@FreeBSD.org>2018-12-04 11:33:06 +0000
commit15513b19667a5c3f5aab37701ac6ab7b966a424b (patch)
treedc18dc015b00358c0260b3d40107459aad9877a9 /mail/dovecot
parent939335500eed126b53374d52a91d4b1d86d79615 (diff)
downloadports-15513b19667a5c3f5aab37701ac6ab7b966a424b.tar.gz
ports-15513b19667a5c3f5aab37701ac6ab7b966a424b.zip
mail/dovecot: add option to support libsodium
- libsodium option to support security/libsodium based crypts - pet portlint - fix LUA option pkg-plist issues
Notes
Notes: svn path=/head/; revision=486595
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile12
-rw-r--r--mail/dovecot/pkg-plist6
2 files changed, 12 insertions, 6 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 5dc59c8f53f1..b0edd1979ac7 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -8,7 +8,7 @@
PORTNAME= dovecot
PORTVERSION= 2.3.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.3/
@@ -17,8 +17,6 @@ COMMENT= Secure, fast and powerful IMAP and POP3 server
LICENSE= LGPL21 MIT
LICENSE_COMB= dual
-LICENSE_FILE_LGPL21= ${WRKSRC}/COPYING.LGPL
-LICENSE_FILE_MIT= ${WRKSRC}/COPYING.MIT
USES= cpe iconv libtool pkgconfig ssl
USE_RC_SUBR= dovecot
@@ -27,7 +25,6 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var \
--with-statedir=/var/db/dovecot \
--without-shadow \
- --without-sodium \
--with-ssl=openssl \
--with-docs
@@ -39,7 +36,7 @@ GROUPS= ${USERS}
CONFLICTS_INSTALL= dovecot22
-OPTIONS_DEFINE= LIBWRAP LUA LZ4 VPOPMAIL DOCS EXAMPLES
+OPTIONS_DEFINE= LIBSODIUM LIBWRAP LUA LZ4 VPOPMAIL DOCS EXAMPLES
OPTIONS_DEFAULT=GSSAPI_NONE LIBWRAP
OPTIONS_SUB= yes
@@ -68,6 +65,10 @@ GSSAPI_HEIMDAL_DESC= Use Heimdal GSSAPI from security/heimdal
GSSAPI_MIT_DESC= Use MIT GSSAPI from security/krb5
# General options
+LIBSODIUM_DESC= support libsodium based crypts (ARGON2I/ARGON2ID)
+LIBSODIUM_LIB_DEPENDS= libsodium.so:security/libsodium
+LIBSODIUM_CONFIGURE_WITH= sodium
+
LIBWRAP_CONFIGURE_WITH= libwrap
LUA_CONFIGURE_WITH= lua
@@ -98,7 +99,6 @@ SQLITE_CONFIGURE_WITH= sqlite
# FTS
ICU_CONFIGURE_WITH= icu
ICU_LIB_DEPENDS= libicui18n.so:devel/icu
-ICU_USES= pkgconfig
LUCENE_CONFIGURE_WITH= lucene
LUCENE_LIB_DEPENDS= libclucene-core.so:textproc/clucene
diff --git a/mail/dovecot/pkg-plist b/mail/dovecot/pkg-plist
index 7dec438c4836..f36f65c28673 100644
--- a/mail/dovecot/pkg-plist
+++ b/mail/dovecot/pkg-plist
@@ -836,6 +836,12 @@ share/aclocal/dovecot.m4
%%LIBWRAP%%libexec/dovecot/tcpwrap
%%LUA%%include/dovecot/dlua-script-private.h
%%LUA%%include/dovecot/dlua-script.h
+%%LUA%%include/dovecot/mail-lua-plugin.h
+%%LUA%%include/dovecot/mail-storage-lua.h
+%%LUA%%%%LUA_LIBDIR%%/dovecot/%%LUA_LIBDIR%%01_mail_lua_plugin.a
+%%LUA%%%%LUA_LIBDIR%%/dovecot/%%LUA_LIBDIR%%01_mail_lua_plugin.so
+%%LUA%%%%LUA_LIBDIR%%/dovecot/%%LUA_LIBDIR%%22_push_notification_lua_plugin.a
+%%LUA%%%%LUA_LIBDIR%%/dovecot/%%LUA_LIBDIR%%22_push_notification_lua_plugin.so
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.a
%%LUCENE%%lib/dovecot/doveadm/lib20_doveadm_fts_lucene_plugin.so
%%LUCENE%%lib/dovecot/lib21_fts_lucene_plugin.a