aboutsummaryrefslogtreecommitdiff
path: root/mail/dovecot
diff options
context:
space:
mode:
authorLarry Rosenman <ler@FreeBSD.org>2019-04-30 21:33:30 +0000
committerLarry Rosenman <ler@FreeBSD.org>2019-04-30 21:33:30 +0000
commit15dd24337993acaad7fb1855f6af3958b253a3a4 (patch)
tree5826901b8015c084390db1466b9bbae6bda0c9b3 /mail/dovecot
parent773f47db31e2bce41406f36a80382ee790fde3ce (diff)
downloadports-15dd24337993acaad7fb1855f6af3958b253a3a4.tar.gz
ports-15dd24337993acaad7fb1855f6af3958b253a3a4.zip
mail/dovecot, mail/dovecot-pigeonhole: upgrade to 2.3.6, 0.5.6 respectively.
Dovecot changelog: * CVE-2019-11494: Submission-login crashed with signal 11 due to null pointer access when authentication was aborted by disconnecting. * CVE-2019-11499: Submission-login crashed when authentication was started over TLS secured channel and invalid authentication message was sent. * auth: Support password grant with passdb oauth2. + Use system default CAs for outbound TLS connections. + Simplify array handling with new helper macros. + fts_solr: Enable configuring batch_size and soft_commit features. - lmtp/submission: Fixed various bugs in XCLIENT handling, including a hang when XCLIENT commands were sent infinitely to the remote server. - lmtp/submission: Forwarded multi-line replies were erroneously sent as two replies to the client. - lib-smtp: client: Message was not guaranteed to contain CRLF consistently when CHUNKING was used. - fts_solr: Plugin was no longer compatible with Solr 7. - Make it possible to disable certificate checking without setting ssl_client_ca_* settings. - pop3c: SSL support was broken. - mysql: Closing connection twice lead to crash on some systems. - auth: Multiple oauth2 passdbs crashed auth process on deinit. - HTTP client connection errors infrequently triggered a segmentation fault when the connection was idle and not used for a particular client instance. Pigeonhole changelog: + sieve: Redirect loop prevention is sometimes ineffective. Improve existing loop detection by also recognizing the X-Sieve-Redirected-From header in incoming messages and dropping redirect actions when it points to the sending account. This header is already added by the redirect action, so this improvement only adds an additional use of this header. - sieve: Prevent execution of implicit keep upon temporary failure occurring at runtime. MFH: 2019Q2 Security: CVE-2019-11494 Security: CVE-2019-11499
Notes
Notes: svn path=/head/; revision=500569
Diffstat (limited to 'mail/dovecot')
-rw-r--r--mail/dovecot/Makefile2
-rw-r--r--mail/dovecot/distinfo6
-rw-r--r--mail/dovecot/files/patch-src_lib-master_test-event-stats.c4
-rw-r--r--mail/dovecot/files/patch-src_lib-sql_driver-mysql.c24
-rw-r--r--mail/dovecot/files/patch-src_plugins_fts-solr_solr-connection.c8
5 files changed, 10 insertions, 34 deletions
diff --git a/mail/dovecot/Makefile b/mail/dovecot/Makefile
index 5d60af5e64d0..ca92d04f89ab 100644
--- a/mail/dovecot/Makefile
+++ b/mail/dovecot/Makefile
@@ -7,7 +7,7 @@
######################################################################
PORTNAME= dovecot
-PORTVERSION= 2.3.5.2
+PORTVERSION= 2.3.6
CATEGORIES= mail ipv6
MASTER_SITES= https://www.dovecot.org/releases/2.3/
diff --git a/mail/dovecot/distinfo b/mail/dovecot/distinfo
index 677ab7ad45ef..e58ddf214227 100644
--- a/mail/dovecot/distinfo
+++ b/mail/dovecot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555598613
-SHA256 (dovecot-2.3.5.2.tar.gz) = ba14e41aefd81a868a35b83bcb54194116106424d37690519b50ea83c0f31bf2
-SIZE (dovecot-2.3.5.2.tar.gz) = 6953228
+TIMESTAMP = 1556658186
+SHA256 (dovecot-2.3.6.tar.gz) = ed1d8dc1beeae9c6c73deac73a62ef19fe9262fbffd86604a3f690452f5536c7
+SIZE (dovecot-2.3.6.tar.gz) = 6980135
diff --git a/mail/dovecot/files/patch-src_lib-master_test-event-stats.c b/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
index 9234677aed68..56d866a6a4ca 100644
--- a/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
+++ b/mail/dovecot/files/patch-src_lib-master_test-event-stats.c
@@ -1,4 +1,4 @@
---- src/lib-master/test-event-stats.c.orig 2018-11-23 11:06:49 UTC
+--- src/lib-master/test-event-stats.c.orig 2019-04-30 12:25:06 UTC
+++ src/lib-master/test-event-stats.c
@@ -12,6 +12,7 @@
#include "stats-client.h"
@@ -6,5 +6,5 @@
#include <fcntl.h>
+#include <signal.h>
#include <unistd.h>
+ #include <signal.h>
#include <sys/socket.h>
- #include <sys/un.h>
diff --git a/mail/dovecot/files/patch-src_lib-sql_driver-mysql.c b/mail/dovecot/files/patch-src_lib-sql_driver-mysql.c
deleted file mode 100644
index b9084bd86ea5..000000000000
--- a/mail/dovecot/files/patch-src_lib-sql_driver-mysql.c
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/lib-sql/driver-mysql.c.orig 2018-11-23 11:06:45 UTC
-+++ src/lib-sql/driver-mysql.c
-@@ -173,7 +173,9 @@ static int driver_mysql_connect(struct sql_db *_db)
- static void driver_mysql_disconnect(struct sql_db *_db)
- {
- struct mysql_db *db = (struct mysql_db *)_db;
-- mysql_close(db->mysql);
-+ if (db->mysql != NULL)
-+ mysql_close(db->mysql);
-+ db->mysql = NULL;
- }
-
- static int driver_mysql_parse_connect_string(struct mysql_db *db,
-@@ -311,7 +313,9 @@ static void driver_mysql_deinit_v(struct sql_db *_db)
- _db->no_reconnect = TRUE;
- sql_db_set_state(&db->api, SQL_DB_STATE_DISCONNECTED);
-
-- mysql_close(db->mysql);
-+ if (db->mysql != NULL)
-+ mysql_close(db->mysql);
-+ db->mysql = NULL;
-
- sql_connection_log_finished(_db);
- event_unref(&_db->event);
diff --git a/mail/dovecot/files/patch-src_plugins_fts-solr_solr-connection.c b/mail/dovecot/files/patch-src_plugins_fts-solr_solr-connection.c
index 596e1cb6a6ea..ea2b3cb05c8f 100644
--- a/mail/dovecot/files/patch-src_plugins_fts-solr_solr-connection.c
+++ b/mail/dovecot/files/patch-src_plugins_fts-solr_solr-connection.c
@@ -1,9 +1,9 @@
---- src/plugins/fts-solr/solr-connection.c.orig 2019-01-02 22:12:57 UTC
+--- src/plugins/fts-solr/solr-connection.c.orig 2019-04-30 12:25:06 UTC
+++ src/plugins/fts-solr/solr-connection.c
-@@ -156,7 +156,7 @@ int solr_connection_init(const char *url,
- http_set.request_timeout_msecs = 60*1000;
+@@ -156,7 +156,7 @@ int solr_connection_init(const struct fts_solr_setting
http_set.ssl = ssl_client_set;
- http_set.debug = debug;
+ http_set.debug = solr_set->debug;
+ http_set.rawlog_dir = solr_set->rawlog_dir;
- solr_http_client = http_client_init(&http_set);
+ solr_http_client = http_client_init_private(&http_set);
}